Jump to content

Recommended Posts

Just trying out new beta, noticed that the long press does not bring up a menu where you can deselect, copy, cut, etc.   Tried it with both Apple core and Serif.   Double tap and triple tap work as they are supposed to.  Does this feature need to be turned on.

Share this post


Link to post
Share on other sites
2 hours ago, p_mac said:

Does this feature need to be turned on.

Looks like it does.


IPad Pro 10.5/512GB   lpadOS 14.3 Apple Pencil (1st gen), Affinity Photo 1.8.6.198,  Affinity Photo beta1.9.0.211, Affinity Design 1.8.6.1, Affinity Designer beta 1.9.10, waiting for Publisher for iPad

Share this post


Link to post
Share on other sites

Long-press works for me. Somewhat counterintuitively the menu doesn’t appear until I lift my finger, but I see the same behaviour in the retail version.


Alfred online2long.gif
Affinity Designer/Photo/Publisher for Windows • Windows 10 Home (4th gen Core i3 CPU)
Affinity Photo for iPad 1.8.6 • Designer for iPad 1.8.6 • iPadOS 14.3 (iPad Air 2)

Share this post


Link to post
Share on other sites
39 minutes ago, Alfred said:

Long-press works for me. Somewhat counterintuitively the menu doesn’t appear until I lift my finger, but I see the same behaviour in the retail version.

Not working for me, (I always had to lift finger too before menu appeared, but yes a little counterintuitive ). Now it doesn’t appear at all. ☹️


IPad Pro 10.5/512GB   lpadOS 14.3 Apple Pencil (1st gen), Affinity Photo 1.8.6.198,  Affinity Photo beta1.9.0.211, Affinity Design 1.8.6.1, Affinity Designer beta 1.9.10, waiting for Publisher for iPad

Share this post


Link to post
Share on other sites
40 minutes ago, Chris B said:

Working for me. The long-press won't work if the menu is already there when pressing in another area. I see no difference between retail and beta:35_thinking:

Working in Retail but not beta. Depends on tool selected!

EDIT. Menu does appear when Move tool is active but in Retail the selected tool does not matter. Also menu options differ between retail and beta. The beta is preferable.

BF4365B2-336A-4F83-A9D8-CAE8F581A363.jpeg

EDB11384-05F2-4FBA-8257-9203404DE5ED.jpeg


IPad Pro 10.5/512GB   lpadOS 14.3 Apple Pencil (1st gen), Affinity Photo 1.8.6.198,  Affinity Photo beta1.9.0.211, Affinity Design 1.8.6.1, Affinity Designer beta 1.9.10, waiting for Publisher for iPad

Share this post


Link to post
Share on other sites

In the beta version it works only with certain tools. And yes, the menu should pop up before you remove your finger, the way it's working right now makes it weird.


-- Window 10 - 32 gb - Intel I7 - 8700 - NVIDIA GeForce GTX 1060
-- iPad 2020 - 12,9 - 256 gb - Apple Pencil 2 -- iPad 6th gen 128 gb - Apple Pencil 1

Share this post


Link to post
Share on other sites
1 hour ago, AlainP said:

And yes, the menu should pop up before you remove your finger, the way it's working right now makes it weird.

Is necessary in order to identify long press from tap or drawing a line or stroke. May be iOS limitation?


IPad Pro 10.5/512GB   lpadOS 14.3 Apple Pencil (1st gen), Affinity Photo 1.8.6.198,  Affinity Photo beta1.9.0.211, Affinity Design 1.8.6.1, Affinity Designer beta 1.9.10, waiting for Publisher for iPad

Share this post


Link to post
Share on other sites
3 hours ago, pruus said:

You first have te get  back from selection to Photo, then the long press works.

No, long press will work in Selection persona. This issue is related to the Tool selected not the Persona. In attached image you can see long press menu in ‘Selection' persona but to have it appear you need to have the 'Move' tool active. In the release version the pop up menu appears regardless of which tool is active.🙂

186984B6-1B71-455D-9BFC-57BBF55D6D41.jpeg


IPad Pro 10.5/512GB   lpadOS 14.3 Apple Pencil (1st gen), Affinity Photo 1.8.6.198,  Affinity Photo beta1.9.0.211, Affinity Design 1.8.6.1, Affinity Designer beta 1.9.10, waiting for Publisher for iPad

Share this post


Link to post
Share on other sites

Adding my voice to this. Was using the beta for some non critical work and really found this a chore. Hopefully fixed soon or presumably for the full release. 

Share this post


Link to post
Share on other sites

Please, please fix this.  I don’t consider this a bug, but  something that it seems is a deliberate change.  

Long press with the ‘Move’ tool enabled is not only inconvenient, but it has created an ability when pressing with a finger can accidentally move the active layer, as  has happened, to me anyway.

This needs to be considered.  Please put the ability to make the ‘long press’ as it was before.  One should not have to waste time to enable the move tool and/or realign a layer because it was accidentally moved in the process. 

Share this post


Link to post
Share on other sites

AP Photo beta 1.9.0.215 - RC1

Long press still requires that the ‘move tool’ be active before the pop-up menu works.

Is this going to be the status quo?

please please fix this.  

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.