Jump to content
tsc07

Wie installiere ich das CH-Wörterbuch korrekt auf einem Windows 10 PC?

Recommended Posts

Ich habe seit wenigen Tagen Affinity Publisher auf einem Windows 10 PC im Einsatz.

Ich habe in verschiedenen Beiträgen versucht herauszufinden, wie ich die Rechtschreibkorrektur für Schweizerdeutsch korrekt installieren und in Betrieb nehmen muss, aber jetzt gebe ich mich geschlagen.

Ich habe bereits die entsprechenden Files runtergeladen, ich habe mich nach diesem Artikel hier gerichtet:

https://forum.affinity.serif.com/index.php?/topic/98911-faq-how-do-i-add-additional-dictionaries-to-affinity-publisher/

Von dort aus bin ich weiter auf diesen angegebenen Link, um die entsprechenden Files zu finden:

https://github.com/LibreOffice/dictionaries/tree/master/de

Diese Files habe auf meinem Windows PC in diesem Verzeichnis abgelegt, direkt via Download aus dem github-Verzeichnis.

  • C:\ProgramData\Affinity\Common\1.0\Dictionaries\de-CH

Im Affinity Publisher habe ich nun unter "Bearbeiten => Einstellungen => Werkzeuge" den Pfad für "Zusätzliche Wörterbuchordner" über die Funktion "Durchsucher" auf den eben genannten Ordner eingestellt.

Auf diese Art meldet mir AP immer noch "Fehlendes Wörterbuch für Sprache (de-CH)".

Ich habe dann alle möglichen Schreibweisen der 4 Files probiert, nach diversen Beiträgen in den Foren (Unterstrich/Bindestrich, mit/ohne frami, ...), nutzt alles nix.

Ich erhalten auch nie eine Auswahl unter der Sprach-Option fü reine Textbox "Rechtschreibung" für "Deutsch (Schweiz)", diese Einstellung ist immer auf "Unbekannt (de-CH)".

Gibt es irgendwo im Universum irgend jemand, der mir sagen kann, was ich machen muss und wie ich vorgehen muss?

Das wäre super, vielen Dank

Thomas

Share this post


Link to post
Share on other sites

Vielen Dank für deinen Feedback.

Ich bin leider erst in 3 Wochen wieder an dem entsprechenden Rechner und werde es erst dann testen können.

  • Aber so wie ich das verstanden habe, muss ich die Files nicht umbenennen - korrekt?
  • Und der Ordnerpfad von oben " C:\ProgramData\Affinity\Common\1.0\Dictionaries\de-CH" ist ebenfalls richtig - korrekt?

LG, Thomas

Share this post


Link to post
Share on other sites
On 9/10/2020 at 9:29 AM, DWright said:

Hi @tsc07,

Willkommen im Forum

Bitte entpacken Sie den angehängten Ordner und legen Sie ihn in Ihrem Publisher-Wörterbuchordner ab. Starten Sie Publisher neu. Das Schweizer Wörterbuch ist dann verfügbar

de-CH.zip 1.46 MB · 1 download

Ich bin jetzt wieder zu Hause, dass hat noch nicht funktioniert.

Was ich gemacht habe:

  • In Affinity ist dieser Ordner unter den Einstellungen als Ablage für die Dictionaries definiert: C:\ProgramData\Affinity\Common\1.0\Dictionaries\
  • In diesen Ordner habe ich einen Unterordner de-CH (also mit Bindestrich) erstellt: C:\ProgramData\Affinity\Common\1.0\Dictionaries\de-CH
  • Da habe ich die Files aus dem ZIP abgelegt, d.h. 2 Ordner (_MACOSX unhd de-CH) mit den entsprechenden Files

Hat nicht funktioniert, deshalb habe ich noch folgende Varianten ausprobiert:

  • Ich habe die Files aus dem ZIP-Ordner de-CH direkt in C:\ProgramData\Affinity\Common\1.0\Dictionaries\de-CH abgelegt (also ohne einen zweiten Unterordner de-CH zu erstellen)
  • Ich habe die beiden Ordne mit Files aus dem ZIP direkt in C:\ProgramData\Affinity\Common\1.0\Dictionaries\ abgelegt

Hat alles nicht funkioniert.

Kannst du mir bitte sagen, wie die Ordner-/Filestruktur am Ende aussehen muss? So in der Art wie hier:

C:\ProgramData\Affinity\Common\1.0\Dictionaries\de-CH
C:\ProgramData\Affinity\Common\1.0\Dictionaries\de-CH\de-CH
C:\ProgramData\Affinity\Common\1.0\Dictionaries\de-CH\de-CH\de_CH_frami.aff.webarchive
C:\ProgramData\Affinity\Common\1.0\Dictionaries\de-CH\de-CH\de_CH_frami.dic
C:\ProgramData\Affinity\Common\1.0\Dictionaries\de-CH\de-CH\hyph_de_CH.dic
C:\ProgramData\Affinity\Common\1.0\Dictionaries\de-CH\MACOSX
C:\ProgramData\Affinity\Common\1.0\Dictionaries\de-CH\MACOSX\ ... usw.

Das würde bestimmt einige Unklarheiten beseitigen.

Vielen Dank für eine Rückmeldung

Thomas

Share this post


Link to post
Share on other sites

image.png.0004772666c01309753bbfd00eb1af12.png

Unzip this file (the ones in your first post, and the ones from @DWright, were downloaded incorrectly, I believe):
de-CH.zip


-- Walt

Windows 10 Home, version 2004 (19041.388),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop:  8GB memory, Intel Core i7-3625QM @ 2.30GHz, Intel HD Graphics 4000 or NVIDIA GeForce GT 630M
Affinity Photo 1.9.1.979 and 1.9.2.997 Beta   / Affinity Designer 1.9.1.979 and 1.9.2.997 Beta  / Affinity Publisher 1.9.1.979 and 1.9.1.979 Beta

Share this post


Link to post
Share on other sites

Hallo @tsc07,

öffne die entpackte Datei und nenne die Datei  de_CH_frami.aff.webarchive, in de_CH_frami.aff  um.

Kopiere die  Datein  " de_CH_frami.aff ;  d  e_CH_frami.dic ;    hyph_de_CH.dic " in den Ordner C:\ProgramData\Affinity\Common\1.0\Dictionaries\de-CH

ich hoffe das hilft.

 

Cheers
 

 

 


Affinity Photo 1.9.1.979:   Affinity Photo-Beta 1.9.2.997:    Affinity Designer 1.9.1.979:  Affinity Designer-Beta 1.9.2.997:

Affinity Publisher 1.9.1.979:  Affinity Publisher-Beta 1.9.0.979:    

Windows 10 Pro  (Version  20H2 Build 19042.844)

 

Share this post


Link to post
Share on other sites
44 minutes ago, Gnobelix said:

öffne die entpackte Datei und nenne die Datei  de_CH_frami.aff.webarchive, in de_CH_frami.aff  um.

I do not think that will help. The file is the wrong format; some kind of archive rather than plain text. The other files provided by @DWright have the correct names, but also have the wrong format.


-- Walt

Windows 10 Home, version 2004 (19041.388),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop:  8GB memory, Intel Core i7-3625QM @ 2.30GHz, Intel HD Graphics 4000 or NVIDIA GeForce GT 630M
Affinity Photo 1.9.1.979 and 1.9.2.997 Beta   / Affinity Designer 1.9.1.979 and 1.9.2.997 Beta  / Affinity Publisher 1.9.1.979 and 1.9.1.979 Beta

Share this post


Link to post
Share on other sites

Hello @walt.farrell,

you are probably right in your assumption that the file is in the wrong format.
I can select the de_CH dictionary, but it has no content, for whatever reason.
Adobe uses dictionaries in the same format as Affinity.
I extracted the Adobe dictionary (de_CH) and copied it into the Affinity directory Common, this also without success.

 

 

Cheers


Affinity Photo 1.9.1.979:   Affinity Photo-Beta 1.9.2.997:    Affinity Designer 1.9.1.979:  Affinity Designer-Beta 1.9.2.997:

Affinity Publisher 1.9.1.979:  Affinity Publisher-Beta 1.9.0.979:    

Windows 10 Pro  (Version  20H2 Build 19042.844)

 

Share this post


Link to post
Share on other sites

Seems to be a serious problem for an easy task.

Is there nobody in the world using the Swiss dictionary who can send me the correct files?

Cheers, Thomas

Share this post


Link to post
Share on other sites

Unzip the attached file. Open the folder de_CH. Inside this folder there is maybe another folder called de_CH. Copy this (last) de_CH folder (with 3 files inside) to C:\ProgramData\Affinity\Common\1.0\Dictionaries (this is correct directory for additional dictionaries unless you changed the path). After copying, restart APublisher.

I tested this and it works.

Serif should really think about an easier way adding dictionaries. As this URL (https://github.com/LibreOffice/dictionaries) is recommended for additional dictionaries it shouldn't be too hard to install (as an Affinity function) from this place?

de_CH.zip

Edited by Joachim_L
Forgot some information.

------
Windows 10 | i5-8500 CPU | Intel UHD 630 Graphics | 8 GB RAM | Latest Retail and Beta versions of complete Affinity range installed

Share this post


Link to post
Share on other sites
1 hour ago, tsc07 said:

Is there nobody in the world using the Swiss dictionary who can send me the correct files?

I provided them in my post above.


-- Walt

Windows 10 Home, version 2004 (19041.388),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop:  8GB memory, Intel Core i7-3625QM @ 2.30GHz, Intel HD Graphics 4000 or NVIDIA GeForce GT 630M
Affinity Photo 1.9.1.979 and 1.9.2.997 Beta   / Affinity Designer 1.9.1.979 and 1.9.2.997 Beta  / Affinity Publisher 1.9.1.979 and 1.9.1.979 Beta

Share this post


Link to post
Share on other sites

For Windows the folder has to be de_CH and not de-CH.


------
Windows 10 | i5-8500 CPU | Intel UHD 630 Graphics | 8 GB RAM | Latest Retail and Beta versions of complete Affinity range installed

Share this post


Link to post
Share on other sites
14 minutes ago, Joachim_L said:

For Windows the folder has to be de_CH and not de-CH.

The setup I showed in my post, with the folder named de-CH, worked for me, with the .zip file I provided.

(I remain confused, though, why for some languages the folder name needs to use the - and for others it needs to use the _ character.)


-- Walt

Windows 10 Home, version 2004 (19041.388),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop:  8GB memory, Intel Core i7-3625QM @ 2.30GHz, Intel HD Graphics 4000 or NVIDIA GeForce GT 630M
Affinity Photo 1.9.1.979 and 1.9.2.997 Beta   / Affinity Designer 1.9.1.979 and 1.9.2.997 Beta  / Affinity Publisher 1.9.1.979 and 1.9.1.979 Beta

Share this post


Link to post
Share on other sites
Quote

Windows

You can add additional dictionaries and hyphenation dictionaries by going to Edit > Preferences > Tools. The default location is C:\ProgramData\Affinity\Common\1.0\Dictionaries\ but you can change this location by clicking Browse... This location is were additional dictionaries needs to copied to. You can click Open... to open the location to copy the files. You will need to create a subfolder with a name in the format of xx_XX ( substituting xx_XX for the locale id ). You will need to copy your xx_XX.dic, xx_XX.aff and hyph_xx_XX.dic files to the subfolder. Now restart Affinity Publisher for the dictionaries to appear within the app.

Please note: Any changes to dictionaries require that you restart Affinity Publisher

Strange. Definitely room for improvement here for Serif.


------
Windows 10 | i5-8500 CPU | Intel UHD 630 Graphics | 8 GB RAM | Latest Retail and Beta versions of complete Affinity range installed

Share this post


Link to post
Share on other sites

You're welcome :)


-- Walt

Windows 10 Home, version 2004 (19041.388),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop:  8GB memory, Intel Core i7-3625QM @ 2.30GHz, Intel HD Graphics 4000 or NVIDIA GeForce GT 630M
Affinity Photo 1.9.1.979 and 1.9.2.997 Beta   / Affinity Designer 1.9.1.979 and 1.9.2.997 Beta  / Affinity Publisher 1.9.1.979 and 1.9.1.979 Beta

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.