Jump to content

Crop Tool Issue


Recommended Posts

I was asked by a friend to crop a phone photo down to passport size. I opened up the image, selected the Crop Tool, switched to Resample, set the DPI to 300dpi and the units to Centimetres. Passport photos are 3.5cm by 4.5cm so I tried to add those numbers, but the crop went really weird, it changes my inputs to crazy numbers. I couldn't get it work no matter what I did. In the end I made a new document 3.5cm by 4.5cm at 300dpi and brought the photo in and resized it with the document. Then exported it.

In the attached JPEG the top image is a new document 3.5 x 4.5 cm @ 300dpi. The second image is when I activated the Crop Tool. The third when I set it to Resample the dpi to 300, units to Centimetres. When I try to add 3.5 and 4.5 to the boxes Affinty Photo instead just makes them 62775.13cm and 413.39cm. At first I thought I was doing something wrong, but this seems to be a bug. I have tried this on my laptop and desktop machines, which both run Windows 10 Home, same results!

Crop Box Issues.jpg

Link to comment
Share on other sites

  • 1 year later...

Hello,

I've found out probably "buggy" behaviour of crop tool in Affinity Photo (ver. 1.10.5.1342 / win 10 Pro).

In this video 

in time 4:33 is nicely explained how to crop and resample the image at the same time. I tried to mimic this procedure in latest version of Affinity photo and results doesn't correspond with video example, nor to expected behaviour of  this tool, please find attached screen record.

Is it really BUG or I do something wrong?

Mikulas

Link to comment
Share on other sites

Hi, @Mikulas and welcome to the forums.

I can confirm that. If you use imperial messurement everything works fine, but if you use the metric system the value is multiplied. However, the resolution ratio is divided by the same factor.

AMD Ryzen 5 5600G | 32 GB DDR4 3200MHz | Sapphire RX 5600 XT 6 GB | Windows 11 Pro (22H2 Build 22621.436)
Affinity Suite V1.10.5.1342
Better translations with: https://www.deepl.com/translator  
SVG preview in Windows Explorer with "SVG-See  Download SVG-See

Those who want to achieve something are looking for solutions,
the others always see only the problem.

Link to comment
Share on other sites

In my case nor imperial units don't solve the problem.

The only option is to use as first: Document / Resize document / switch off "Resample" checkbox / set DPI / Save (Resize) and then use Crop tool / resample mode / set the units / set the required dimensions.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.