Jump to content

Recommended Posts

I was just wondering does AD and AP need to run on a specific resolution? My PC is running 1920x1080 165Hz in a repeating pattern using Symbols I get white lines in my project, but when I export the project the white lines disappear. How do I fix this, so I'm not freaked out thinking I messed something up in my project?

 

Exported_Project.png

 

Inside Affinity Designer I see this.

Capture.PNG

 

Share this post


Link to post
Share on other sites
1 hour ago, Mark Ingram said:

The resolution shouldn't be an issue - what display scale have you got set (in Windows)?

Changing the scaling in the Nvidia control panel does absolutely nothing. Windows display scale is set to 100%.

Share this post


Link to post
Share on other sites

Hi crayons,
Set the document units to pixels temporarily, and check the X,Y coordinates for the symbol's layers in the Transform panel. Are they integer values? You may have to go to Affinity Preferences, User Interface tab, Decimal Places for Unit Types section and change the Pixels value to 2 or more so you can see more decimal places in the Transform panel (and elsewhere), then delete the decimal parts in the X, Y coordinates fields. If the layers/symbols are properly pixel aligned (integer values) these lines shouldn't appear at 100%, 200% zoom levels etc (still may appear at arbitrary zoom levels).

Share this post


Link to post
Share on other sites

Hi crayons,
All symbols are correctly aligned and the lines do disappear at 100%, 200% zoom etc for me. At arbitrary zoom values they will appear/vary depending on the zoom level due to the way we render things on screen (i agree it can be a bit disconcerting in particular on this file where the symbols are all black and the background it white). The only thing i can suggest is to put a black rectangle on the bottom of the layer's stack in the artboard 2.
Have you checked the file at 100% zoom - does the lines appear for you when the zoom level is set to 100%?

Share this post


Link to post
Share on other sites

The background colour suggestion was to help disguise the lines when possible/applicable (in the case of the black symbols). In the case above set the background to the same green as the symbols. If it's different from the symbols themselves (contrasty) then you will still see the lines at arbitrary zoom levels. I've just checked your file on a Windows 10 system (1920x1080) and the file does display correctly at for me 100%, 200% etc (no lines). At arbitrary zoom levels (126% for example) it does display the lines but that's expected and a side effect of the ender engine. You are not the first user reporting these issues but changes/improvements here are complex and may take a while (if possible).

Share this post


Link to post
Share on other sites
9 minutes ago, MEB said:

 At arbitrary zoom levels (126% for example) it does display the lines but that's expected and a side effect of the ender engine.

The top photo in my last post was at 100% zoom. View > Zoom > 100%, I select each one up to 800%

Nvidia Geforce GTX 560 Ti

Edited by crayons
my system

Share this post


Link to post
Share on other sites

Hi crayons,
Can you attach the file shown in your last screenshot please? I'm still convinced this is side effect of the rendering engine. I'm a bit perplexed you are seeing these lines at 100%. If you press CTRL+1 (to set the zoom to 100% as well) do you still see them? Maybe i'm missing something here, unfortunately i don't have another Windows system available to try to replicate this. Thanks.

Share this post


Link to post
Share on other sites
2 hours ago, crayons said:

The top photo in my last post was at 100% zoom. View > Zoom > 100%, I select each one up to 800%

In Designer and Publisher, 100% zoom when document units is physical (such as inches) is a different scaling of the view than when document units is pixels.

Either switch units to pixels and then try 100%, or use Zoom > Pixel Size (ctrl+9) with any document units.

(Mac users with Retina screens will find that using Metal results in Zoom > Pixel Size incorrectly producing 200% of pixel size, whereas using OpenGL correctly produces 100% of pixel size.)

Share this post


Link to post
Share on other sites

Hi @crayons,
Did you set the document units to pixels temporarily to check this? If you are still checking the document with the units set to inches when you set the zoom to 100% then you will still see the lines. If that's the case changing to pixels and checking at 100%zoom (or 200% etc) should fix the issue or as @anon2 suggested above go to menu View > Zoom > Pixel Size if you still have the document set to inches. Can you confirm that was the case please?

Share this post


Link to post
Share on other sites
21 minutes ago, MEB said:

Hi @crayons,
I advised to set the document to pixels temporarily to check this. If you are still checking the document with the units set to inches when you set the zoom to 100% then you will still see the lines. If that's the case changing to pixels and checking at 100%zoom (or 200% etc) should fix the issue or as @anon2 suggested above go to menu View > Zoom > Pixel Size if you still have the document set to inches. Can you confirm that was the case please?

Okay thank you for your time, Be Safe and Have a Great Day, Bye for now.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.