Jump to content

Recommended Posts

Create an asset that included two shape elements, 3 png, and 6 text elements. It worked fine for awhile, but I think after this most recent update they are behaving very oddly and completely breaking. Review the video and you will see it seems to occur after copying. Something not captured in the video is that it seems to permanently break the original asset in the system as well. The individual elements are flying all over the page.

Share this post


Link to post
Share on other sites

This asset behaves strange indeed, and different to me than in OP's screencast.

1. After I placed it first + copy/pasting + moving the copy, then the icons moved only horizontally but quite far, ~ 8-10 x the width of the initial group.
2. I deleted both groups.
3. Now, when adding the asset again, it appears under the dragging cursor already as destructed and gets placed like this after mouse release:

1765029710_assetplacedagain.jpg.0a0e5a136c1933656a69870954d4d97c.jpg

thothsscribe,
– In which app were the assets created?
– Were symbols involved at any stage?


macOS 10.14.6, Macbook Pro Retina 15" + Eizo 24", Affinity in Separated Mode (documents merged)

Share this post


Link to post
Share on other sites
On 8/9/2020 at 4:27 AM, thothsscribe said:

I think after this most recent update they are behaving very oddly and completely breaking

@Jon P in the recent days various issues with scaling and/or bounding box size issues seem to be reported. Would it be possible there is a general issue in v184 which didn't exist in v183 and therefore might get solved kind of 'easily'?


macOS 10.14.6, Macbook Pro Retina 15" + Eizo 24", Affinity in Separated Mode (documents merged)

Share this post


Link to post
Share on other sites
3 hours ago, thomaso said:

– In which app were the assets created?
– Were symbols involved at any stage?

Everything was created in Publisher. The icons were exported from Figma but all the text and rectangles were in Publisher.

I don't believe I used symbols at any stage. Not entirely sure what they are in Publisher.

Share this post


Link to post
Share on other sites

Odd that only this group is affected but not the various other assets which use the icons, too.
– Do you still have the "original" file where you setup the layout and colours for the assets?
– Were the assets downloaded from Figma as vectors, or as pixels as used in the assets?

It seems APub affects this asset not continously in the same way but differently with each new use.
The process/behaviour seems to get reset by deleting the Asset Category + importing it again.
In the first video I drag/copy this asset on page, in the second I place the asset in a new .afpup (after its use as shown the first video), the icons show as vertical stripes only.

 


macOS 10.14.6, Macbook Pro Retina 15" + Eizo 24", Affinity in Separated Mode (documents merged)

Share this post


Link to post
Share on other sites

I have not seen the lines issue yet. Maybe there is some link broken when importing the asset into a new file?

 

I am trying to recall exactly, but I believe the icon assets were imported as SVG from Figma and then at some point I rasterized them because apparently you can't make a Pub asset that contains svg. The other colored assets are older versions on an earlier iteration, but ultimately still make in the same process as this one as far as I recall.

Share this post


Link to post
Share on other sites
1 hour ago, thothsscribe said:

I have not seen the lines issue yet. Maybe there is some link broken when importing the asset into a new file?

No, there is no link in the asset, also the stripes don't occur on every use of the asset. The stripes are rather a render issue. Their seem to be conflicts for APub to handle various sizes, dimensions and bounding boxes of the group's items correctly, in particular of this pixel icons in relation to each other and to the group.

I wonder if the group was someway corrupted already before it got copied to the Asset Panel, that's why I asked you for the initial layout document.


macOS 10.14.6, Macbook Pro Retina 15" + Eizo 24", Affinity in Separated Mode (documents merged)

Share this post


Link to post
Share on other sites
Quote

Would it be possible there is a general issue in v184 which didn't exist in v183 and therefore might get solved kind of 'easily'?

Not that i'm currently aware of.

It would be useful if we had the original document, but there's definitely something wrong with these assets. I'll pass them on to development to see if we can see how they might have got like this


Serif Europe Ltd. - www.serif.com

Share this post


Link to post
Share on other sites

I was referring to the document the assets were originally created from, if you had it. It's been passed on to development regardless, as it does seem to be a regression over 1.8.3.


Serif Europe Ltd. - www.serif.com

Share this post


Link to post
Share on other sites

sounds good. The document I did send was a cleaned up clone of the original, but I know that may not have all the necessary data to explain it. Thank you all for all of your help and suggestions. Glad to see it wasn't ENTIRELY me ;)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.