Jump to content
casey

Affinity photo won't save sometimes

Recommended Posts

I save my photos in Finder via Pathfinder. I view them in Unbound. I edit them in Affinity -- when I can. 

 

Today, I successfully chose several photos from Unbound, edited them in Affinity, and successfully saved them.

 

Two photos -- from the same camera, from the same shooting session, and both of which showed up in Unbound just fine -- could be edited, but when I went to save them I got this :

 

Save failed because the file could not be created. Please report this to Serif.

 

File::OpenUnmanaged fopen E001 [errno = 2]

 

What can be done about this? I like affinity, but I can't spend hours on a photo only to find out it won't save. 

 

 

Share this post


Link to post
Share on other sites

I have been using Affinity for about 3 weeks. So far these are the only two images that I could not save.

 

I tried skipping Unbound. Still couldn't save.

I tried turning Pathfinder off and selecting photo directly from Finder. Still no save.

 

So, I don't think it's Unbound or Pathfinder. Perhaps the files are corrupt? However, I have no problems viewing them or, as I ended up doing, editing and saving them through Pixelmator. 

Share this post


Link to post
Share on other sites

Yes, I've replicated this error several times with the two aforementioned files.  So far I've encountered this with 2 of approximately 20 images that I've worked on in Affinity. I only recently bought it. 

 

I attempted to attach the file, but apparently I can't upload RW2 files. It says I am "not permitted to upload this kind of file". That is the format I initially use almost all of the time. Once I'm in an editor, I use the editor's native file type and export to jpeg. I always start out in RAW though. But I haven't got the chance with this one and it's a RW2 file. Let me know if there is anything I can do to get around this.

Share this post


Link to post
Share on other sites

Update: I recently tried to save a jpg in Affinity and received the same error message. Clearly there is something very wrong. Can it be fixed? Should I re-download? 

Share this post


Link to post
Share on other sites

That’s interesting and confusing. I go through the same process with every photo, including the offending and non-offending files:


 


a) choose from my viewer, choose option to open in Affinity


b) in Affinity edit the photo


c) save and export the photo to a specified folder in my Finder (although I have been doing c) before b) since this problem started, as there is nothing more frustrating than working on an image and having it lost.


 


It has happened with jpeg and RAW files. This morning I have worked on several files and it happened again with a jpeg and once more with a RAW. The RAW are all stored in the same place and, for the work I have been doing the past two days, shot in the same session with the same camera. 


 


I did a test run with another batch of files and all saved just fine. 


 


It seems somewhat random. I’d say about 10% of the files I’ve worked on in Affinity had this problem. 


 


The image I sent you has now been worked on in Pixelmator, saved, and then I decided against using it, so trashed. I can’t try it again. 


 


If this can’t be figured out, I probably will favor Pixelmator for my work. I actually bought it a couple of months ago, and then when I read about Affinity, I couldn’t help but buy it too, but with some guilt seeing as I already have an adequate editor. Now, I’m very glad I have Pixelmator as a backup. 


 


I can’t really tell you more than I have already. I don’t know why you could save and I couldn’t. I don’t know why ~10% of my files from the same shooting session won’t save in Affinity, but work fine in other editors. I do know that this is very frustrating. 


Share this post


Link to post
Share on other sites

By chance, did you try Export, without Save as first step?


Cecil - North Carolina

iMac Retina 5K, 27”, 2019. 3.6 GHz Intel Core 9, 40 GB Memory DDR4, Radeon Pro 580X 8 GB. iPad Pro 10.5.

Continuous improvement is better than delayed perfection 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.