Jump to content

Duplicating Live Filter (Perlin Noise) Crash


Recommended Posts

I could not replicate this with Photo 1.8.3.641 on Windows 10.
Procedure used:
* Create new file (SVGA web preset with no background transparency);
* Create white Rectangle layer which covered the canvas;
* Add Live Noise Filter (intensity 50%) - not Perlin Noise, there is no Live Perlin Noise Filter;
* Duplicate the Rectangle layer.
Tried a few different settings and different ways to get it to crash – add a fill layer instead, duplicate the filter layer instead, use different intensity, etc. – but could not get it to crash.
Can you give us the exact – step-by-step, click-by-click – method that causes the crash?

Link to post
Share on other sites
  1. Create a new file
  2. Create a new empty layer
  3. Edit -> Fill -> Primary Color
  4. "Live Filters" from the Layer panel. Select Procedural Texture from the context menu.
  5. Set preset to Simple Perlin Noise, Close the Live Procedural Texture window
  6. Select the layer, copy/paste with CTRL+C CTRL+V
  7. Crashes %100 of the time

Ctrl+J duplicate works fine so I'm guessing it's the copy/paste that's problematic.

Link to post
Share on other sites
  • Moderators

Hi Sarper,
Thanks for your report. I'm having trouble replicating this. Both copy/paste the whole layer or just the live filter works for me. Not sure i'm missing something. Are you able to crash it again if you restart the app? Are you running any third party utilities that may interfere with copy/paste (clipboard) functions?

Link to post
Share on other sites
1 hour ago, MEB said:

Hi Sarper,
Thanks for your report. I'm having trouble replicating this. Both copy/paste the whole layer or just the live filter works for me. Not sure i'm missing something. Are you able to crash it again if you restart the app? Are you running any third party utilities that may interfere with copy/paste (clipboard) functions?

I've terminated every process and third party background services and tried, it still crashes on cut or copy every time, please see the video

Link to post
Share on other sites
  • Moderators

Hi Sarper,
I've checked the video (it's basically the same i've been doin except you are using the right-context menu to copy/paste) and have been trying to replicate the crash the same way now but without luck. I will keep trying.... Thanks for the video and support.

Link to post
Share on other sites
8 minutes ago, MEB said:

Hi Sarper,
I've checked the video (it's basically the same i've been doin except you are using the right-context menu to copy/paste) and have been trying to replicate the crash the same way now but without lick. I will keep trying.... Thanks for the video and support.

Thank you. Isn't there anything further that can be done about this like inspecting the crash report? Are there any other files I can send that would help pinpoint the problem?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.