Jump to content
Ron P.

Brush Resize & Pressure Broken When using Pen Tablet

Recommended Posts

2 hours ago, AlainP said:

I had the same problem a few days ago while I was fiddling with the Wacom Driver and Photo settings. All of a sudden I had the same problem you have. I uninstalled "completely" the Wacom app and drivers, restarted the computer and reinstalled the Wacom app (same version) and since then everything is back to normal.

Try wacom drive version 6.3.40-2 (latest)
https://www.wacom.com/en-us/support/product-support/drivers


The more restricted you put on the program, the closer you program is to idiot.

Share this post


Link to post
Share on other sites

Tried newest drivers, no change.

One thing of note, I remember that in previous versions (2-3 ago) I rarely had an issue where my pointer stopped moving and I had to take my pen away and back above the tablet. I don't get this error now, but I gat the stuck on stroke, all the time.


"I'm a lumberjack and I'm OK, I sleep all night, and I work all day..."

Share this post


Link to post
Share on other sites
12 hours ago, TEcHNOpls said:

Tried newest drivers, no change.

One thing of note, I remember that in previous versions (2-3 ago) I rarely had an issue where my pointer stopped moving and I had to take my pen away and back above the tablet. I don't get this error now, but I gat the stuck on stroke, all the time.

Could you provide a video demonstrating the problem?

Share this post


Link to post
Share on other sites

Limited tests on my end show better performance with the tablet. Seems quite smooth.


Microsoft Windows 10 Home (Build 18363)
AMD Ryzen 5 3600 @ 3600Ghz; Mobo: Asus X470-PRO
16GB DDR4 (3100Mhz)
NVIDIA GeForce GTX 1060 6GB
Monitor 1: 4K @ 150%
Monitor 2: 1080p @ 100%

WACOM Intuos4 Large; X-rite i1Display Pro; NIKON D5600 DSLR

Share this post


Link to post
Share on other sites
2 hours ago, Mark Ingram said:

For the Bamboo you'll need to use the --legacy-wintab command line option.

I did not add this to Photo and Windows Ink is not checked in the Wacom app and everything works perfectly in the latest beta.... will there be any difference if I add this to the command line of Photo?

Edit: I just tried with and without  --legacy-wintab .... since I installed the latest beta I did not add this to the command line. I checked before starting Photo and it was not there, my Wacom pen worked perfectly, pressure, zoom, size and opacity.... everything was perfect. I edited the command line and added  --legacy-wintab to it. Restarted Photo and my pen was still working very fine, so I edited the command line again and removed it. Then my pen stopped working fine, it was working like the previous version.... I now need to have this  --legacy-wintab. Does this make any sense?


Window 10 - 32 Gb - Intel I7 - 8700 - NVIDIA GeForce GTX 1060

Share this post


Link to post
Share on other sites
2 hours ago, Mark Ingram said:

Are you sure you removed the command line option from the correct shortcut? i.e. Photo beta or Photo retail? 

It was the beta .681 version. It installed without the  "--legacy-wintab" added to the shortcut. I'm sure it was working fine right after the installation. But since I added it and then removed it... it has to be there to make it work correctly with my pen. I can't explain, but as long as it works fine... I'm good with that.


Window 10 - 32 Gb - Intel I7 - 8700 - NVIDIA GeForce GTX 1060

Share this post


Link to post
Share on other sites
7 hours ago, Mark Ingram said:

Could you provide a video demonstrating the problem?

Here you go, I couldn't find any good OSD solution for my keystrokes, but you can see when it happens and hear my clicking on the keyboard. It stops once I click with my mouse.

2020-07-22_19-42-18.mkv


"I'm a lumberjack and I'm OK, I sleep all night, and I work all day..."

Share this post


Link to post
Share on other sites

Windows 10 Pro 64 bit (version 1909), Wacom Intuos Pro, driver 6.3.40-2 (Windows Ink off), APhoto 1.8.4.681

I'm going to throw in my twopen'th here.  I've been having a lot of trouble with 'stability' when it comes to holding down the pen and tapping to change brush properties - sometimes as @TEcHNOpls says I don't get de-click and keystrokes (e.g. <alt> or <ctrl>) are held, even outside of the application. However, the process is not (so far) repeatable although it does occur very frequently.  I didn't try using the mouse but unplugging and reconnecting the USB connection worked. It's a real pain.

So I tried reverting to driver 6.3.39-1 and so far (limited testing only this evening) I haven't been able to fault APhoto. Makes me wonder if the problem lies with the Wacom driver or some other (so far untried) combination of options in the Properties of the Wacom tablet.  However I note that the latest incarnation of the Wacom drivers appears to include significant new functionality.  Will be testing the older driver further.

Share this post


Link to post
Share on other sites
On 7/21/2020 at 6:39 PM, AlainP said:

Thanks, but it will not work with my CTH-470 Bamboo tablet. The latest version I can use is 5.3.5-3

Sorry @AlainP, I told you wrong here. It's only the previous Graphire model that requires the --legacy-wintab command line flag. Your tablet should work fine as it is.

Share this post


Link to post
Share on other sites

For what it's worth, I'm on driver ver 6.3.38-2 ... my model is in my signature. No problems here (so far). I've had issue(s) with Wacom drivers on Windows in the past that required a downgrade, so it's not unheard of.


Microsoft Windows 10 Home (Build 18363)
AMD Ryzen 5 3600 @ 3600Ghz; Mobo: Asus X470-PRO
16GB DDR4 (3100Mhz)
NVIDIA GeForce GTX 1060 6GB
Monitor 1: 4K @ 150%
Monitor 2: 1080p @ 100%

WACOM Intuos4 Large; X-rite i1Display Pro; NIKON D5600 DSLR

Share this post


Link to post
Share on other sites

I just wish changing size with pen was simple like say in Krita. Shift+draw on canvas. Easy. Quick. Friendly. Digital painting in Photo is getting really cool. Just make that brush resizing easier so I don't have to make macros, dig into settings of pen to set special things just for Photo. I really like the brushes, I like speed, feeling, symmetry is there... And such simple, fundamental thing as resizing is set by default to extremely weird, two buttons + key setting. My only complain really :)

Share this post


Link to post
Share on other sites
On 7/23/2020 at 3:25 AM, Mark Ingram said:

Sorry @AlainP, I told you wrong here. It's only the previous Graphire model that requires the --legacy-wintab command line flag. Your tablet should work fine as it is.

OK... after a few trials and errors latest beta version works fine with my CTH-470 tablet without the  "--legacy-wintab". In the Wacom driver "Windows Ink" is disabled. 

I noticed that assigning different functions to the pen's buttons may change the behaviour of the pen. I assigned Zoom in and Zoom out to these buttons using the "keystrokes" option and everything works fine now.


Window 10 - 32 Gb - Intel I7 - 8700 - NVIDIA GeForce GTX 1060

Share this post


Link to post
Share on other sites

@Mark Ingram Just tried the new shortcuts for the selection tools now and they work great! Thanks a lot for fixing them! 🥳

While we're still on the topic of shortcuts, I would like to ask if it would be possible to get these types of shortcuts for the Sponge Brush Tool as well for this Beta period? Currently you can only change brush size with ctrl+alt+L click like any other brush, but when you want to quickly switch between Saturate and Desaturate or toggle between HSL Saturation and Vibrance, you can't do that with modifier shortcuts and instead you have to manually click on them in the toolbar.

I think adding these shortcuts would make the current push for improved workflow shortcuts feel a bit more feature complete.

Share this post


Link to post
Share on other sites

Thanks @Frozen Death Knight. The aim of the current set of changes was to eliminate the slightly odd use of right mouse button for shortcuts as it is difficult to do with Wacom, and impossible with Surface pens. We can look at improving other shortcuts in due course (as we're in release candidate mode now) 🙂.

Share this post


Link to post
Share on other sites
20 minutes ago, Mark Ingram said:

The aim of the current set of changes was to eliminate the slightly odd use of right mouse button for shortcuts as it is difficult to do with Wacom, and impossible with Surface pens.

Also impossible on laptops like mine where the construction of the touchpad area is such that it’s impossible to press the left and right buttons at the same time. Any move away from the “slightly odd” RMB use is warmly welcomed!


Alfred online2long.gif
Affinity Designer/Photo/Publisher 1.7.3.481 • Windows 10 Home (4th gen Core i3 CPU)
Affinity Photo for iPad 1.8.3.180 • Designer for iPad 1.8.3.2 • iPadOS 13.5.1 (iPad Air 2)

Share this post


Link to post
Share on other sites

I -had- a nasty (temporary) problem after installing the 693 version.  With the Wacom the only set of brushes to work were from the basic set, simply trying to paint on a pixel layer. No other brushes worked. As a quick test I used the <L mouse> button to paint with other brushes - which worked fine - and afterwards the Wacom pen worked on all brushes. Am not sure there is there's an initialisation issue here but I can no longer reproduce it.

On a separate note, I switched from USB to Bluetooth connection today and there is noticeable response in delay APhoto such that it's each to overdo a pen movement if it is too quick.  With USB the response was instantaneous.  This may be normal so am leaving it as an observation.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.