Jump to content

Installing language and hyphenation libraries on Mac osx


Recommended Posts

I want to use Dutch hyphenation / language check in Publisher using Mac OsX Mojave, I've been searching the forum on tips, but still haven't found any solution on installing the language libraries. I've noticed there are many requests on this item, so I think Affinity should REALLY address this issue with a simple install.

Link to post
Share on other sites

Welcome to the Serif Affinity forums.

This FAQ article should help:

 

-- Walt

Windows 10 Home, version 20H2 (19042.685),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop (2021-04-06):  32GB memory, Intel Core i7-10750H @ 2.60GHz
, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU
Affinity Photo 1.9.2.1035 and 1.9.4.1048 Beta   / Affinity Designer 1.9.2.1035 and 1.9.4.1048 Beta  / Affinity Publisher 1.9.2.1035 and 1.9.2.1024 Beta

Link to post
Share on other sites
  • 5 months later...
52 minutes ago, Christian R said:

In the past it did work. But for a month ago, my dutch hyphenation doesn't work any longer, although the spelling files are in the right folders on my system. Anyone any idea? Has it anything to do with te latest update of AP?

If you're using Publisher, have you verified that all the right files are in the right directories as shown in the FAQ above?

-- Walt

Windows 10 Home, version 20H2 (19042.685),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop (2021-04-06):  32GB memory, Intel Core i7-10750H @ 2.60GHz
, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU
Affinity Photo 1.9.2.1035 and 1.9.4.1048 Beta   / Affinity Designer 1.9.2.1035 and 1.9.4.1048 Beta  / Affinity Publisher 1.9.2.1035 and 1.9.2.1024 Beta

Link to post
Share on other sites

From what I can tell that seems right, but not being a Mac user I can't verify it.

Next: can you provide a screenshot showing the Paragraph panel Spelling Language pulldown? And the Language and Hyphenation settings while the cursor is in a paragraph where you think it should be working?

And one showing the Hyphenation Language pulldown in the Character panel.

-- Walt

Windows 10 Home, version 20H2 (19042.685),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop (2021-04-06):  32GB memory, Intel Core i7-10750H @ 2.60GHz
, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU
Affinity Photo 1.9.2.1035 and 1.9.4.1048 Beta   / Affinity Designer 1.9.2.1035 and 1.9.4.1048 Beta  / Affinity Publisher 1.9.2.1035 and 1.9.2.1024 Beta

Link to post
Share on other sites
13 minutes ago, Christian R said:

In the Character panel I don't see 'Nederlands' as an option for 'Hyphenation Language'...

In my experience, Character Studio reflects what languages have been activated in the macOS system preferences for spelling. The settings below are in the macOS System PreferencesKeyboard pane, Text tab (yes, it's pretty hidden). Once you get to that Text tab, go to the Spelling: dropdown, and at the bottom of the dropdown will be Set Up…. That brings you to this screen:

653963575_ScreenShot2020-08-10at8_39_54AM.png.37f3ab2da224d65afd03b3627b27a475.png

With the settings I have above, Publisher only offers me the choice of "English" and "Français." If I check more options in that macOS spelling preference, Publisher updates accordingly.

 

Link to post
Share on other sites
4 hours ago, Christian R said:

Interesting and I see, but in Publisher it won't make any difference. (un)Marking a language, indeed is showing/hiding that language in Publisher. The problem is that when I do have set everything  to Dutch (Nederlands) the magic of hyphenation not appears...

Just a guess, but you might try renaming that nl-NL dictionary in your screenshot to nl_NL and restarting the application.

-- Walt

Windows 10 Home, version 20H2 (19042.685),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop (2021-04-06):  32GB memory, Intel Core i7-10750H @ 2.60GHz
, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU
Affinity Photo 1.9.2.1035 and 1.9.4.1048 Beta   / Affinity Designer 1.9.2.1035 and 1.9.4.1048 Beta  / Affinity Publisher 1.9.2.1035 and 1.9.2.1024 Beta

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.