Jump to content

Recommended Posts

1.8.3.641 - WIN 10 latested updates - clean new reset of PC and therefore new installation of Affinity Photo.

NVIDIA GTX 650 - newest driver 446.14

EIZO CS 2730

Also installed: Affinity Designer 1.83.641 + Affitity Publisher 1.83.641 and Capture One 13.1.0.162  (all downloaded today).

---------

Hello, I'm new to the forum and didn't really find a similar problem description on Google. Therefore I'll ask here:

When I open an image in Affinity Photo for the very first time via "File -> Open..." it often instantly crashes. When I retry with the same file at the same source there is no problem anymore.

I first thought it had something to do with the fact, that the images are on a OneDrive directory (already downloaded before), but now, on my new clean system, it also crashed 2 times with local only images. 

Now, after approx. 10-15 tries with other files and sources, it works well. But I am afraid it will happen again when I do not expect it.

I use DNG from Ricoh GR 3 and CR2 from Canon EOS 6.

Strangley enough a have the same behaviour on my iPad Air 3 with the latest Affinity Photo App when I use "Import from cloud" and open files from OneDrive.

Does anyone have an idea what can be the reason?

I have not experienced such a behaviour in version under 1.83.

Thank you very much in advanced. Best regards.

Share this post


Link to post
Share on other sites
Posted (edited)

Hello,

Update from myself: same behaviour this morning: Opened a CR2. Picture appears and shortly after that Affinity Photo closed itself without any error message.

The second opening worked well. But after I pushed "Develop", to change into the Photo Persona it instantly crashed again. That happend twice in a row. 

Affinity Photo also created a crash reports (*dmp), but I can not read it. 

Tried it with older version 1.8.2 but unfortunately it also crashes.

Edited by last-address
Tried out with older version.

Share this post


Link to post
Share on other sites

Same problem, Windows 10 v.2004 (last update), Affinity photo 1.8.3.

Crash after opening a photo and doesn't autosave my work unfortunately.

Waiting for updates

 

Aurian

Share this post


Link to post
Share on other sites

This could be related to a colour profile being broken/corrupt. 

Can you go into Windows Colour Management and disable 'Use my settings for this device' and also see if setting to sRGB works.

They can be found in:

%AppData%\Affinity\Photo\1.0\CrashReports

or 

%AppData%\Affinity\Photo\1.0 (Store)\CrashReports

 

Share this post


Link to post
Share on other sites

I forgot to mention, we have also seen the app crash on runup due to Nvidia drivers being a bit wonky... It might be worth making sure you're up to date or remove and reinstall them.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.