Jump to content

Recommended Posts

Hello, everybody.

I have a lot of performance issues in affinity photo. 

I have :
- Windows 10
- i5-4690k
- 16gb RAM
- GTX 960 4GB

I've been searching through the forums and I've seen that maybe there are some options turned on that make the software perform badly. I don't know if there is any combination of settings that will improve performance, it is very frustrating to work on affinity photo. I ALWAYS end up closing it because I can't even move a curve line smoothly.

Thank you all in advance!

Share this post


Link to post
Share on other sites

Welcome to the forums.
It might be useful, for diagnostic purposes, if you give us more details about one specific problem you are having.
For instance, you say you can’t “move a curve line smoothly”. Can you specify clearly what is happening (maybe with a video) and under which circumstances it is happening?
The more information you can give us the better we can help.

Share this post


Link to post
Share on other sites

Thanks for answering! I will try to give you all the information you need. I love AP and would love to be able to use it in my day to day life. 

I don't have many problems to tell because at the minimum I see that the performance I have can be better in photoshop, change of program. Whether it's viewing changes to a layer of settings, changing color and seeing it update by squares, when I can't move a layer smoothly or things like that.

Maybe it's because I have bad settings and it gives problems with some settings, I don't know. I understand that the performance in mac is splendid and I don't know if the problem I have is in general windows or specifically just my PC.

I have attached a video of how I'm doing and a picture of how I have my settings in the performance tab. Putting a layer under the color grading is when the performance is affected. The layer itself moves smoothly.

Once again, thanks!

affinity settings.JPG

Share this post


Link to post
Share on other sites

That does look to be a bit ‘patchy’ but, unfortunately, without being able to check with your document on my machine, I can’t tell whether what’s happening is expected or not. I would expect some performance degradation when lots of adjustments are used but the extent of the degradation would depend on a lot of things.
It’s generally quite difficult to diagnose performance problems and give solutions – if any exist – because of the sheer number of things that could be contributing to any performance loss and the amount of different combinations of settings which could be tried.
Even if I had a copy of your document I would only have one machine to try it on so I wouldn’t get much of an idea of what could be changed to make things better as I don’t have your machine with its specific setup.
As I understand the situation, performance on Macs is slightly better than on Windows – even better if Metal processing is used (in most cases) – but that can be down to various things which aren’t under our control.
Maybe someone with similar hardware, or one of the team, could give some advice.

Share this post


Link to post
Share on other sites

Running on my machine I have seldom speed problems, but I am not a specialist to judge if my machine is better than the one from Alterjorch

i5-8500 @ 3.00 GHz

8 GB RAM

Samsung 256 GB SSD

Intel UHD Graphics 630 4 GB

Share this post


Link to post
Share on other sites

Yes, I have the drivers to the latest version. And I don't have G-sync, my graphics card doesn't have this technology. The cat layer doesn't give many problems once I deactivate all the filters that it has on top but still it doesn't go completely fluid. In photoshop I also have some loss of fluidity and performance but I can work without problems.

I attach the document to see if it can help, thanks.

Tea_time.afphoto

Share this post


Link to post
Share on other sites
13 minutes ago, Alterjorch said:

Yes, I have the drivers to the latest version. And I don't have G-sync, my graphics card doesn't have this technology. The cat layer doesn't give many problems once I deactivate all the filters that it has on top but still it doesn't go completely fluid. In photoshop I also have some loss of fluidity and performance but I can work without problems.

I attach the document to see if it can help, thanks.

Tea_time.afphoto 39.95 MB · 0 downloads

The live Gradient Map Adjustment seems to be the significant degrader of performance when I try your example on my iMac.

Share this post


Link to post
Share on other sites

First of all: Thank you all for answering! I thank you all very much

As for the problem... In my pc windows if I deactivate it I don't notice any difference. It's still just as bad :/

Share this post


Link to post
Share on other sites
On 6/3/2020 at 8:16 AM, Alterjorch said:

Yes, I have the drivers to the latest version. And I don't have G-sync, my graphics card doesn't have this technology. The cat layer doesn't give many problems once I deactivate all the filters that it has on top but still it doesn't go completely fluid. In photoshop I also have some loss of fluidity and performance but I can work without problems.

I attach the document to see if it can help, thanks.

Tea_time.afphoto 39.95 MB · 2 downloads

GTX960 should have G-sync as far as I know.
Check Geforce setting to make sure.

ximg_5c3eac35d300a.png.pagespeed.gp+jp+jw+pj+ws+js+rj+rp+rw+ri+cp+md.ic.0tPkoNse9S.png

Share this post


Link to post
Share on other sites

Wow! I don't have it in my settings. I checked to see if I was missing any updates but none were missing. This confuses me >.< 

 

Does anyone in windows do perfectly well AP without problems? Does it have the same performance as in photoshop or is it just me?

nvidia panel.JPG

update check.JPG

Share this post


Link to post
Share on other sites

It seems that DELL P2418D does not support G-sync.
So G-sync is not the cause.

BTW, that square artifact happens on my machine too(though not as powerful as yours)
And when I disable adjustment layers, it doesn't happen.
It may be just too heavy.
(though CPU and GPU isn't used much so I'm not sure what's the bottleneck)

Core i5 3470
GTX 650Ti
 

Share this post


Link to post
Share on other sites

Okay, so nothing. I'm going to put AP aside and keep using photoshop. I'll keep an eye out for future program updates to see if it improves performance. Thank you all for answering!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.