Jump to content

Recommended Posts

Hi,

I am trying to export a 24 page magazine to pdf for web distribution. 

It looks fine in Publisher but one of the typefaces (VAG Rounded) reproduces in the pdf as gobbledygook, although not all the time.

I would attach screenshots of the before and after but I don't know how to, so I have attached the complete pdf file instead.  The afpub file fails to load.

Any help would be most appreciated.  Thanks.

06_June_Lineswapper.pdf

Share this post


Link to post
Share on other sites

If the magazine is made for reading only (I imagine it is), why don't you export text as curves to avoid all the problems? Usually we save text or embedd fonts into pdf while we think someone will use Find option to jump to text or for someone else to edit the text.

As goes for the screenshot I in Windows use "Lightshot" app which free and easy, offers many nice things.

export text as curves.png

Share this post


Link to post
Share on other sites

You might also want to test if not allowing subsetting in font embedding resolves the problem:

fonts_nosubsets.jpg.aefb852bb1aca891efc2a505422310e4.jpg

This might well be a problem of Affinity apps failing to encode the font properly in case the used glyphs are subsetted and if the font uses non-standard encoding. This could be the case as your version of VAG Rounded is a Type 1 font and Affinity apps fail to encode also many symbol Type 1 fonts, e.g. Zapf Dingbats (which on Windows show as empty glyphs and on macOS cause export to fail), so when this happens, the symptom usually is that the font displays correctly on screen, but shows garbage or empty spaces instead of proper glyphs when exported.

Share this post


Link to post
Share on other sites

When I open this in publisher I get no less than 10 (ten) missing font warnings. I would look at using more common fonts.

144660-cross-platform-fonts_original.png
Fonts available on both Mac OS X and Windows.


iMac 27" Late 2015 Fully Loaded, iMac 27" Mid 2011 both running High Sierra 10.13.6 - Affinity Designer/Photo & Publisher - Illustrator CC, Inkscape, Blender, Sketchup, Pepakura Designer, MTC, Pixelmator & Pixelmator Pro + more... XP-Pen Artist-22E, - iPad Pro 12.9 B|  

Affinity Help - Affinity Desktop Tutorials - Feedback - FAQ - most asked questions

Share this post


Link to post
Share on other sites

I tried to open your file with CorelDRAW and Xara which often can process PDF files that fail to open properly or at all with other apps, but both failed to open the PDF that you had attached. On the other hand, Adobe Illustrator can open (did not try each and every page), even if it reported about missing fonts, and PDF-XChange can open the file otherwise at least seeminly similarly as the PDF is shown, also showing VAG Rounded as garbarge.

I have sometimes seen this kind of behavior and those errors were memory related, so there might also be point in exporting in batches, e.g. 4 pages at a time and see if that goes well, or if there is a specific page that causes a break. 

Share this post


Link to post
Share on other sites

Hi Chaps,

Thanks very much for your responses.  I tried a separate test with each of your suggestions but unfortunately, none of them appear to work, the result is the same.

I have detached the cover from the rest of the magazine in order to conduct the test, and I now attach the afpub file and the resulting pdf, whihc may shed some light on the problem.

Any help would be much appreciated!

 

06 June cover.afpub Untitled.pdf

Edited by Jeffrey Poulter

Share this post


Link to post
Share on other sites

Ive just exported the .apub file to PDF for Print and it exported fine, so the logical question is what are your PDF export settings (screenshots please) Graphic is pixelated because it’s missing.

1714251337_ScreenShot2020-06-01at17_34_28.png.4eca17e9a262e6b6c48d4b4b25a5e956.png

1501728427_ScreenShot2020-06-01at17_43_30.png.325eba0d7db24eccd2f28e5a63f14271.png

Removed the black stroke from the bottom text.

06 June cover xx.pdf


iMac 27" Late 2015 Fully Loaded, iMac 27" Mid 2011 both running High Sierra 10.13.6 - Affinity Designer/Photo & Publisher - Illustrator CC, Inkscape, Blender, Sketchup, Pepakura Designer, MTC, Pixelmator & Pixelmator Pro + more... XP-Pen Artist-22E, - iPad Pro 12.9 B|  

Affinity Help - Affinity Desktop Tutorials - Feedback - FAQ - most asked questions

Share this post


Link to post
Share on other sites

Bad fonts can certainly cause this. I had a simple envelope job here that I set with Gill Sans Light last week. Got approval this morning and opened it up. Text was gobbledegook and had to replace the font in my font management software (FontExplorer Pro) in order to fix the problem. This was in Indesign and I actually saw the problem though in Indesign. It is strange that it views fine for you but on export it gets messed up. If it was a DRM issue with the font it would warn you about it when you try and export and then it would usually just substitute with a system font. Maybe Publisher behaves differently? Where did you get the fonts you are using?

Share this post


Link to post
Share on other sites

Hi Wonderings,

The font I'm using came with the computer.

There may be something wrong with it, though, since it will not embolden and it always used to in PagePlus.

Maybe I should uninstall it and re-install?  Jeff

 

Share this post


Link to post
Share on other sites

As far as I remember, the Bitstream version of Vag never shipped with an OS. The letters "BT" in the font name are normally associated with that company's font versions. 

Share this post


Link to post
Share on other sites
2 hours ago, Jeffrey Poulter said:

There may be something wrong with it, though, since it will not embolden and it always used to in PagePlus

PagePlus might have just allowed faux bold. VAG Rounded from Bitstream has been long included in CorelDRAW and it never came with any other styles but one. Your font might be from some old CorelDRAW version at the time the font came as Type 1 and TrueType versions (nowadays OpenType and TrueType).

I used the OpenType version from Corel with your cover and there were no problems. Sometimes these kinds of problems occur if you have the same font installed using different font technologies (e.g. if you have VAGRounded installed both as Type 1 and TrueType font)..

Share this post


Link to post
Share on other sites
2 hours ago, Jeffrey Poulter said:

Hi Wonderings,

The font I'm using came with the computer.

There may be something wrong with it, though, since it will not embolden and it always used to in PagePlus.

Maybe I should uninstall it and re-install?  Jeff

 

On windows you can use the snip tool: https://support.microsoft.com/en-us/help/13776/windows-10-use-snipping-tool-to-capture-screenshots

On Mac: https://support.apple.com/en-us/HT201361

Also: https://lifehacker.com/how-to-take-a-screenshot-or-picture-of-whats-on-your-co-5825771


iMac 27" Late 2015 Fully Loaded, iMac 27" Mid 2011 both running High Sierra 10.13.6 - Affinity Designer/Photo & Publisher - Illustrator CC, Inkscape, Blender, Sketchup, Pepakura Designer, MTC, Pixelmator & Pixelmator Pro + more... XP-Pen Artist-22E, - iPad Pro 12.9 B|  

Affinity Help - Affinity Desktop Tutorials - Feedback - FAQ - most asked questions

Share this post


Link to post
Share on other sites

Solved it!  Yay!

The problem, as one of you genii observed,  was that I had two versions of the typeface loaded.  I thought that they were the same family but wondered why they appeared separately.  So I uninstalled one family and job's a good 'un.

Thanks very much everybody for rallying round.  It is much appreciated!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.