Jump to content

New brush with texture has a low quality


Recommended Posts

Hi, 

I have create this brush in Pixel persona using a square brush and adding a texture that I have created using symbols in vector personal. I could not add an SVG as texture so I added an PNG. The problem is that is looks very pix-elated. Looks really bad. I tried to make the texture bigger, smaller, played with zoom but it still looks bad.

Do you have any idea what I should to to make it look batter?

hfgnhjm,hjjhszfhg.JPG

Link to comment
Share on other sites

Can you attach that image?

Due to the fact that Boris Johnson is now was our Prime Minister, punctuation, spelling and grammar will never be worried about ever again.  We now have far bigger problems to be worried about.

Link to comment
Share on other sites

3 minutes ago, PixelPest said:
5 minutes ago, Oval said:

Which symbol?

The brush icon in the layers panel.

If I do that it makes the bricks really big. If I resize the brush the bricks remain the same size, only the painting area is changing. If I scale it to get the bricks the size I want I get the same result.

Link to comment
Share on other sites

Hi,

I believe that the issue is the size of the actual image that you are trying to make the 'pattern'/ brush from. When you open it each area (rectangle is incredibly small). To get this kind of pattern you just need to create a valid tessellation in a rectangle...

Create a rectangle inside a symbol and build a simpler pattern in the rectangle Then use that as the repeat.This is how you can test whether the pattern repeats correctly.

I have never created a brush with an image this size...Most of my pattern brushes are only 200x200px square rectangles. For higher resolution I have created some at 400 x 400px output with a 800x800 px build (300 dpi)...but you could use 400dpi for quality...

The rectangles in the pattern are very small!

Try creating something much simpler...:) 

AD 1.10.5.1342 Beta 1.10.5.1342 RC2 | APh 1.10.5.1342 Beta 1.10.5.1342 RC2 |APu 1.10.5.1342 Beta 1.10.5.1282
OS:Windows 10 Pro 21H2 OS Build 19044.1706 + Windows Feature Experience Pack 120.2212.4170.0
Rig:AMD FX 8350 and AMD Radeon (R9 380 Series) Settings Version 21.04.01 
Radeon Settings Version 2020
20.1.03) + Wacom Intuous 4M with driver 6.3.41-1

 

 

Link to comment
Share on other sites

4 minutes ago, PixelPest said:

I don´t get it: Is it a brush (which category: Intensity/round/square/texture?) or a Symbol and why are the edges softened??

It's a square brush with the bricks pattern image used as the brush's base texture, and the base texture scaling has been changed to something other than the default 100%, which results in ugly resampling of the base texture.

Link to comment
Share on other sites

11 minutes ago, PixelPest said:

When it´s a square brush size has no influence of the pattern just the amount of painted at the same time - no?

Yes, but there is a scaling slider in the controls for the base texture, that is independent of the brush scaling.

scale.png.1e4d684c0e3d4a6414e6831331dad13b.png

Link to comment
Share on other sites

18 minutes ago, StuartRc said:

Create a rectangle inside a symbol and build a simpler pattern in the rectangle Then use that as the repeat.This is how you can test whether the pattern repeats correctly.

This is exactly what I did.

10 minutes ago, anon2 said:

the base texture scaling has been changed to something other than the default 100%

Even if I leave it at the default 100% it still doesn't look good.

Brick_brush_2.gif

Link to comment
Share on other sites

OK!
What size is the output image for the png?

Looks to be 100% for Scaling of texture..is that correct....?

1024 px +size of the mesh=very small even at 100%..going to have a play!:)

 

AD 1.10.5.1342 Beta 1.10.5.1342 RC2 | APh 1.10.5.1342 Beta 1.10.5.1342 RC2 |APu 1.10.5.1342 Beta 1.10.5.1282
OS:Windows 10 Pro 21H2 OS Build 19044.1706 + Windows Feature Experience Pack 120.2212.4170.0
Rig:AMD FX 8350 and AMD Radeon (R9 380 Series) Settings Version 21.04.01 
Radeon Settings Version 2020
20.1.03) + Wacom Intuous 4M with driver 6.3.41-1

 

 

Link to comment
Share on other sites

10 minutes ago, CodyHill said:

This is exactly what I did.

Even if I leave it at the default 100% it still doesn't look good.

Brick_brush_2.gif

 

With base texture scaling at 100%, your painted pattern now looks identical to the PNG used as the base texture.

If you want a less obviously pixelated result, you will need to work with a higher dpi document and base texture image for the brush.

Link to comment
Share on other sites

2 minutes ago, StuartRc said:

Looks to be 100% for Scaling of texture..is that correct....?

Yes

3 minutes ago, StuartRc said:

1024 px +size of the mesh=very small eve at 100%..going to have a play!:)

I tried to do it with this img witch is the same size 1024 / 1172 px but this is what happens

30 minutes ago, CodyHill said:

If I do that it makes the bricks really big. If I resize the brush the bricks remain the same size, only the painting area is changing. If I scale it to get the bricks the size I want I get the same result.

 

Link to comment
Share on other sites

11 minutes ago, anon2 said:

If you want a less obviously pixelated result, you will need to work with a higher dpi document and base texture image for the brush.

I have tried to use a 2k texture with 400 dpi and it has the same effect.

 

8 minutes ago, PixelPest said:

Can you try this simplified 2k texture set to 800% and tell if this works better?

It still looks bad but what your version did, was to get rid of that weird bleed that I have in mine textures.

simplify texture.JPG

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.