Jump to content
mactech

Update 1.8.3 Breaks Paragraph Styles

Recommended Posts

My paragraph styles stopped respecting bold and italic formatting coming in from .docx files. I have recreated the styles repeatedly with the same result.

Now, when I import text it comes in white and in all caps (which are attributes that I recently formatted some text to have). I did not save this formatting other than in the one place I wanted those attributes. When I try to change the format to my preferred style, it alters the style with a + and retains this unwanted formatting. When I tell it to "apply paragraph style and clear character styles", it changes the color back to black but leaves text in all caps. Then when I import more text, this process starts all over again.

Share this post


Link to post
Share on other sites

Welcome to the Serif Affinity forums.

It sounds like you may have saved new defaults for text. You should be able to correct that by:

  1. Creating a Text Frame.
  2. Setting the characteristics (font, font size, font color) you want
  3. Edit > Defaults > Synchronize from Selection
  4. Edit > Defaults > Save

I'm not sure why that would affect text imported from a .docx file, but with luck the above will help.


-- Walt

Windows 10 Home, version 1909 (183623.476),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop:  8GB memory, Intel Core i7-3625QM @ 2.30GHz, Intel HD Graphics 4000 or NVIDIA GeForce GT 630M
Affinity Photo 1.8.3.641 and 1.8.4.674 Beta   / Affinity Designer 1.8.3.641 and 1.8.4.674 Beta  / Affinity Publisher 1.8.3.641 and 1.8.4.663 Beta.

Share this post


Link to post
Share on other sites

Hi @mactech

Sorry for the delay in replying & welcome to the forum. I haven't been able to reproduce this. Would you be able to save and attach the afpub document and also attach the .docx file so I can take a look please?

Share this post


Link to post
Share on other sites

Attaching the afpub document. The problem is not within the word documents, as I have the problem when I am typing into a new text box. However, I am attaching one of those as well. What is also odd is that my defaults keep changing. When I change them on purpose, they don't hold. When I don't change them, the new formatting that I apply to something, carries forward as the default, and the attributes of the default that have taken hold (like all caps when I don't want it), persist after applying the style. This did not happen before the update. I now have the choice of applying the style and clearing character styles, but I lose the bold and italic formatting from the editors. Any other choice is not even close to the style that I have created. I have setup a spread of imported text for pages 12-13. Before the update it didn't matter what this text looked like. I simply selected the style without any attention to choosing a method of applying it from the Text Styles list palette. I chose the Paragraph Styles area in the toolbar area at the top of the page and chose my style (in this case Meredien). I have remade this style many times since the update and each time I would select text that contains both italics and bold and the font style would say "no changes". However, the style would only format the text Roman, and the style attributes would say "Roman" going forward. 

!VC_JULY_2020_style_test.afpub 4 BhagawatiColumn 1,148.docx

Share this post


Link to post
Share on other sites

Try setting up a basic Group style (I use the name Base for it), set the font, size, leading, justification etc you would use and then base your styles on that instead of No Style.


MacBook Pro (13-inch, Mid 2012) Mac OS 10.12.6 || Mac Pro (Late 2013) Mac OS 10.14.6

Affinity Designer 1.8.3 | Affinity Photo 1.8.3 | Affinity Publisher 1.8.3 | Affinity Designer Beta 1.8.4.2 | Affinity Photo Beta 1.8.4.183 | Affinity Publisher Beta 1.8.4.663

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.