Jump to content
KipV

Leading seems super broken, often won't change when I try to set something different

Recommended Posts

Have you checked that you don't have a Baseline Grid overriding things? Or, in the Character panel, a Leading Override?

In any case, a sample file would be very helpful, and possibly some screenshots.

 


-- Walt

Windows 10 Home, version 2004 (19041.388),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop:  8GB memory, Intel Core i7-3625QM @ 2.30GHz, Intel HD Graphics 4000 or NVIDIA GeForce GT 630M
Affinity Photo 1.8.5.703 and 1.9.0.820 Beta   / Affinity Designer 1.8.5.703 and 1.9.0.820 Beta  / Affinity Publisher 1.8.5.703 and 1.9.0.822 Beta.

Share this post


Link to post
Share on other sites

I am quite sure those things are not the issue. I have a logo which I copied over from a Designer file. If I paste it into the stable version of Publisher I can scale it to any size no problem. When I do exactly the same thing in the latest beta the logo text falls below the image symbol and the spacing between the two lines is no longer consistent. I could show an example if that would help.

Share this post


Link to post
Share on other sites

Can you show a video, including layers, character and paragraph panel?
And/or upload an .afpub where you experience this behavior?


macOS 10.14.6, Macbook Pro Retina 15" + Eizo 24", Affinity in Separated Mode (documents merged)

Share this post


Link to post
Share on other sites

Here is a simple copy and paste between designer and publisher. Notice that the logo scales perfectly fine in designer and when I switch to publisher it starts doing weird things?

Share this post


Link to post
Share on other sites

Could it be related to the vertical alignment of the text frame set to justify  +  text wrap for the graphic below?

Unfortunately video 1 + 2 aren't showing. Perhaps they will work if you delete them in your post + upload them once more. Also I'd like to see the layers, character and paragraph panels. The pages panel in video 3 seems irrelevant here. – Or just upload the file(s).


macOS 10.14.6, Macbook Pro Retina 15" + Eizo 24", Affinity in Separated Mode (documents merged)

Share this post


Link to post
Share on other sites

The other videos were just failed attempts to send the one which you already watched so you won't have to worry about that. I just couldn't figure out how to delete the failed attempts.

This screen grab should have all the panels you asked for. Looks like everything is okay to me.

Screen Shot 2020-05-21 at 1.08.32 PM.jpg

Share this post


Link to post
Share on other sites

Odd leading compared to font size. Is a baseline grid activated?

Has the text frame set overflow to visible? That way the text can appear below its frame, too, in your case partially covered by the graphic.

I can create a similar behavior when the object below has text wrap active. Your screenshot does show the text wrap setting for the selected object, the text frame. But text wrap gets assigned to those objects which should become wrapped by the text, not applied to the wrapping text.

I have no further ideas. It appears too speculative without having the file.

You can delete your uploads when you click on "Edit" below your post and there, below the text area, click on the garbage bin icon on the symbols for each upload. If you delete an upload there it also will be deleted from the text area (not vice versa).


macOS 10.14.6, Macbook Pro Retina 15" + Eizo 24", Affinity in Separated Mode (documents merged)

Share this post


Link to post
Share on other sites
1 hour ago, thomaso said:

Has the text frame set overflow to visible?

You mean so that it shows the eye next to the area where you link text boxes? Yes it show the eye.

1 hour ago, thomaso said:

I can create a similar behavior when the object below has text wrap active.

Isn't text wrap turned off? It is set to none in my screen shot. I still wonder why there are zero problems when work with it in Designer though? I would think whatever problem I had in one I would have in the other?

Share this post


Link to post
Share on other sites
28 minutes ago, KipV said:

I would think whatever problem I had in one I would have in the other?

AD and APub are different apps with different features and text options and therefore possible conflicting settings. Just recreate the objects on this page in APub and you may experience it.


macOS 10.14.6, Macbook Pro Retina 15" + Eizo 24", Affinity in Separated Mode (documents merged)

Share this post


Link to post
Share on other sites
15 hours ago, thomaso said:

AD and APub are different apps with different features and text options and therefore possible conflicting settings. Just recreate the objects on this page in APub and you may experience it.

Yes, I may have to do the workaround of just re-doing the text so that it works right. I just think something as simple as copy and paste between two apps from the same company shouldn't be difficult. If I remember right doing a copy and paste between competing graphics apps would often work quite well. I am pretty sure I copied pages from InDesign over to Quark for an example without issues.

Share this post


Link to post
Share on other sites
17 hours ago, thomaso said:

AD and APub are different apps with different features and text options and therefore possible conflicting settings.

Hello @thomaso and @KipV.

I'm afraid that's not quite true.

They are different apps but they are built on the same foundation. There shouldn't be any issues copying text between these apps.

If there is a problem this is not it.

Share this post


Link to post
Share on other sites
5 minutes ago, Seneca said:

I'm afraid that's not quite true.

I'm happy it's true in some points: e.g. different to AD only APub offers Baseline Grid and Text Wrap.

This way even objects simply copied from AD into an .afpub may "suddenly" appear different in APub – depending on the settings there.

1 hour ago, KipV said:

Yes, I may have to do the workaround of just re-doing the text so that it works right.

I did not mean to use it as workaround but to experience what may cause the unexpected behavior when scaling the text frame.

I don't get an issue with copied text from AD to APub – but I can make such an occurrence happen with certain settings in APub (– and that way not related at all to the initial creator AD).

If you are convinced there is sth broken within your .afpub why do you hesitate to upload an .afpub with these objects?


macOS 10.14.6, Macbook Pro Retina 15" + Eizo 24", Affinity in Separated Mode (documents merged)

Share this post


Link to post
Share on other sites
23 hours ago, Seneca said:

They are different apps but they are built on the same foundation. There shouldn't be any issues copying text between these apps.

Yeah, I think this is just a bug. That is what I would expect from software that is just over a year old.

22 hours ago, thomaso said:

I don't get an issue with copied text from AD to APub

This logo has gone through many different formats; was made in FreeHand, updated in Illustrator and then converted to Affinity Designer. I would bet things would be smoother had it all been made in the Affinity apps. Since Affinity is such a new suite it is expecting that lots of people are bringing work from other formats over.

 

22 hours ago, thomaso said:

I'm happy it's true in some points: e.g. different to AD only APub offers Baseline Grid and Text Wrap.

Text wrap isn't applied as you can tell from the screen shot. I don't think I have worked with Baseline Grid at all. I can't see why I would have applied either feature to a logo, those functions are usually applied to body text. Again at this point I really think it is a bug. Would be great if someone from Serif told us what they thought too. I would be happy to report a bug.

Share this post


Link to post
Share on other sites
1 hour ago, KipV said:

Yeah, I think this is just a bug. That is what I would expect from software that is just over a year old.

Until you give us the actual file (ideally, both the .afdesign and .afpub versions) as both thomaso and I have suggested, I don't think anyone will be able to verify whether it's a bug. The applications are complex enough that screenshots and videos often won't suffice.


-- Walt

Windows 10 Home, version 2004 (19041.388),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop:  8GB memory, Intel Core i7-3625QM @ 2.30GHz, Intel HD Graphics 4000 or NVIDIA GeForce GT 630M
Affinity Photo 1.8.5.703 and 1.9.0.820 Beta   / Affinity Designer 1.8.5.703 and 1.9.0.820 Beta  / Affinity Publisher 1.8.5.703 and 1.9.0.822 Beta.

Share this post


Link to post
Share on other sites
33 minutes ago, KipV said:

Text wrap isn't applied as you can tell from the screen shot.

As mentioned before your screenshot of the Text Wrap options window doesn't tell if text wrap is applied, because to cause a wrapping text it doesn't get applied to the text but to the wrapped object. Your screenshot shows the setting for the text, not for a possibly wrapped object.

38 minutes ago, KipV said:

I don't think I have worked with Baseline Grid at all.

It still sounds you aren't sure. You can check the Baseline Grid Manager to see if it's ticked when you drag-scale your objects. As Walt already pointed out an active baseline grid can cause such a behavior of 'jumping' text lines which might make you assume the "leading seems super broken".

671097161_baselinegridmanageron-off.jpg.2c556a83caf6449f958cf61792ef69e0.jpg

43 minutes ago, KipV said:

I can't see why I would have applied either feature to a logo, those functions are usually applied to body text.

Baseline Grid is not applied to objects, instead it gets activated for an entire document. It can be active with or without showing its guide lines. Also it can get deactivated for certain text frames while still working for all others in a document. And even if the grid is set to show it still can be invisible according to its zoom setting.

Here you see the "Cascade..." text frame as the worst of the samples. This is because of its set leading which is smaller than the font size as apparently in your text frame, which additionally has a leading override set. That might cause a conflict, too, especially since both your leading values appear in brackets.


macOS 10.14.6, Macbook Pro Retina 15" + Eizo 24", Affinity in Separated Mode (documents merged)

Share this post


Link to post
Share on other sites
1 hour ago, walt.farrell said:

Until you give us the actual file (ideally, both the .afdesign and .afpub versions) as both thomaso and I have suggested, I don't think anyone will be able to verify whether it's a bug. The applications are complex enough that screenshots and videos often won't suffice.

Okay here they are.

1 hour ago, thomaso said:

It still sounds you aren't sure. You can check the Baseline Grid Manager to see if it's ticked when you drag-scale your objects. As Walt already pointed out an active baseline grid can cause such a behavior of 'jumping' text lines which might make you assume the "leading seems super broken".

I think the baseline grid may be the problem. It seems like it was turned on by default? I don't think I turned it on because as you can tell from the design it isn't a layout where you need to align a great deal of body text between columns or pages. If the software turned it on by default I don't think it should.

Cascade Logo 2010 for Affinity Forum.afdesign Extractor_mailer_FINAL_for_Affinity_Forum.idml.afpub

Share this post


Link to post
Share on other sites
4 hours ago, KipV said:

I don't think I turned it on because as you can tell from the design it isn't a layout where you need to align a great deal of body text between columns or pages.

I don't understand your conclusion, because even though "you can tell from the design it isn't a layout where you need" a leading of 14,4 pt with a font size of 28,9 pt and a leading override of 28,9 pt – instead you obviously used it this way (see your screenshot above):

508307353_ScreenShot2020-05-21at1_08_32PM_ot.jpg.d4206d6fecb83736bbe948945221edda.jpg

 

I want to understand your way of thinking, which appears to me confusing: In the first reply to your topic you were asked about Baseline Grid and Leading Override. You answered "I am quite sure those things are not the issue." This sounds you did not know actually but assumed instead. – What prevented you from simply checking your setting?

Then, 11 posts later, you kind of repeated your assumption: "I don't think I have worked with Baseline Grid at all." You still are not aware of your Baseline grid setting but think instead, again without just checking it. Finally you decide "I think the baseline grid may be the problem." – Does it mean, you still  think  but don't know your setting(s)? But then, what makes you suspect a bug at all if you don't know the situation but guess it only? You even have confirmed your bug suspicion several times – while I would have expected you to check your settings instead. And then, after your thought all being possibly baseline grid related, you upload your files. Why now, where the answer was found, and not in the beginning were you were asked for it several times? Can you explain it and help me to understand?


macOS 10.14.6, Macbook Pro Retina 15" + Eizo 24", Affinity in Separated Mode (documents merged)

Share this post


Link to post
Share on other sites
1 hour ago, thomaso said:

This sounds you did not know actually but assumed instead.

Yes, I was sure there were many things I didn't know hence the reason for asking a question. If I already knew answers I wouldn't be asking questions.

1 hour ago, thomaso said:

What prevented you from simply checking your setting?

That is what we have been doing, checking settings. There was a long list of things to check so I didn't get to all of it right away. In my mind this is a simple operation so it didn't seem it would require checking ten steps. I never do all this work in other layout software.

1 hour ago, thomaso said:

In the first reply to your topic you were asked about Baseline Grid and Leading Override. You answered "I am quite sure those things are not the issue." This sounds you did not know actually but assumed instead. – What prevented you from simply checking your setting?

To repeat the same point I made above, there was no reason for me to set up a baseline grid. As you can tell it is not a book layout where I am aligning text across columns or pages. This is a simple mailer. There is no reason, that I can think of, for using a baseline grid. That is why I doubted the baseline grid would be the issue, there was no reason to use a baseline in this assignment. It turned out the baseline grid was checked. I don't know how it got checked, I don't think it's checked by default, I don't think I checked it accidentally, I don't recall this ever happening in any other page layout software. 

1 hour ago, thomaso said:

Why now, where the answer was found, and not in the beginning were you were asked for it several times?

There were a lot things to look at and write about for one. Also you asked for screenshots or videos, I don't understand why you would want all three of those things. If what you really wanted was the files to begin with then why ask for screen shots and videos when you could just check the files first hand? Why not just ask for one or the other?

Share this post


Link to post
Share on other sites

It looks like other people are having the same confusion I am having. I am gradually understanding the Publisher way even if I don't think it is clear at all. I didn't realize leading override was an override because it is not labeled like it is under spacing. I couldn't figure out why the leading wasn't working when I went somewhere else to apply it. I also agree with the author of this thread, why is character size and leading in completely different spots? It's the strangest layout.

 

Share this post


Link to post
Share on other sites

UX is not UI: The differences between the two. - Truong Lam✌ - Medium


I gave up using Designer for hobby use - a "professional" vector drawing program without actual vector features. Customers waiting for five years in vain is more than any company can ask for. Maybe if Affinity Designer 2.0 gets real and advanced vector features I can use it. Until then... I am a customer, a potential upgrader and an active observer with an opinion. Currently I am slowly finishing a project I started in Designer.

Further... give up and please hire an UX (usability designer), Serif. It is how professional software is made in this century.

Share this post


Link to post
Share on other sites

Perhaps Leading override should be called "Baseline shift" or something else, since people not used to layout apps like QXD and ID seem to confuse the 2 and not use them properly.

Share this post


Link to post
Share on other sites
10 hours ago, KipV said:

That is what we have been doing, checking settings. There was a long list of things to check so I didn't get to all of it right away. In my mind this is a simple operation so it didn't seem it would require checking ten steps. I never do all this work in other layout software.

In the first response Walt asked about only 2 (!) settings: Baseline Grid and Leading Override.
After your answer ("I am quite sure...") then you were asked for Text Wrap as the 3rd setting.

So  I can't follow when/why you talk about "checking ten steps". Each of the requested settings are just 1 click, makes 3 steps for all of them.

11 hours ago, KipV said:

there was no reason for me to set up a baseline grid.

I do see a reason (page 5, see details below). And, that's more important here, you have not only activated baseline grid but also customised it AND additionally use a saved paragraph style were the baseline grid is deativated (see below, too).

11 hours ago, KipV said:

Also you asked for screenshots or videos, I don't understand why you would want all three of those things.

Most often the text written to a question or bug report isn't really sufficient, the simple reason is, as you mention, that asking a question or describing an issue perfectly (means with all relevant aspects) would also demand to know the answer already. Therefore it is in the sake of the OP to show screenshots, videos or the affected documents. As you noted above even a screenshot can be useless if it doesn't include relevant info (compare above: text warp panel for a selected text frame and not for the relevant graphic).

So it is meant as an offer for faster help with less talking (questions > misunderstandings > answers) when you are asked for such visual input. Then even both, screenshots + files, can be useful, for instance to illustrate what the user sees and what his files includes (which may vary, e.g. if a specific UI panel is not opened or checked).

17 hours ago, KipV said:

I think the baseline grid may be the problem. It seems like it was turned on by default? I don't think I turned it on because as you can tell from the design it isn't a layout where you need to align a great deal of body text between columns or pages.

In your .afpub I see a few confusing settings, none of them done as default by the app:

1.)  Baseline Grid is active AND customised in its width (14 pt) PLUS a specific start position (36 pt). – Do you agree that this setting is no default setting, caused by the app wand without user interaction?

2.)  Text frames in your .afpub have a saved style "Basic Paragraph" applied. In the style editor it shows that the baseline grid is deactivated for this style. – Again, do you agree that Basic Paragraph is a custom, user-defined style and no app default?

1204318314_baselinegridcustomizedstyleoff2.jpg.df0c0328e86a416e534d3469e144d349.jpg

3.) The text on page 5, which also has this style assigned to ignore baseline grid, is also the layout where baseline grid can make sense since it shows two columns of text in individual frames. Weird, that in particular this frames are set by style not to use the activated baseline grid. And also strange that the grid is set to start below these text frames.

1483959327_baselinegridcustomizedstyleoff1.jpg.3f739be3cdc94bda6ef920df80d97131.jpg

 

11 hours ago, KipV said:

I didn't realize leading override was an override because it is not labeled like it is under spacing. I couldn't figure out why the leading wasn't working when I went somewhere else to apply it. (...) why is character size and leading in completely different spots?

If you consider the difference between a character, a word, a line and a paragraph you will notice that leading set in the Paragraph Panel applies to entire paragraphs. That is the normally desired use. In seldom cases one wants a modified leading for specific parts within a paragraph and without altering the leading for the entire paragraph or text frame. In that case you need a leading option affecting not the paragraph. This leading override is set in the Character Panel, together with some other options which usually are assigned to a specific text selection only but not to all text. Therefore those settings can be saved in a character style, additionally to paragraph styles. You also can understand character style as a individual modification of a paragraph style. The most used examples are text color (paragraph: black / character: red) or font weight (p: normal / ch: bold, italic etc).

The fact that Affinity users are confused by the software UI or UX can also, and especially in the case of typography, be due to a lack of knowledge. Imagine that, before DTP, the typesetter was a profession with a few years' education. The same applies to pre-press (formerly lithography and print film/plate production), which can lead to questions and confusion these days if there is a lack of knowledge at APhoto. Today even design students are often not taught how to understand software, but only in theory and terms of visual appearance. – Nowadays it is quite easy to purchase a software to do things which demanded before DTP various expensive hardware AND the knowledge because the UI was quite reduced and very different. But you should not yet expect today from the software that you can use it correctly without some specific understanding or knowledge.


macOS 10.14.6, Macbook Pro Retina 15" + Eizo 24", Affinity in Separated Mode (documents merged)

Share this post


Link to post
Share on other sites
4 hours ago, Wosven said:

Perhaps Leading override should be called "Baseline shift" or something else, since people not used to layout apps like QXD and ID seem to confuse the 2 and not use them properly.

Nope. They are two pairs of shoes:

While baseline shift does affect only selected characters within a line ...

1557460840_baselineSHIFT.jpg.23a70c65dd7288caaf57985e31406c52.jpg

... baseline override affects the entire line – but without affecting the rest of its paragraph:

1054793986_baselineOVERRIDE.jpg.aba73b85a47c6f46f722971ea9b1cfe7.jpg


macOS 10.14.6, Macbook Pro Retina 15" + Eizo 24", Affinity in Separated Mode (documents merged)

Share this post


Link to post
Share on other sites
On 5/21/2020 at 1:20 PM, KipV said:

This screen grab should have all the panels you asked for. Looks like everything is okay to me.

Looking at the files you included showed me that the Designer file has all the items for the logo but if you Group them then the text will scale along with graphics.


MacBook Pro (13-inch, Mid 2012) Mac OS 10.12.6 || Mac Pro (Late 2013) Mac OS 10.14.6

Affinity Designer 1.8.4 | Affinity Photo 1.8.4 | Affinity Publisher 1.8.4 | Affinity Designer Beta 1.9.0.2 | Affinity Photo Beta 1.9.0.199 | Affinity Publisher Beta 1.9.0.742

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.