Jump to content
Milomade

Why can't I print this file???

Recommended Posts

I've designed a set of greetings cards in affinity - all b+w outline drawings, so when printed the kids can colour them in and send them off to friends and family. All the different designs are on separate layers - all print absolutely fine.

Tonight I decided to add a rainbow design to the existing ones. Drew this out using ellipses and nothing out of the ordinary. When I go to print, it just hangs....forever! If I cancel printing I then cannot select anything in the file, can't edit, can't click on any tools or layers and simply have to shut it down.

I started again with a fresh file and re-created the design - still won't print.

I took the rainbow ellipses out. Took a while, but the rest of the design printed. So there's something about these elipses that will not print.

My greetings cards are 120mm x 240mm and I've even tried a test to print the design onto A4 paper rather than the custom size. Again if the elipses are switched off, it prints the rest of the design just fine, if the ellipses are switched on it just hangs.

I switched off my laptop and printer, restarted both, re-opened the file and the same issue occurs. My Canon printer is not low on ink and will print any other document I fire at it except this one.

Does affinity hate rainbows??

SmileBoxCardsRainbows.afdesign

Share this post


Link to post
Share on other sites
2 hours ago, Milomade said:

I've designed a set of greetings cards in affinity - all b+w outline drawings, so when printed the kids can colour them in and send them off to friends and family. All the different designs are on separate layers - all print absolutely fine.

Tonight I decided to add a rainbow design to the existing ones. Drew this out using ellipses and nothing out of the ordinary. When I go to print, it just hangs....forever! If I cancel printing I then cannot select anything in the file, can't edit, can't click on any tools or layers and simply have to shut it down.

I started again with a fresh file and re-created the design - still won't print.

I took the rainbow ellipses out. Took a while, but the rest of the design printed. So there's something about these elipses that will not print.

My greetings cards are 120mm x 240mm and I've even tried a test to print the design onto A4 paper rather than the custom size. Again if the elipses are switched off, it prints the rest of the design just fine, if the ellipses are switched on it just hangs.

I switched off my laptop and printer, restarted both, re-opened the file and the same issue occurs. My Canon printer is not low on ink and will print any other document I fire at it except this one.

Does affinity hate rainbows??

SmileBoxCardsRainbows.afdesign 45.42 kB · 1 download

Hi

Use the workaround - via pdf - from @MikeW

It is a bug in Affinity Designer. Don't pull out more hair, @Milomade and don't waste more time on it. Let Serif look at it.

🥶


I gave up using Designer for hobby use - a "professional" vector drawing program without actual vector features. Customers waiting for five years in vain is more than any company can ask for.

Maybe if Affinity Designer 2.0 gets real and advanced vector features I can it use. Until then... I am a customer, a potential upgrader and an active observer with an opinion. Currently I am slowly finishing a project I started in Designer.

Share this post


Link to post
Share on other sites

Hi Milomade,

Your cloud shape and the curves that form the rainbow all have a dash pattern of 0 0.05 0 0 - this is incredibly small and doesn't give the appearance of a dashed line. I believe it is likely sending A LOT of values to the printer as it tries to interpret all the miniscule dashes.

If you select these objects and change the Stroke Style to be a 'Solid Line Style' you will be able to print your document. How did you create the objects - do you know why they have a dashed line on them?

Share this post


Link to post
Share on other sites
2 hours ago, Sean P said:

Hi Milomade,

Your cloud shape and the curves that form the rainbow all have a dash pattern of 0 0.05 0 0 - this is incredibly small and doesn't give the appearance of a dashed line. I believe it is likely sending A LOT of values to the printer as it tries to interpret all the miniscule dashes.

If you select these objects and change the Stroke Style to be a 'Solid Line Style' you will be able to print your document. How did you create the objects - do you know why they have a dashed line on them?

Thanks for pointing this out - I hadn't noticed that at all - I'll change it to a solid line and see if that fixes it - thanks for checking.

Share this post


Link to post
Share on other sites
7 hours ago, Milomade said:

Thanks for pointing this out - I hadn't noticed that at all - I'll change it to a solid line and see if that fixes it - thanks for checking.

It was in fact visible:

image.png.f927a649e7fe46d793c3c6968dce6444.png

I wasn't thorough enough yesterday - I did see that the lines had jagged edges and rendered slowly. I believed the CPU was just running wild and the program slowing down. It was actually a good clue. Normal lines are rendered with smooth edges:

image.png.7e719c0fb6dd1a6a3a713ffdd9bb1071.png


I gave up using Designer for hobby use - a "professional" vector drawing program without actual vector features. Customers waiting for five years in vain is more than any company can ask for.

Maybe if Affinity Designer 2.0 gets real and advanced vector features I can it use. Until then... I am a customer, a potential upgrader and an active observer with an opinion. Currently I am slowly finishing a project I started in Designer.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.