Jump to content

Recommended Posts

The problems with asset panel in designer 1.8.3 are below.

1. Switching Between assets crash the software. Not always, but most of the time. When no documents are open & with document open.

2. Dragging .afassets file in the panel dosent add any assets in the panel & Sometimes makes Designer not responding. Luckily importing works.  

3. Searching asset is very slow. When I type something in the search box, it appears after 2-3 sec. Deleting a keyword after the search is also slower. Clicking on the cross button also works slowly. I'll attach the asset file.  

4. Changing assets position in the sub categories & between subcategories make Designer not responding (not always).

5. Notice 1:36 sec in the video. It glitches. 

Restarting Designer Doesn't solve the Problem.   

I use adobe xd in my UI design. Searching assets in xd is incredibly fast. Working with t

he same material icon asset is fast enough here.

Is there any limitation for assets file or category or subcategory  or file size or items in the subcategories? 

Material Icons.afassets Material_Design_Icons.afassets

Share this post


Link to post
Share on other sites
3 hours ago, Asfak Mahmud said:

Why no response there? 

Perhaps because none of the users has any thoughts on your problem, and as for Serif staff:

  1. They're very busy; and
  2. Working from home; and
  3. You posted just after normal business hours where they work.

In my experience a bug report can sometimes get a quick response from Serif, but depending on the area it's in, who is available that works on that area, and the number of issues they're already working on, it can take a few days, even a week, before a report gets to the front of the queue. But they will get to it.


-- Walt

Windows 10 Home, version 2004 (19041.388),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop:  8GB memory, Intel Core i7-3625QM @ 2.30GHz, Intel HD Graphics 4000 or NVIDIA GeForce GT 630M
Affinity Photo 1.8.4.693 and 1.8.5.703 Beta   / Affinity Designer 1.8.4.693 and 1.8.5.703 Beta  / Affinity Publisher 1.8.4.693 and 1.8.5.703 Beta.

Share this post


Link to post
Share on other sites
On 4/23/2020 at 6:12 PM, Asfak Mahmud said:

The problems with asset panel in designer 1.8.3 are below.

1. Switching Between assets crash the software. Not always, but most of the time. When no documents are open & with document open.

2. Dragging .afassets file in the panel dosent add any assets in the panel & Sometimes makes Designer not responding. Luckily importing works.  

3. Searching asset is very slow. When I type something in the search box, it appears after 2-3 sec. Deleting a keyword after the search is also slower. Clicking on the cross button also works slowly. I'll attach the asset file.  

4. Changing assets position in the sub categories & between subcategories make Designer not responding (not always).

5. Notice 1:36 sec in the video. It glitches. 

Restarting Designer Doesn't solve the Problem.   

I use adobe xd in my UI design. Searching assets in xd is incredibly fast. Working with the same material icon asset is fast enough here.

Is there any limitation for assets file or category or subcategory  or file size or items in the subcategories? 

Hi Asfak,

Sorry for the delay in responding, but we're not always able to reply to your bugs immediately. Also when reporting issues if you could get a clear video for each issue your reporting instead of putting them all in one 5 minute long video that would also help us understand the problems you're facing. If that isn't possible them a time stamp for the issues would be very useful (Like you've done for number 5).

1. Looking at your asset files they're rather large (Material Icons has around 950 objects and Material Design Icons has around 2100) - this is especially noticeable when selecting Material Design Icons. Because of the way our assets are loaded I think having a large amount of them can cause a delay whilst they are loading - this is why you're seeing the occasional not responding. However I haven't actually got them to crash.

2. Unfortunately dragging an afassets file isn't allowing them to import - I'll get this passed onto development.

3 and 4. Again this goes back to having a lot of objects in the each category - you'll notice that as the search becomes less narrower, the slower it takes to update.

5. I do occasionally get this myself when doing a screen recording - is this something that has happened when you're not screen recording?

I will pass the slowness on to development and see if any improvements can be made - it is considerably slower than the Mac!

Share this post


Link to post
Share on other sites

Thanks for your response. I understood your limitations. But I wasn’t able to work with this assets, this made me crazy and I asked for an instant response. Your supports are good although.

From next time I'll try to be more specific while reporting problems. And again, I use the same assets in adobe xd, It's fine there. How do they manage such a large amount of icons? Maybe Developers should focus in this area as it needs serious improvements.

What is the problem here You think? The numbers (2100) of the icons or the file size (mb)?

As a UI Designer, I've to work with icons everyday. And this is not even possible to split up the icon assets in more than one file. Is there any tip from you until it gets fixed?

Share this post


Link to post
Share on other sites
20 hours ago, Asfak Mahmud said:

Thanks for your response. I understood your limitations. But I wasn’t able to work with this assets, this made me crazy and I asked for an instant response. Your supports are good although.

From next time I'll try to be more specific while reporting problems. And again, I use the same assets in adobe xd, It's fine there. How do they manage such a large amount of icons? Maybe Developers should focus in this area as it needs serious improvements.

What is the problem here You think? The numbers (2100) of the icons or the file size (mb)?

As a UI Designer, I've to work with icons everyday. And this is not even possible to split up the icon assets in more than one file. Is there any tip from you until it gets fixed?

I do think there is an issue here, as it isn't a problem on Mac, so looks like improvements can be made within the Windows UI. 

Unfortunately I can't think of anything that will be a great solution right now with these assets, except if you can get a copy of them as individual SVG files and then place them from the SVG file, using Windows or a Contact Sheet to browse them. However I can understand this may not be appropriate depending on the source of the icons.

Share this post


Link to post
Share on other sites

There are hundreds of icons and I've to search them to find the right one. So It's not going to work for me. By the way, Thanks for your suggestion.

Is it going to be fixed in the upcoming update? It'll be great for me as I've to deal with assets every single day.      

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.