Jump to content
Glyphs

Can't open afpub files in Publisher

Recommended Posts

I am trying to open my afpub files after several system crashes and force-quitting Publisher several times, and even the lighter files aren't opening yet. I suppose I would have to wait a few hours for the files to finally open, because it happened before, but it's tiring. Are there preferences to reset, or something to do in Publisher to not have these problems ?

Share this post


Link to post
Share on other sites
1 minute ago, wonderings said:

What message do you get when trying to open a Publisher file in Publisher?

No message. I only read that the file is loading in the menubar. So far, I managed to load a 487 Mb file in 30 minutes, and a 1,32 Gb file in an hour. I am working on an iMac 2012 with Catalina, so it's supposed to be slow, but not that slow. The only thing peculiar that happens each time I reopen the files after a force restart of my Mac is that Catalina is verifying each file I am trying to open before it is actually handled by Publisher. So I have been wondering what Catalina is supposed to do when Publisher is trying to open a verified file with unverified embedded files in it after a restart. Since I have been trying to open a file containing a lot of linked and embedded files all day to no avail, I am now opening each embedded file separately. So far, it's very slow, but it works. Each file is verified separately, and opened in its App. Then when all the files will have been verified separately, I'll try to open the main afpub file containing all these files. Do you think the problem is somehow linked to Catalina verifying the files after a force restart?

Share this post


Link to post
Share on other sites
1 minute ago, wonderings said:

Can you open Publisher without a file, create a new blank document? Or does this loading process happen no matter what you are trying to do?

I just created a new document a few seconds after your reply while latest file was loading, so it's OK on this side. The latest file I opened is stil loading though.

Share this post


Link to post
Share on other sites

I wonder if the file is possibly corrupted after numerous crashes you had. Do you have a Time Machine backup that you can go back to and get the file before the crashes? Another option that is simple is uninstall the app and reinstall and see if the problem persists. 

Share this post


Link to post
Share on other sites
Just now, wonderings said:

I wonder if the file is possibly corrupted after numerous crashes you had. Do you have a Time Machine backup that you can go back to and get the file before the crashes? Another option that is simple is uninstall the app and reinstall and see if the problem persists. 

No, it's all the files. Even those I didn't work on at the time of the crash. Every afpub file is opening in slow motion. I did have this same problem a few days ago, and the backups were as slow to open as the other files. I'll try to reinstall Publisher as soon as my latest file is loaded.

Share this post


Link to post
Share on other sites
Just now, wonderings said:

Has it always been this way? Or this is something new?

Can you give details on your computer, specs, age, etc? Is everything else on your computer running normally?

It has been this way since the latest major update. I even sent you files I couldn't open in Designer and Publishers. You might still have it. Afterwards, there was a maintenance update for all the apps, and I managed to open the files. So maybe just reinstalling the App would do the trick. I'll try it as soon as possible.

I am working on an iMac 2012 on macOS Catalina 10.15.4 There are periods when the system is slowing everything down, not just Publisher. I have system crashes when I'm using Publisher, but since I'm using it everyday, I couldn't say if it's coming from Publisher or the system itself. It's been like that since Catalina's latest updates, and reinstalling Catalina doesn't change a thing. 

Share this post


Link to post
Share on other sites
1 hour ago, wonderings said:

Has it always been this way? Or this is something new?

Can you give details on your computer, specs, age, etc? Is everything else on your computer running normally?

Following my latest post: I have reinstalled Affinity Publisher, then tried to reopen the file I was talking about earlier, and opened it in a few seconds. I'm still at a loss as to what caused the problem, but reinstalling Publisher is the solution. Any hope to have a fix in a next update, so that I don't have to reinstall Publisher every two week?

Share this post


Link to post
Share on other sites
5 minutes ago, Glyphs said:

Following my latest post: I have reinstalled Affinity Publisher, then tried to reopen the file I was talking about earlier, and opened it in a few seconds. I'm still at a loss as to what caused the problem, but reinstalling Publisher is the solution. Any hope to have a fix in a next update, so that I don't have to reinstall Publisher every two week?

Ah, talked too fast. A few images are still blurry, and I can't select anything. It seems like everything isn't loaded in memory. I'm going to try again to load the embedded files one by one, and see where it leads me.

Share this post


Link to post
Share on other sites
6 hours ago, Glyphs said:

Ah, talked too soon. A few images are still blurry, and I can't select anything. It seems like everything isn't loaded in memory. I'm going to try again to load the embedded files one by one, and see where it leads me.

 

Share this post


Link to post
Share on other sites

OK, the problem seems to have been solved by reinstalling Publisher. A few images were blurry because I had to update their linked files in the Resources Manager. I also had to unsync my symbols because they were automatically synced again after the reinstall, but otherwise everything seems OK. I'll think about reinstalling the App the next time I have this problem. Thanks.

Share this post


Link to post
Share on other sites
On 4/23/2020 at 1:47 PM, wonderings said:

Good to hear it is resolved, hopefully you don't have the problem again. From my light use it has always been stable. 

Not quite resolved yet. I have reinstalled Publishers several times since my latest post, and it doesn't seem to solve the issue (which seems mostly a memory issue) for long. When I try to load a too heavy file for example, or a light file containing too many Affinity Publisher placed multi-page files, I have to wait for all the images of the displayed page not to be blurry before even trying to save anything, else I will have a saving progress bar without any progress for hours. I even have to wait for the blue progress bar below the title to completely load before saving anything for these same reasons. Even a message telling me I couldn't save a file before all of these processes are finished would be better. At least, this way, I would know where I'm going. Once the loading of a file is finished, I can finally work on the file, and save it (for a little while. Then, there are other slow-downs. It's a very narrow window), but it would be much better to have dialogs telling me I can't work on the file until all the processes are finished. At least, this way, I wouldn't work for nothing. Is there an update coming for these kind of problems?

Share this post


Link to post
Share on other sites
On 4/25/2020 at 2:47 PM, Glyphs said:

Not quite resolved yet. I have reinstalled Publishers several times since my latest post, and it doesn't seem to solve the issue (which seems mostly a memory issue) for long. When I try to load a too heavy file for example, or a light file containing too many Affinity Publisher placed multi-page files, I have to wait for all the images of the displayed page not to be blurry before even trying to save anything, else I will have a saving progress bar without any progress for hours. I even have to wait for the blue progress bar below the title to completely load before saving anything for these same reasons. Even a message telling me I couldn't save a file before all of these processes are finished would be better. At least, this way, I would know where I'm going. Once the loading of a file is finished, I can finally work on the file, and save it (for a little while. Then, there are other slow-downs. It's a very narrow window), but it would be much better to have dialogs telling me I can't work on the file until all the processes are finished. At least, this way, I wouldn't work for nothing. Is there an update coming for these kind of problems?

Hi Glyphs,

If you would be willing please could you try rolling back to a previous version of Mac OS to see if this improves performance?

Thanks

C


Please tag me using @ in your reply so I can be sure to respond ASAP.

Share this post


Link to post
Share on other sites
46 minutes ago, Callum said:

Hi Glyphs,

If you would be willing please could you try rolling back to a previous version of Mac OS to see if this improves performance?

Thanks

C

I'll try, as soon as I have the time. For now, I have repaired authorizations, and reset the PRAM to no avail, then I reinstalled Catalina, and everything slowed down to a stop. I finally solved the problem Catalina by cleaning everything in OnyX, but not Publisher's memory problem, which seems to happen with heavy files and complex files. What I call complex files are files containing several multipage placed .afpub files. Complex files are not very heavy, but seem to cause memory problems, which can even lead to a system crash. I am going to create versions of these files with PDFs versions of these multipage files instead, to check if the file is better manageable.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.