Jump to content
NotMyFault

AP 1.8.3.641 selection and refine mask slow/hang

Recommended Posts

Posted (edited)

Dear team,

 

after upgrading to latest release, performance issues with selections start again.

While using selection brush, flood select tool, or refine mask, Photo becomes totally sluggish and freezes many times.

Issue most severe after adding filters / adjustments above the pixel layer. I'm talking about 2 curve layers, not 10 or 100 layers.

Example file can be downloaded https://www.amazon.de/clouddrive/share/iQJ8gbNrwzgJCxGzsQaOolSRTuTpgQKiqroeS0Jr4pb

For video, see post below.

RGBA/32

Widnows 10 latest

lots of free CPU, RAM, and GPU power

Edited by NotMyFault
added link to file

Share this post


Link to post
Share on other sites
  1. Are you using the latest release version?
    yes
  2. Can you reproduce it?
    yes
  3. Does it happen for a new document? If not do you have a document you can share that shows the problem?
    https://www.amazon.de/clouddrive/share/iQJ8gbNrwzgJCxGzsQaOolSRTuTpgQKiqroeS0Jr4pb
  4. If you cannot provide a sample document then please give an accurate description of the problem for example it should include most of the following:
  •    What is your operating system and version (Windows 10, OSX Mojave, iOS 12 etc)?
    • Windows 10 1909
  •    What happened for you (and what you expected to happen)
    • there is a lag of 1-5 seconds between mouse mouse movement and visible effect
    • i expect no noticable lag, or maximum 150ms
  •    Provide a recipe for creating the problem (step-by-step what you did).
    • use sample image above
    • select lowest pixel layer
    • select "selction brush"
    • select any area, e.g. one of the beach seats
    • press left mouse button, move mouse to cover a small area, release mouse button
    • wait for Photo to make selction visible. it takes much too long
  •    Screenshots (very handy) or a screen capture/video.
  •    Any unusual hardware (like tablets or external monitors or drives that may affect things) or relevant other applications like font managers or display managers.
    • no. plain vanilla PC

      Nvidia Gforce GTX 1080

      OS Name    Microsoft Windows 10 Home
      Version    10.0.18363 Build 18363
      Other OS Description     Not Available
      OS Manufacturer    Microsoft Corporation
      System Name   
      System Manufacturer    MEDION
      System Model    ERAZER X7731 D/C485
      System Type    x64-based PC
      System SKU    ML-110000 10021768
      Processor    AMD Ryzen 7 1800X Eight-Core Processor, 3600 Mhz, 8 Core(s), 16 Logical Processor(s)
      BIOS Version/Date    American Megatrends Inc. P2A4W0X.206, 12.06.2018
      SMBIOS Version    3.0
      Embedded Controller Version    255.255
      BIOS Mode    UEFI
      BaseBoard Manufacturer    MEDION
      BaseBoard Product    P2A4-EM
      BaseBoard Version    1.0
      Platform Role    Desktop
      Secure Boot State    On
      PCR7 Configuration    Elevation Required to View
      Windows Directory    C:\WINDOWS
      System Directory    C:\WINDOWS\system32
      Boot Device    \Device\HarddiskVolume1
      Locale    Germany
      Hardware Abstraction Layer    Version = "10.0.18362.752"
      User Name   
      Time Zone    W. Europe Daylight Time
      Installed Physical Memory (RAM)    32,0 GB
      Total Physical Memory    31,9 GB
      Available Physical Memory    21,7 GB
      Total Virtual Memory    36,7 GB
      Available Virtual Memory    22,7 GB
      Page File Space    4,75 GB
      Page File    C:\pagefile.sys
      Kernel DMA Protection    Off
      Virtualization-based security    Not enabled
      Device Encryption Support    Elevation Required to View
      Hyper-V - VM Monitor Mode Extensions    Yes
      Hyper-V - Second Level Address Translation Extensions    Yes
      Hyper-V - Virtualization Enabled in Firmware    No
      Hyper-V - Data Execution Protection    Yes

       

  •    Did this same thing used to work and if so have you changed anything recently? (software or hardware)
    yes, befor upgdating Affinity Photo from older release (still 1.8.3.xxx)

Share this post


Link to post
Share on other sites

Not seeing any lagging on the document you provided.

Everything nice and smooth on my medium specification PC.

Note: The document in your video is not exactly the same as I downloaded (layers are different) but that may or most likely not be relevant. It just adds a bit of confusion.


Due to the fact that Boris Johnson is now our Prime Minister, punctuation, spelling and grammar will never be worried about ever again.  We now have far bigger problems to be worried about.

Share this post


Link to post
Share on other sites

Hi carl123,

 

the original file used in the video was quite large (>600MB), and failed to upload to this forum.

To reduce file size, i copied only the relvenat layers into a new file, and verified that the issue occurs with the smaller file. Upload failed again, so i finally switched to the amazon drive link.

I tried the same file with my iPad 2018, it is much faster vs. Windows, but still shows some slowness (below 1 second)

I observerd similar issues more than once with older Affinity Photo releases, my high end PC is by factor 10-30 slower than the iPad in many situations, e.g. when switching to tone map persona. It is way faster in all other aplications, e.g. web browsing, video editing etc.

Performance clearly depends on file size (megapixel count, color depth e.g. 8/16/32).

Share this post


Link to post
Share on other sites

I just reopened your document to have another look and I accidently had my Paint Brush selected and when I try to paint on your image I am seeing quite a lot of lag but absolutely zero lag when using the Selection Brush.

When I disable the Noise Reduction Layer and the Group Layer (containing the 2 curves adjustment) my Paint Brush lag virtually disappears.

If you disable those two items does your selection brush work normally/better?

 


Due to the fact that Boris Johnson is now our Prime Minister, punctuation, spelling and grammar will never be worried about ever again.  We now have far bigger problems to be worried about.

Share this post


Link to post
Share on other sites

Hi NotMyFault

If you disable "All layers" in the selection brush it will be quicker. The "All layers" option requires rendering the noise reduction live filter, the lab curves and the gaussian blur filter effect at full resolution for at least some of the document, which will take some time, hence the delay. You should only turn on the "All layers" option when you really need it, i.e. edges are derived from multiple layers. In your cut down document all the edges are derived from the one pixel layer, so maybe you don't need "All layers".

Regards

Justin

Share this post


Link to post
Share on other sites

Even with "All layers" unchecked in the OPs document, Photo selects more slowly than in a newly created document with only the background layer in it. But with "All alyers" checked in the original documents it takes ages to select...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.