Jump to content
You must now use your email address to sign in [click for more info] ×

publisher crashes when trying to print (pdf)


Recommended Posts

When I try to use the print  function from menu or from shortcut cmd+p, 

I first noticed this when, I open a pdf file, and then try to print it, publisher 1.8.3 crashes.  Even after saving as a publisher type file *.afpub, crashes after the file is saved as publisher type.  I have noticed this is now happening with all documents, even those created in publisher.  

The work around, I have been using is to export as a pdf, and then open in another PDF reader like Preview or Acrobat, from which I can print.  

I'd be happy to test any patches or fixes.  




iMac13,1  i7, 3.09 16 GB 500GB Samsung

MacOS 10.13.6 (17G4015) 

Publisher 1.8.3


Link to comment
Share on other sites

  • Staff

Hi @dr_d, welcome to the forums!

Does this happen even if you simply create a new blank document? 

Do you have any issues printing in any other applications?

Do you have a crash report you can attach?


Serif Europe Ltd. - www.serif.com

Link to comment
Share on other sites

  • 1 month later...


i'm experiencing the very exact same thing. i have a macbook with version 10.13.6. and pushlisher version 1.8.3. affinity is crashing when i try to print, doesn't matter if commanded with shortcut cmd+p or via the menu. it happens with "normal" documents, a4, containing textframes, frames and pictures as well as with a completely blank empty new document. i cannot tell if this is a new error and had worked before because it was my first time trying this.

i had never any issues printing in any other applications.

i don't know how to actively get a crash report, publisher didn't ask me to create one.


Link to comment
Share on other sites

I'm trying to print and the app crashes immediately before even getting to the print dialogue. It's pretty much a blank 52 page doc, one spread with some text content, that's it. I reduce the page count down to one spread, nothing else, same result. 

Running on a 2016 Macbook Pro, Mac OS 10.15.5.

Any ideas?

Link to comment
Share on other sites

I removed Affinity Publisher with AppCleaner 2.2.3; then re-installed from the AppStore (23 May 2020).  

Its working now, and there haven't been any crashes.  Not sure that it was a printer driver; after the re-install all seems to be working. 

The printer drivers were/are: 

  • Epson 1400 Sylus photo (and the same printer also with GutenPrint+Cups;
  • Epson et-2750;
  • VipRiser;
  • HP Pagewide 477DW. 

best wishes,


Edited by dr_d
Link to comment
Share on other sites

  • 2 weeks later...
  • 8 months later...

Hello I have the same problem since I switched to macOS Big Sur. It affects all three programs, Photo, Designer and Publisher. I updated to Big Sur on Friday. Over the weekend I noticed the problem. Now I have removed all three programs and reinstalled them. Unfortunately, this has not given any improvement. I work with FontExplorer X pro latest version. 
My System macOS 11.2.3 MBP 16 inch, 2,3 Ghz 8-Core Intel i9, 32 GB RAM, AMD Radeon Pro 5500 M 8GB.
The bug report is attached.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.