Jump to content
Max N

3 bugs mix brushes. (1.7, 1.8)

Recommended Posts

First - Switching layers should not restore the fill to white—when I paint, it isn't white either so this is a clear UI bug. I think this might be logged but I'm not sure. 

Second - Resetting the fills was added in 1.7 and the shortcut should be 'D' however, this was not implemented on Windows (omission) and is already logged. I'll give it a kick :) 

Third bug - The mix brush doesn’t work if the shift is held down if there is no fill. I can’t draw a straight line with an empty mix with a brush.

1237331650__2020_04_18_13_45_50_451.thumb.gif.70c7297f7218e0dcfc97b0fdc47d8dd4.gif

I'd like to tame the mix brush. She is like a arrogant horse, trying to throw off a rider. I hope it will be pacified and it will work as it should 🙂 This is one of the most popular tools for retouching after the healing brush.
 

Share this post


Link to post
Share on other sites
On 4/18/2020 at 11:55 AM, Max N said:

Third bug - The mix brush doesn’t work if the shift is held down if there is no fill. I can’t draw a straight line with an empty mix with a brush.

 

This is working for me. What am I missing? 

Share this post


Link to post
Share on other sites
56 minutes ago, Chris B said:

This is working for me. What am I missing? 

I think it’s important to make similar settings. All problems are related to empty fill. Untitled.png.aa4ab9ab7909c0670933e6dfd05dd332.png

The fill brush works correctly. A brush with a fill and a brush without a fill differently respond to pressing the Shift key.  

You can try to configure the brush completely as in the screenshot. Maybe this will help.

Share this post


Link to post
Share on other sites
1 hour ago, Max N said:

I think it’s important to make similar settings. All problems are related to empty fill. Untitled.png.aa4ab9ab7909c0670933e6dfd05dd332.png

The fill brush works correctly. A brush with a fill and a brush without a fill differently respond to pressing the Shift key.  

You can try to configure the brush completely as in the screenshot. Maybe this will help.

Try disabling Auto Load Brush to make the brush work with shift key when the fill colour is none.

Share this post


Link to post
Share on other sites
45 minutes ago, anon2 said:

Try disabling Auto Load Brush to make the brush work with shift key when the fill colour is none.

I tried it. The brush works with the shift. But I need it with the checkbox turned on.

Share this post


Link to post
Share on other sites
6 minutes ago, Max N said:

I tried it. The brush works with the shift. But I need it with the checkbox turned on.

If the checkbox is off, you can still clean the brush before every stroke by pressing C key.

Share this post


Link to post
Share on other sites
4 minutes ago, anon2 said:

If the checkbox is off, you can still clean the brush before every stroke by pressing C key.

This method is good when you need to make 2-3 movements. And when you work on the tablet, and making thousands of such movements, each time you press - for a very long time.

Share this post


Link to post
Share on other sites

Can we think of a reason why it shouldn't work with Shift when Auto Load Brush is enabled? If not I can log it. Sounds like you need it to work for you Max N so that's probably enough reason. I won't pretend to know as much as you about digital painting so I can't really argue against having this added.

Share this post


Link to post
Share on other sites
3 hours ago, Chris B said:

Can we think of a reason why it shouldn't work with Shift when Auto Load Brush is enabled? If not I can log it. Sounds like you need it to work for you Max N so that's probably enough reason. I won't pretend to know as much as you about digital painting so I can't really argue against having this added.

I'm also not good at painting. I use in retouching. Frequency decomposition, and smoothing the color layer. Works well on leather, backgrounds, metal. It is possible to smooth the color while maintaining the texture.

Share this post


Link to post
Share on other sites
1 hour ago, Max N said:

RC is already being tested, and old bugs are not fixed.

There is no promise when bugs will be fixed. That is done on the Developers' schedule, based on their prioritization of the problems and their workload.


-- Walt

Windows 10 Home, version 2004 (19041.388),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop:  8GB memory, Intel Core i7-3625QM @ 2.30GHz, Intel HD Graphics 4000 or NVIDIA GeForce GT 630M
Affinity Photo 1.8.5.703 and 1.9.0.767 Beta   / Affinity Designer 1.8.5.703 and 1.9.0.767 Beta  / Affinity Publisher 1.8.5.703 and 1.9.0.742 Beta.

Share this post


Link to post
Share on other sites
5 hours ago, walt.farrell said:

There is no promise when bugs will be fixed. That is done on the Developers' schedule, based on their prioritization of the problems and their workload.

I know. But I periodically remind about the problem. The first time I did it in version 1.7, then in 1.8, now we are approaching 1.9. I will assume that we are close to version 2.0 for which (guess) will have to pay. And there is some concern that the owners of older versions will not have time to get fixes for known errors. A paid transition from version 1.xx to version 2.xx should be motivated by the desire to get new functionality, and not by the desire to get fixes for errors in the existing functionality (which should not have been, from the user's point of view).
I understand that out of love for this program, I will switch to version 2.0. But my love for this program makes me sometimes a bore, and remind of mistakes or resort to criticism.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.