Jump to content

Affinity Photo and Raw files from Sony Nex 6


Recommended Posts

Welcome to the forums @Pandan,

I downloaded your file, and don't have any problem opening and working on it.

Is Windows up to date?

Can you describe how your trying to open the file in AP? Where is the file stored? On the same drive as your app?

Affinity Photo 1.10.5.1342 ; Affinity Photo Beta 1.10.5.1342; Affinity Designer 1.10.5.1342; Affinity Designer Beta 1.10.5.1342; Win10 Home Version:21H2, Build: 19044.1766: Intel Core i7-4770, 3.90GHz, 32GB Ram, Nvidia GTX 645, 3-Internal HDD (1 Crucial MX5000 1TB, 1-Crucial MX5000 500GB, 1-WD 1 TB), 4 External HDD

Link to comment
Share on other sites

Thank you for the quick reply.

On my  "french version" of Affinity Photo  I simply go to File/open to load an image. The raw file will appear  for a very brief moment in the "raw"   persona and then the app crashes.

Windows 10 is up to date.

My photos are stored on a different drive. I have moved some  raw photos to the drive where the app is situated . Unfortanetly this did not solve the problem.

Most of the time I use Affinity photo with a tiff or PSD file  and and then everything works fine.

I do not remember having encountered  this problem in previous versions of Affinity photo ( 1.6 and 1.7 versions, for instance).,

Maybe I should reinstall version 1.7.3 on my computer to make sure.

 

Link to comment
Share on other sites

I have finally found that when I load a Sony raw file by dragging it  to the Affinity photo icon at the bottom of my computer screen the file opens in the Develop persona  and that from then on everything works normally..

However, when I load such a file the way I described previously ( file/open ) the file still crashes either right away or when I move a slider in the Develop persona.

Many thanks to Ron P. for taking the time to download and test my file. Thanks for his comments, advice and help. Greatly appreciated

Link to comment
Share on other sites

I tested several of my Sony Nex 6 files following the sequence ( file/open) over the last few days and here are my findings :

 

1-  With a few exceptions (which surprised me), raw files crashed either right after opening up in the Develop persona or after I performed one or a few slider moves in the Develop persona;

 

2- Jpeg files opened up normally and worked fine.

 

If I moved a jpeg file from the Photo persona to the Develop persona the jpeg file worked without any problem in the Develop persona.

 

3- If I opened a raw file using the sequence ( File/ open recent) instead of my usual ( File/open) and found a reference to a raw file which had previous ly crahed in the Develop persona and clicked on it the raw file which had previously crashed then opened normally in the Develop persona and worked fine from then on.

 

4- If I right click on a raw file stored on my drive and choose to open it up in Affinity Photo it opens in the Develop persona and everything works fine.

 

5- As indicated in a previous post if I click on a raw file and drag it to the Affinity photo icon it opens normally in Affinity photo and works fine.

 

I hope these findings may shed some light.

 

Thank you for your help.

Link to comment
Share on other sites

  • Moderators

All the crashes seem to be related to your nvidia Drivers. Try this please:

Download the latest graphics drivers from the manufacturer's website
Uninstall the current graphics drivers
Reboot
Install the latest drivers
Reboot

Link to comment
Share on other sites

 

Hi Gabe,

Good news to report!

I  have followed the suggestion to change the renderer to Warp .

The suggestion was right on.

After that change I opened several raw files  and all operations  in the Develop and the Photo personas  worked fine.

 I presume the problem had to do with my graphics card?

Many thanks to you and to Ron. P. for your help.

 

Link to comment
Share on other sites

  • Moderators

WARP uses your CPU for screen rendering. This will be slower, but should work fine.

Those crash reports are all calling the nvidia driver. So, it might be a driver issue, it might be a hardware issue. 9/10 is a driver issue. Perhaps you can try to install the previous version of the graphics driver if you've not had any problems until now?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.