Jump to content
Fantomas.CZ

[1.8.3] Esc soft key not present in TouchBar (MBP) [solved, not Affinity's fault]

Recommended Posts

Hi! Yesterday, I have upgraded to Affinity Publisher 1.8.3 and saw a very serious problem: the Esc key from the TouchBar has disappeared! I have a MacBook Pro 15" 2018.

I didn't really try to document it properly, so I just know it happens in the text editing mode. Which is bad! How am I supposed to end the text editing mode and enter the move mode or any other? Had you introduced this Cmd + mouse to enter the move mode like the InDesign has, this wouldn't be that serious, but man, it is! Please fix it as soon as possible.

Thanks, have a nice day everyone and stay healthy, stay safe!

Share this post


Link to post
Share on other sites

I’m on Mojave on a 2017 Macbook Pro and I still have the Escape key on my Touch Bar in Publisher 1.8.3 and in the other Affinity apps.
Is it missing in other apps?
I know this is an old standby but have you tried restarting your Mac and see if the Touch Bar loads correctly?


macOS 10.15.7  15" Macbook Pro, 2017  |  4 Core i7 3.1GHz CPU  |  Radeon Pro 555 2GB GPU + Integrated Intel HD Graphics 630 1.536GB  |  16GB RAM  |  Wacom Intuos4 M

Share this post


Link to post
Share on other sites

Do you have the Touch Bar support ticked in the preferences? Not having the Touch Bar I keep it unchecked.

253628404_ScreenShot2020-04-09at8_45_06AM.png.a2d7c01264acef5c2eefc653f0b14f8b.png


MacBook Pro (13-inch, Mid 2012) Mac OS 10.12.6 || Mac Pro (Late 2013) Mac OS 10.14.6

Affinity Designer 1.9.0 | Affinity Photo 1.9.0 | Affinity Publisher 1.9.0 | Beta versions as they appear.

Share this post


Link to post
Share on other sites

The Escape key is part of the OS and should remain in place regardless of Publisher’s preferences.


macOS 10.15.7  15" Macbook Pro, 2017  |  4 Core i7 3.1GHz CPU  |  Radeon Pro 555 2GB GPU + Integrated Intel HD Graphics 630 1.536GB  |  16GB RAM  |  Wacom Intuos4 M

Share this post


Link to post
Share on other sites

How about restarting the TouchBar via the Terminal.app? – After killing Touch Bar server application it will come back. Just paste the following to terminal and enter your password when asked:


macOS 10.14.6, Macbook Pro Retina 15" + Eizo 27" // Affinity preferred in Separated Mode + Merged Windows

Share this post


Link to post
Share on other sites
11 hours ago, thomaso said:

How about restarting the TouchBar via the Terminal.app? – After killing Touch Bar server application it will come back. Just paste the following to terminal and enter your password when asked:

Yes, that's what I did. And it worked. Actually it didn't really cross my mind that it could have been a system failure, but when I got back home, I tried it and found a solution pretty quickly. 

Thanks for the reply everyone!

I leave this here as a reminder of my stupidity, rashness and failure to research the problem (I was in a hurry...).

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.