Jump to content

Recommended Posts

I'm a relatively new user to Affinity (though I did use a few of the original apps way back when). I'd like to migrate from InDesign and Illustrator to Affinity Publisher and Designer, and so far the apps are actually great to use. My only MAJOR issue is that (like Adobe apps) every time there is an update, it fails repeatedly! It's really hard to make a living as a creator and having issues with updates is time-consuming and unhelpful. Is there something I'm doing wrong? I run on Windows 10 version 1909.

Link to post
Share on other sites
1 hour ago, I Hardy said:

My only MAJOR issue is that (like Adobe apps) every time there is an update, it fails repeatedly!

Is it the update that fails, or does the application begin failing? What is the nature of the failure?

MacBook Pro (13-inch, Mid 2012) Mac OS 10.12.6 || Mac Pro (Late 2013) Mac OS 10.14.6

Affinity Designer 1.9.3 | Affinity Photo 1.9.3 | Affinity Publisher 1.9.3 | Beta versions as they appear.

Link to post
Share on other sites

I think it's the update itself that fails. The update downloaded, began installing, then stops before finishing and posts the message "update failed". And that's it. The  program itself is not open, so no conflict there. This is repeated, and has done it with Designer as well (I don't own Photo).

Link to post
Share on other sites

In that case I would delete the application and reinstall it from what ever store I bought it from, this is a larger download but has the result that you get the new version. If you don't want to delete (Follow free advice from an unqualified stranger. What could go wrong?) try renaming it or putting it on a separate drive and disconnect that drive. Place in the trash and don't empty it.

I do this with different applications a fair amount of the time, I am on Mac. Windows I don't know about anymore.

MacBook Pro (13-inch, Mid 2012) Mac OS 10.12.6 || Mac Pro (Late 2013) Mac OS 10.14.6

Affinity Designer 1.9.3 | Affinity Photo 1.9.3 | Affinity Publisher 1.9.3 | Beta versions as they appear.

Link to post
Share on other sites
3 minutes ago, Old Bruce said:

(Follow free advice from an unqualified stranger. What could go wrong?)

 

😂 😄

Thank you kindly, I will try uninstalling. My daughter has a Mac and keeps telling me "mom just go get a mac f'crying out loud" without thinking of the hefty price tag. But anyway. Will report back.

Link to post
Share on other sites
1 minute ago, I Hardy said:

My daughter has a Mac and keeps telling me "mom just go get a mac f'crying out loud" without thinking of the hefty price tag.

Kids. 

Here on Mac we have lots of trouble too.

MacBook Pro (13-inch, Mid 2012) Mac OS 10.12.6 || Mac Pro (Late 2013) Mac OS 10.14.6

Affinity Designer 1.9.3 | Affinity Photo 1.9.3 | Affinity Publisher 1.9.3 | Beta versions as they appear.

Link to post
Share on other sites

So I uninstalled it, tried reinstalling and it failed again. Twice. So I tried reinstalling in the same Affinity folder, but not in the Affinity--Publisher folder and it worked. Likely not a very good idea to put it there, it's a messy folder now, but well I didn't know where else to try. But maybe the next time it fails (it will surely happen again) I could try naming a new folder a random name and it would work too?

Anyway, for now it seems all is good. Thank you so much for the help, very much appreciated!

Link to post
Share on other sites

There's a FAQ entry with a number of suggestions and debugging steps for when Windows screws up an installation. Perhaps these will help you the next time :)

https://affin.co/WinSetupFailed

-- Walt

Windows 10 Home, version 20H2 (19042.685),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop (2021-04-06):  32GB memory, Intel Core i7-10750H @ 2.60GHz
, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU
Affinity Photo 1.9.2.1035 and 1.9.4.1048 Beta   / Affinity Designer 1.9.2.1035 and 1.9.4.1048 Beta  / Affinity Publisher 1.9.2.1035 and 1.9.2.1024 Beta

Link to post
Share on other sites

Your Mac updates of Photo, Designer, and Publisher corrupted ALL of my installs. :( It installed duplicate versions of all 3. When I tried to delete the duplicates they were then all corrupted. I had to install them all over again from scratch and have now lost ALL of the brushes, fonts, and such that you offered after launch. So aggravating!!!!! 

How do I get all of that back?!

Link to post
Share on other sites
2 minutes ago, skiphunt said:

Your Mac updates of Photo, Designer, and Publisher corrupted ALL of my installs. :( It installed duplicate versions of all 3. When I tried to delete the duplicates they were then all corrupted. I had to install them all over again from scratch and have now lost ALL of the brushes, fonts, and such that you offered after launch. So aggravating!!!!! 

How do I get all of that back?!

As the original post (and the rest of this discussion) was about a problem on Windows, you may get better help if you post your own topic rather than piggy-backing on something irrelevant to your situation.

-- Walt

Windows 10 Home, version 20H2 (19042.685),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop (2021-04-06):  32GB memory, Intel Core i7-10750H @ 2.60GHz
, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU
Affinity Photo 1.9.2.1035 and 1.9.4.1048 Beta   / Affinity Designer 1.9.2.1035 and 1.9.4.1048 Beta  / Affinity Publisher 1.9.2.1035 and 1.9.2.1024 Beta

Link to post
Share on other sites
Just now, walt.farrell said:

As the original post (and the rest of this discussion) was about a problem on Windows, you may get better help if you post your own topic rather than piggy-backing on something irrelevant to your situation.

It says Mac and Windows at the top! Easy with the attitude. I've just lost a week's worth of work.

Link to post
Share on other sites
2 minutes ago, walt.farrell said:

As the original post (and the rest of this discussion) was about a problem on Windows, you may get better help if you post your own topic rather than piggy-backing on something irrelevant to your situation.

I just checked again. It freakin' says "Constantly Unable to Update (Mac and Windows)" right at the freakin' top of the screen. What's your problem? Back off if you don't have anything constructive to say.

Link to post
Share on other sites
Just now, skiphunt said:

I just checked again. It freakin' says "Constantly Unable to Update (Mac and Windows)" right at the freakin' top of the screen. What's your problem? Back off if you don't have anything constructive to say.

The forum is for Mac and Windows.

The topic you chose to post in (rather than creating your own topic) is from a user having trouble on Windows, and the people looking at this topic are primarily Windows people. None of us can help you, and Mac people may not notice that a Mac person has popped in with a post in a topic that has been Windows-related.

The suggestion was for your benefit, and was based on a significant amount of experience with how this set of forums operates, and how to help things in the forum work well, and was (though of course, perhaps only in my opinion) very constructive. But feel free to ignore it.

-- Walt

Windows 10 Home, version 20H2 (19042.685),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop (2021-04-06):  32GB memory, Intel Core i7-10750H @ 2.60GHz
, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU
Affinity Photo 1.9.2.1035 and 1.9.4.1048 Beta   / Affinity Designer 1.9.2.1035 and 1.9.4.1048 Beta  / Affinity Publisher 1.9.2.1035 and 1.9.2.1024 Beta

Link to post
Share on other sites
16 hours ago, walt.farrell said:

There's a FAQ entry with a number of suggestions and debugging steps for when Windows screws up an installation. Perhaps these will help you the next time :)

https://affin.co/WinSetupFailed

Will look through that, thanks!

 

13 hours ago, skiphunt said:

 Back off if you don't have anything constructive to say.

I'm the one who began this thread, please be kind to people. 🙂

Link to post
Share on other sites
  • Moderators

@skiphunt Please adhere to our Forum guidelines if you are looking for support, specifically regarding the first rule;

Quote

Be nice. Do not insult, harass, or "SHOUT" at anyone. Any personal criticism or attacks will immediately result in your account being suspended or removed.

I appreciate, and offer my sincerest apologies if files or custom settings have been lost, however this behaviour will not be tolerated here, and certainly won't help the situation.

Please can you create a separate thread for this issue, as Walt has suggested, it's a rather major report and unrelated enough to the original issue to warrant it's own thread. We ask for this as it helps keeps issues separate and makes life a lot easier for the tech support team here.

________________________________________________________________________

@I Hardy

I'm sorry to hear you often have installation issues - do you by chance have any third party 'cleaning' applications, such as CCleaner installed? Affinity apps use a Windows 'MSI' based updated, which requires certain files are left on your system for the next updater to use, and certain apps such as CCleaner have been known to remove these files periodically, which causes the update to fail.

If you'd like, I can double check the reason the install failed using your SetupUI file. To find this, please open Windows Run (Windows Key + R) then paste the following string and press OK:

%temp%\AffinitySetup

In the window that opens, please select the most recently created folder, then upload SetupUI.log to your reply here.
Many thanks in advance!

Link to post
Share on other sites
2 hours ago, Dan C said:

@skiphunt Please adhere to our Forum guidelines if you are looking for support, specifically regarding the first rule;

I appreciate, and offer my sincerest apologies if files or custom settings have been lost, however this behaviour will not be tolerated here, and certainly won't help the situation.

Please can you create a separate thread for this issue, as Walt has suggested, it's a rather major report and unrelated enough to the original issue to warrant it's own thread. We ask for this as it helps keeps issues separate and makes life a lot easier for the tech support team here.

________________________________________________________________________

@I Hardy

I'm sorry to hear you often have installation issues - do you by chance have any third party 'cleaning' applications, such as CCleaner installed? Affinity apps use a Windows 'MSI' based updated, which requires certain files are left on your system for the next updater to use, and certain apps such as CCleaner have been known to remove these files periodically, which causes the update to fail.

If you'd like, I can double check the reason the install failed using your SetupUI file. To find this, please open Windows Run (Windows Key + R) then paste the following string and press OK:

%temp%\AffinitySetup

In the window that opens, please select the most recently created folder, then upload SetupUI.log to your reply here.
Many thanks in advance!

Oh geez... I'm trying to get work done in Affinity apps on Mac. I see there's an update for all of them. I take a moment to do a quick update... only it never finishes the updates. I try again and again... won't complete. Then FINALLY it finished, only there's now duplicate installs of all three apps. I try to figure out which was the older install to delete. I delete and now the remaining installs are corrupt. The work I had going it all lost. 

I come to the forum to see if anyone else is having trouble. I see a post that says "Constantly Unable to Update", so I add my similar experience to it. All the while, already upset because I lost work and a couple hours dealing with what was supposed to be a quick update. End up having to start all over and redownload them all again and lose ALL of my fonts, brushes, etc. with now evident way to get them back. 

I come back to the forum to see if anyone has answers and all I get is a snarky reply trying to evidently shame me for "piggybacking" on a thread that sounds like my same problem instead starting yet another thread about the same problem.

Now, I'm being threatened to have my account deleted?! Seriously?!!! 

That's just rich. I've been a loyal user of Affinity since the beginning and love the applications as a whole (when installs aren't going dreadfully wrong and costing lost time and work that is)

I thought I'd try the forum first, but it looks like sending Affinity direct support emails might be much less aggravating.

Link to post
Share on other sites
  • Moderators
5 minutes ago, skiphunt said:

Now, I'm being threatened to have my account deleted?! Seriously?!!! 

No threats have been made, but I'm sorry you feel this way. I simply quoted the forum guidelines which you agreed to when creating an account and posting here - and asked you to respect the rules.

Link to post
Share on other sites
29 minutes ago, Dan C said:

No threats have been made, but I'm sorry you feel this way. I simply quoted the forum guidelines which you agreed to when creating an account and posting here - and asked you to respect the rules.

I got what I needed. It was actually Walt who got me what I was looking for. I've downloaded all of my lost content and saved for backup this time. I also apologized to Walt for taking out the aggravation out on him... of losing my work, the afternoon troubleshooting a bad Affinity update, and having to look for all my lost Affinity downloads. 

I wasn't trying to piggyback on anything. I only posted in this thread because it read like the same problem I was having. I thought it would be more efficient to contain similar problems in one thread rather than starting completely new threads. I didn't intend to get in any arguments or upset any other posters by adding my similar Affinity failure on their thread instead of starting my own. 

In the future, I will forgo trying to be efficient, and just start a new thread that's specific to my own tech support issues only. 

Regards

Link to post
Share on other sites
  • Moderators

Thanks for letting me know, skiphunt. I'm glad to hear Walt has been able to point you in the right direction and once again I'd like to offer our apologies for any inconveniences caused during this update.

21 hours ago, skiphunt said:

also apologized to Walt for taking out the aggravation out on him... 

I appreciate this, as Walt is a great member of our community and has worked tirelessly to keep these forums running smoothly.

I certainly understand why you would choose this thread, there is no great deal of harm caused by you posting your issue here and I for one am a great fan of efficiency!
I think in any other situation this would not have been as poignant, and we would likely have supported your issue here, but the initial response was somewhat aggressive and I felt it important to resolve this, before attempting to resolve the software issue, so I simply reiterated the point that Walt made suggesting it may help to be in it's own thread.

Once again, my apologies on behalf of Affinity for any inconveniences caused through the update procedure and for any custom settings lost. Could you confirm for me, do you require any further support in getting back up and running? :)

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.