Jump to content
Our response time is longer than usual currently. We're working to answer users as quickly as possible and thank you for your continued patience.

Cant Open .Nef Raw Files on iPad


Recommended Posts

Posting here to add to the .Nef file issue with the iPad version 1.8.2 of Affinity Photo. When I import the Raws from photos they open up as extremely pixelated, small sized files, with the message:
following message is displayed: “Assigned profile: Photo iPad assigned your working profile (sRGB IEC61966-2.1) to this unprofiled document” as a 120X160Px size file.


Is Affinity opening the thumbnail image for these filetypes? Im also noticing my images are flipped in some instances. Luckily my Google-FU led me here and I have been able to get into editing my raws using the drag and drop trick. 

I shoot Both D850 and D800 Nikon Cameras, hoping Devs can have this bug fixed soon.

Thanks!

Link to comment
Share on other sites

Hi! I have the same issue. RAW files have until now opened beautifully. But suddenly few days ago, as I had in mind to process photos of my new paintings for my website, the photos are opening in absolutely huge lumps of pixels. Same thing is still happening with photos I took yesterday and tried processing just now.

I hope it will get fixed soon. 

Thanks!

Link to comment
Share on other sites

  • 2 weeks later...

I am having exactly the same problem when importing NEF raw photos from the Apple Photos app.  The files are from a Nikon D7000 which I have imported directly onto my iPad using a sd card reader.  Landscape files are fine and import with the .NEF extension but portrait import with a .TIFF extension and look to be the lo res preview image created by the camera.

I have found a workaround, if I export the portrait NEF files from the photos app into iCloud (keeping them as raw format), then importing those NEF files into Afinity and it’s fine, so it seems afinity can correctly process the RAWs but not when imported from apple photos.

Link to comment
Share on other sites

  • 2 weeks later...
  • 1 month later...

Hey guys I’m have the same issue and have been going mad testing different workarounds.i have found as someone earlier has said ,that it is only portrait images that have the issue and only raw images. But if i export from the iPad to cloud or external ssd and bring them into AP that way then it is ok. I have noted as well that all previous portrait photos that previously went into AP without issue and were edited the original Raws also have the issue as i had thought for a while it may have been camera (Nikon D5300) firmware to blame, i also tried changing colour space setting in camera to and from sRGB and adobe rgb. I am still not sure if this is a AP issue or and IPad Issue as i have had random occurring similar issues when i deleted an image from camera roll (that would not load into AP) and then tried to put the same image back in to Camera roll from the external ssd the result was the same messed up lumpy pixelated image i had seen on AP but obviously AP was not involved in any way. In this instance it maybe work noting that the image was taken in portrait from camera and imported to camera roll and looked perfect than was loaded onto external ssd and looked perfect then was loaded back to camera roll and looked a mess ( same lumpy pixel but not flipped). But if i load from external ssd to AP renders fine and gone straight to “develop”. So I don’t know. After two days messing around with it I don’t know if it iPad or AP i just know its doing my head in.There are work arounds but not ideal when you want to spend to editing not send images here and there trying to get them to load.

 

for referance my iPad is is all up to date and is a 10.5 pro

 camera is a Nikon d5300 firmware all up to date 

all cables all cables are official apple where poss and powered usb hub (AUKRU usb 3.0 hub) works perfect and a 500gb WD my passport go ssd.

and lastly the note i get on affinity is as follows.

Assigned Profile: Photo iPad assigned your working profile (sRGB IEC61966-2.1) to this unprofiled document

 

if anyone figures anything out or if i can help test any potential fixes please email me madmanpan@icloud.com

 

 

Link to comment
Share on other sites

FIXED!!!!! 

Save the image to a file Not camera roll and it will load onto affinity fine. 

Back story if interested:

Raws files are the only ones i found to be affected jpegs are fine. so in this post i am only refering to Raw files unless otherwise stated. 

This was driving me insane so i experimented with bit size of file and in camera colour file change, portrait and landscape, various sd cards and ssd various cables and ways of not only taking the photo from camera to ipad but also ipad to affinity. And have found it to be not a affinity problem but i think a ipad issue. I found that with the new update 13.5.1 when i plug my camera (nikon5300) into ipad via official lightning adapter and IMPORT the images to carmera roll they go in fine and i can export them onto a external ssd or sd or place them in a file fine. But if i take the sd card out of the camera and use a usb card reader and lightning adaptor and SHARE/SAVE  them into carmera roll the arrive totally pixallated. Even if i use the good images in camera roll and export to ssd or a in-ipad-file and then share/save them back into camera roll those same images come back pixallated. Furthermore if i load a good file from camera roll onto affinity in portrait it comes onto the screen pixalated and flipped where as landscape images come through sometimes piaxalated sometimes fine and somtimes fine but in photo persona not develop where as as i mentioned in my previous post the images are all good when they come from anything other than camera roll. So for now i think i will stop using camera roll at all and just save work to files.

Hope this helps some people and i hope its fixed on the next update but to be honest i quite like the organisation of different photo shoot means different file instead of being lazy and just throwing all my images into camera roll as i used to. 

 

Link to comment
Share on other sites

  • 3 months later...
10 hours ago, Antonio Picasso said:

Please can we have a fix for this..

Have you tried the latest beta. It allows you to select Serifs RAW engine instead of Apples. Don’t know if it make a difference with you issue  though.

beta link.

 

IPad Pro 10.5/512GB   lpadOS 16.1.1 Apple Pencil (1st gen), Affinity Photo 1.10.5 Affinity Design 1.10.5 Affinity Publisher 2, Affinity Designer 2, Affinity Photo 2

Official Online iPad Help documents (multi-lingual) here: https://affinity.https://affinity.help/ 

 

Link to comment
Share on other sites

  • 1 month later...
On 9/18/2020 at 5:44 PM, DM1 said:

Have you tried the latest beta. It allows you to select Serifs RAW engine instead of Apples. Don’t know if it make a difference with you issue  though.

beta link.

 

I downloaded it, cant find the settings....

 

never mind it is in

general - assistant option

 

 

nevertheless the problem still persist

Edited by senxxkingslayer
Link to comment
Share on other sites

  • 11 months later...

It’s September 2021 and I’m trying to process RAW/.NEF (Nikon) for the first time. I’m getting a perfect RAW image in Apple Photos, but when it is opened in Affinity on my 9.7 iPad Pro it is highly pixelated. Has there been a fix for this yet, please?

Link to comment
Share on other sites

  • 1 month later...
  • 3 weeks later...
  • 5 months later...

I still have this issue with version 1.10.5. I tried to change the raw engine with no success. I can open a raw file directly, but the integration with Photos app does not work

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.