Jump to content
You must now use your email address to sign in [click for more info] ×

Affinity Photo - objects in PDF have weird outline


Recommended Posts

I'm working in Affinity Photo preparing some mock-ups. The file looks simple, it's white background with some objects pasted on it. But when exported to PDF, the pdf looks weird. Every single object/photo has this weird outline. In Affinity it looks OK (no outline), it's probably just Acrobat seeing something that's not there and displaying it. But this complicates my job since I need pdfs to look clean. To avoid the outlines I have to export the file as PNG, open that PNG and then save it as PDF.

What could be causing this weird behavior? I'm kind of a newbie in Affinity so it might be something that I'm doing wrong.

 

Untitled.png

Link to comment
Share on other sites

First guess would be the anti-aliasing options in Acrobat. Have a look at the preferences of Acrobat. If this won't help, the PDF and / or .afphoto file would do to be posted here.

------
Windows 10 | i5-8500 CPU | Intel UHD 630 Graphics | 32 GB RAM | Latest Retail and Beta versions of complete Affinity range installed

Link to comment
Share on other sites

18 hours ago, Joachim_L said:

First guess would be the anti-aliasing options in Acrobat. Have a look at the preferences of Acrobat. If this won't help, the PDF and / or .afphoto file would do to be posted here.

THANKS! It was anti-aliasing in Acrobat. Unchecked "smooth images" in Preferences>Page Display>Rendering.

Link to comment
Share on other sites

This still keeps bugging me because I have no idea why Affinity does this. And I can't really ask clients to change their Acrobat options to make it go away. It's probably my fault, could someone please check the affinity file to see what I'm doing wrong? Maybe I'm not exporting it to PDF correctly (which options should I use?)

I'd be grateful if someone would check it!

PDF problem.afphoto

Link to comment
Share on other sites

Not entirely sure why you get those thin lines around some of the Pixel layers when viewing the finished PDF in Acrobat?
Using Preview on my Mac, your PDF looks fine, no thin lines.

However;
The Pixel layers in question in your sample file all have white backgrounds to them and it is at the edges of these backgrounds that the lines occur on opening the exported PDF in Acrobat Reader.
If you set these 4 layers blend modes to ‘Multiply’ then the subsequent PDF output from Photo displays correctly in Acrobat Reader for me. Even with 'Smooth Images' turned On in Acrobat's preferences.
But as to why this works I’ve no idea!

macOS 13.6.7  15" Macbook Pro, 2017  |  4 Core i7 3.1GHz CPU  |  Radeon Pro 555 2GB GPU + Integrated Intel HD Graphics 630 1.536GB  |  16GB RAM  |  Wacom Intuos4 M

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.