Jump to content
Pockenfresse

[AD 1.8.2.620] Strange Pentool behavior / Windows Ink

Recommended Posts

Posted (edited)

Version 1.8.2 runns fine so far but the behavior of the pentool is very strange. By adding starting ancors I always accidently make curve grips which causing strange effects. It only happens when I use my Wacom tablet. I also noticed that I cant adding new ancors anymore in already exsisting paths. In the old version I simply could click with the pentool into the path. With the Mouse its no problem but as soon I use my graphic Tablet it is impossible.

 

Edited by Pockenfresse
Edited title

Share this post


Link to post
Share on other sites

I'm experiencing the same issues as you, as well as other problems. Can't terminate with a double tap, nor change node type mid drawing with a single tap.

Share this post


Link to post
Share on other sites

EDIT: Reported the actual bug causing this here:

I "know" what's going on. The new "Use Windows Ink for tablet input" option found in Preferences > Tools causes this issue. If you turn that off you'll be able to to do sharp point with your table. I don't know why this is happening, Illustrator also uses Windows Ink and does not show this behaviour so it's not a tablet or driver fault. @Pockenfresse are you able to edit the title of this topic to mention this is related to the Windows Ink option? So QA and developers can track this more easily? Thanks!

QA, here's the gist to pass to developers:

  • This issue is related to drawing with the Pen tool (EDIT: Actually this has anything to do with the Pen tool, it's a deeper issue, I'm going to post a separate bug report on this)
  • With "Use Windows Ink for tablet input" enabled we're unable to do sharp points by tapping on the tablet, they end up always being curve points
  • Does not happen when that option is disabled
  • This option exists in all 1.8.2 Affinity apps, so they need to be checked for this behaviour as well (EDIT: just checked, same issue happens on all apps)
  • Does not happen in Illustrator, that also uses Windows Ink
  • The "Use Windows Ink for tablet input" should have a "(requires restart)" warning BTW
  • I'm using Windows 10 18363.720
  • Wacom drivers are 6.3.38-2
  • Tablet is a Wacom Intuos CTL-480/S

Attached video shows what's happening.

Thanks!

Share this post


Link to post
Share on other sites

Can confirm this does fix the issue, however, disabling this setting on a Microsoft Surface disables the touch gestures as well so its definitely as band-aid solution. I'll be testing this out on my Cintiq as well when I'm home from work.

Here's hoping this gets fixed soon!

Share this post


Link to post
Share on other sites
7 hours ago, LCamachoDesign said:

 @Pockenfresse are you able to edit the title of this topic to mention this is related to the Windows Ink option? So QA and developers can track this more easily? Thanks!

Done.

 

Disabling the Windows Ink option in the settings works out for me. Pentool is working now as disired.

Share this post


Link to post
Share on other sites

Gotta need to add something to the bugs: Again keystrokes dont working anymore after a while inactive window. Zoom tool and the other tools are working this time just the keystrokes dont react.. Another bug that exsist since 1.6.x.

Share this post


Link to post
Share on other sites

I just bought a wacom graphics display recently. Working with AF is currently a pain in the.. you know where... with this pentool problem. One version later its still not fixed. Guys I'd had a lot of patience and I understand its rough times but... What are you doing the whole day? Working on new features? Please for god sake, please make the latest stable run good first! I don't need a Template browser! I need a proper workflow! It's a nightmare:

Disable Windows Ink and you have a lag on the whole system with every stroke where working is impossible.
Enabling Windows Ink makes your cursor is hyper sensitive and you even cant add a ancorpoints correctly. Yes I use the Beta - problem still exsist. Every beta update I hope.. but no... I'm disappointed!

I mean you have this nice forum here were people can write bugs and other things down but whats the point when the major bugs which really interrupting the main workflow and productivity, still exsist in every update? Im aware that the pentool bug is addressed and known to the dev team but it seems the priority isnt that high for it. Why something like such a major bug gets ignored everytime? Some people do more in AD rather than just drawing cycles or creating logos. I illustrate comics, I do commissioned works and thats my job. I need to pay my bills with it. I actually put a lot of trust into Affinity when I changed from AI to AD.
So I need your Software and I dont want to miss the other pros this great program has. But now It's impossible to work with AD if the workflow is a nightmare!

I need double the time to finish one work than before with AD 1.7.x which also had anyoing bugs which were partly fixed in 1.8.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.