Jump to content
chapolote

Bug? File hyperlinks not working

Recommended Posts

When I add a file-hyperlink without checking "including file on export", the links are not working, because the exported path isn't correct.

Presuming, my exported File is stored under drive d in the directory export and the linked file is is called test.pdf and stored under drive e in directory myfiles, the generated link looks like this:

d:\export\E\myfiles\test.pdf

Correct would be: e:\myfiles\test.pdf

Can someone confirm this bug or know any workaround?

By the way: if it would work, it's not helpful to have absolute pathes in file-hyperlinks, because by giving the exported file to someone else, the link would be broken.

Using the checkbox "including file on export" creates valid links, but all files will be stored in the same directory. If you have a document with lots of including files, this is not helpful, because the main-file is somwhere hiddem between all the included files. There should be the possibilty to define an additional directory for included files, e.g. my file is stored in a certain place and automatically a directory will be createt on the same level called "attached files" or whatever

Share this post


Link to post
Share on other sites

I can't see this at the moment, I've set up the same folders on a C and D drive and exported to one drive, linking to a file on the other and the correct path is written in the exported file.

Can I confirm what build of the software you are on? Can you reproduce this in a new document?


Serif Europe Ltd. - www.serif.com

Share this post


Link to post
Share on other sites
4 hours ago, Jon P said:

I can't see this at the moment, I've set up the same folders on a C and D drive and exported to one drive, linking to a file on the other and the correct path is written in the exported file.

Can I confirm what build of the software you are on? Can you reproduce this in a new document?

Ok, I proofed it again, with a new installed publisher 1.8.2.620 and a blank standard-template A4 for print.
(Deinstalled publisher, rebooted and installed it new)

OS is Win 10 Pro Build 18362

See screenshots  filelink_publisher_pdf, filelink_publisher_jpg and filelink_publisher_txt to verify, what I did in publisher.

Tried 3 different files, to show first an (for me) unexpected behaviour:

for pdf it's generated an action to read another article. So far, so good.

for txt-files or jpg-images a weblink is generated, what surprises me, because I expected that the file opens in editor(txt) or any picture viewer (jpg)

If you watch my screenshots now, you see the bigger problem: none of the generated links is working:

filelink_publisher_pdf_generiert shows this wrong path I described in my first post. Such link can't work.
filelink_publisher_txt shows the link, how it would be passed to my standard-browser (because it's a weblink generated). Because of a not correct path, the browser can't open a link like x:%5Cfilelink_publisher.txt
Same behaviour for the jpg file.

The generated pdf is opened adobe acrobat pro dc in actual version.

filelink_publisher_jpg.JPG

filelink_publisher_pdf.JPG

filelink_publisher_pdf_generiert.JPG

filelink_publisher_txt.JPG

filelink_publisher_txt_generiert.JPG

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.