Jump to content

Recommended Posts

Hey,

 

I saw this has been an issue on MacOS until the latest version (still to be validated, I guess...), but it also appears on the Windows version:

If you open a "Levels" Adjustment Layer, the Histogram shows up with a delay. This can range from 1 second to almost 30 seconds.

Share this post


Link to post
Share on other sites

Hey outgettingsubs, welcome to the Affinity Forums :) 

I have fed this back to the developers in the past. The Histogram is given CPU power in the Develop Persona, however in the Photo Persona it isn't given any power from the CPU and can occasionally take a while to update. 

I will of course add your post to the original report I made in the hopes this may be improved one day. Thank you.

Share this post


Link to post
Share on other sites
23 minutes ago, Chris B said:

Hey outgettingsubs, welcome to the Affinity Forums :) 

I have fed this back to the developers in the past. The Histogram is given CPU power in the Develop Persona, however in the Photo Persona it isn't given any power from the CPU and can occasionally take a while to update. 

I will of course add your post to the original report I made in the hopes this may be improved one day. Thank you.

Thanks Chris!

Yes, that's what I thought as itr sems to occur more often and obvious with large file sizes / big projects. Fingers crossed this gets fixed at some point. :)

Share this post


Link to post
Share on other sites

Have you seen it take longer than 30 seconds? There's an old post where some people are reporting minutes (if not longer) for the Histogram to update. Though recently they reported this as fixed. 

Share this post


Link to post
Share on other sites
6 minutes ago, Chris B said:

Have you seen it take longer than 30 seconds? There's an old post where some people are reporting minutes (if not longer) for the Histogram to update. Though recently they reported this as fixed. 

Yes, it can be more than 30 seconds as well. I just recorded a video tutorial yesterday and it suddenly happened again with at least a 30 sec delay.

 

One thing that is an indicator: When I merge or duplicate a layer and the thumbnail of the new Layer in the Layers tab stays gray, that's mostly when it starts to happen. If you open a Levels AL then, its thumbnail will stay gray as well, then the delay, then the thumbnails and histogram will appear.

 

I'm assuming that the thumbnails are bound to the same CPU process/problem.

I can upload the part from the video later when I'm back on the PC if that helps.

Share this post


Link to post
Share on other sites

Alright, here we go. It took over a minute in this case (I certainly edited that part out of the final film, haha...).
There you can also see the coresponding bug with the greyed out thumbnails in the "Layers" tab.

Machine is:

  • Intel i9 9900X 3.5GHz
  • 64 GB DDR4 RAM
  • Windows 10 Enterprise
  • Nvidia GTX2070 Super

Thanks!

Share this post


Link to post
Share on other sites
6 hours ago, Chris B said:

Thanks for the video—that really doesn't look great, does it... 

Your're welcome. Yeah, it's a pain, especially as I'm using the Levels a lot during astro processing. I hope I can find more people with this problem and draw some attention towrds fixing it.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.