Jump to content
Goner__

[1.8.x] Pinned images – Delete and Undo Distorts Proportions

Recommended Posts

Hi guys, a minor bug you may want to look into when there are no more important issues.

  1. Insert an image (icon for instance) and pin it to the first word of a paragraph (pin position does not really matter though). 
  2. Paste new text into the paragraph (and overwrite your pin, thus deleting the image).
  3. Think: "Ah, darn, I did it again. I wanted to keep the bloody image."
  4. Press Cmd + Z to save the day.
  5. The original contents will reappear – but the proportions of the pinned image will be completely different (and cannot be easily restored other than typing them manually to the Transform fields)

Disclaimer: It's perfectly possible that I am just not doing something right. If that's the case, just let me know. ;-)   

Anyhow, thanks again for the brilliant piece of software you unleashed on us! I really love every minute working in the Affinity suite. 

Cheers to the UK!

 

Share this post


Link to post
Share on other sites

Due to the fact that Boris Johnson is now our Prime Minister, punctuation, spelling and grammar will never be worried about ever again.  We now have far bigger problems to be worried about.

Share this post


Link to post
Share on other sites

The ultimate cause may be the same but my issue is basically a two-in-one: 

  • undesired resizing of a pinned object
  • undo does not get you back to the last correct version

Share this post


Link to post
Share on other sites

It seems to be the same cause, I can only reproduce the issue following your steps if I resize the text frame first, do you get the same if you create a new frame?


Serif Europe Ltd. - www.serif.com

Share this post


Link to post
Share on other sites
2 hours ago, Jon P said:

I can only reproduce the issue following your steps if I resize the text frame first,

For whatever it's worth, I had a similar issue a couple of weeks ago but only with IDML files exported from indesign and opened in Publisher.

Also, by clicking the "Float with Text" button continuously on and off  the pinned graphic would march up the page.

Share this post


Link to post
Share on other sites
On 3/25/2020 at 3:11 PM, Jon P said:

It seems to be the same cause, I can only reproduce the issue following your steps if I resize the text frame first, do you get the same if you create a new frame?

First things first, sorry for a latish reply Jon. 

No, I did not resize the frame. However, the issue seems to be resolved by the pinning fixes implemented in .627. I have not been able to reproduce it in the current beta, not even with resizing the text frame (which is still reproducible in MAS).

Weird because I checked the bug like 10 times before submitting a ticket. Anyway....  good news, I guess! THANKS. 

That leaves us with my other pinning-related issue 😉– styled text in pinned image-text frame groups (such as image + caption) are ignored in TOC

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.