Jump to content

Recommended Posts

I must be missing the boat on the trip.  I have Templates and they work perfectly with Place photos from internal/external hard drives.  My problem is I cannot figure out how to navigate to Apple Photos to select picture to Place in Templates.  MacOS, Catalina when I go to pictures, the Apple Photos is grayed out.  Thank you for any assistance.


Cecil 

iMac Retina 5K, 27”, 2019. 3.6 GHz Intel Core 9, 40 GB Memory DDR4, Radeon Pro 580X 8 GB, macOS,iPad Pro iPadOS

 

Continuous improvement is better than delayed perfection 

Share this post


Link to post
Share on other sites

It should work the same whether you are working with an existing template (.aftemplate) file or any other native format document file. The trick is to first make sure the "Media" sidebar item (usually at the bottom of the sidebar so you may have to scroll down to see it) is set to show its categories. If there is not a "Photos" category indented below it, move the pointer to the right of the word "Media," which will reveal the word "Show," & click on that. (I wanted to add a screenshot but the forum software is acting up again & won't let me. ☹️)

Once the "Photos" category is visible, click it & in the main Open window on the right, after a delay you should see one or more items, one of which should be "Photos," which is your Apple Photos library, with the various Photos stuff like Moments, Years, etc. indented below that, with Finder-like reveal triangles so you can navigate to & select any photo in the library in the usual way.

At the moment, that is working fine for me in AP but it is erratic in AD -- sometimes the "Photos" library shows up on the right & sometimes not, but I do not know if that is caused by some problem with my Mac or what. I can eventually get it to work in AD, but sometimes I have to cancel the Place & try again, or switch to some other sidebar item & back again for it to show up.

EDIT: Added a screenshot of the "Media" section at the bottom of the sidebar:

733456882_Media.photos.jpg.146ec52e46685d0a77a98c8e1bc1cd02.jpg


Affinity Photo 1.8.4, Affinity Designer 1.8.4, Affinity Publisher 1.8.4;  2020 iMac 27"; 3.8GHz i7, Radeon Pro 5700, 40GB RAM; macOS 10.15.6
Affinity Photo 
1.8.4.186 & Affinity Designer 1.8.4.4 for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 14.0.1

Share this post


Link to post
Share on other sites

@R C-R Thank you, fixed my problem with the exception Photo was imported upside down. 


Cecil 

iMac Retina 5K, 27”, 2019. 3.6 GHz Intel Core 9, 40 GB Memory DDR4, Radeon Pro 580X 8 GB, macOS,iPad Pro iPadOS

 

Continuous improvement is better than delayed perfection 

Share this post


Link to post
Share on other sites
2 hours ago, Cecil said:

... with the exception Photo was imported upside down. 

I have had some come in upside down, some right side up, & some sideways. I think it may have something to do with the orientation of the camera.


Affinity Photo 1.8.4, Affinity Designer 1.8.4, Affinity Publisher 1.8.4;  2020 iMac 27"; 3.8GHz i7, Radeon Pro 5700, 40GB RAM; macOS 10.15.6
Affinity Photo 
1.8.4.186 & Affinity Designer 1.8.4.4 for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 14.0.1

Share this post


Link to post
Share on other sites
35 minutes ago, R C-R said:

I have had some come in upside down, some right side up, & some sideways. I think it may have something to do with the orientation of the camera.

One would think it would import photo as saved, original info should be lost (guessing) if one save after changes and different format.


Cecil 

iMac Retina 5K, 27”, 2019. 3.6 GHz Intel Core 9, 40 GB Memory DDR4, Radeon Pro 580X 8 GB, macOS,iPad Pro iPadOS

 

Continuous improvement is better than delayed perfection 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.