Jump to content

Recommended Posts

Hi everyone,

Before I updated Affinity Designer, I noticed this weird issue pop up. Layers of my artwork or the entire artwork will stay selected purple even if I click off all the layers or Ctrl + D to deselect everything. This happens on my other artwork too. Initially, it looks normal but when I select any layer and click off, everything goes purple as if its all selected and its stuck like that.


I've tried closing down the program and restarting. I've updated to the latest version. I've tried Ctrl + D. Any help is much appreciated. :)

Select Issue 2.JPG

Select Issue 3.JPG

Share this post

Link to post
Share on other sites

Try turning off "Show Snapping Candidates" in the Snapping Manager.

Affinity Photo 1.9.2, Affinity Designer 1.9.2, Affinity Publisher 1.9.2;  2020 iMac 27"; 3.8GHz i7, Radeon Pro 5700, 32GB RAM; macOS 10.15.7
Affinity Photo & Affinity Designer 1.9.1 (showing 1.9.7) for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 14.4 (18D52)

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.