Jump to content
ChristAlix

AD [1.8.1.604] - Artboard cannot be created by selection! BUG

Recommended Posts

In contrast to the 1.7x version, it is now (and in the 1.8.0x version) no longer possible to convert the area to artboard! An artboard is created, but not at the desired position. Also the function Undo after creating the artboard does not work, so you can never go back to the origin!
Please note that the workspace moves again and again after each use of the Undo function, which should not be the case!

I have included an example with document history, please solve the problem.

AD_1.81.604_Beta_artboard_bug.gif

S_Curve_Artboard_BUG.afdesign

Share this post


Link to post
Share on other sites
8 hours ago, ChristAlix said:

In contrast to the 1.7x version, it is now (and in the 1.8.0x version) no longer possible to convert the area to artboard! An artboard is created, but not at the desired position. Also the function Undo after creating the artboard does not work, so you can never go back to the origin!
Please note that the workspace moves again and again after each use of the Undo function, which should not be the case!

S_Curve_Artboard_BUG.afdesign 10.03 kB · 0 downloads

Yep, I experience the exact same behavior in 1.8.1.604 (quoting):

  • An artboard is created, but not at the desired position.
  • Undo after creating the artboard does not work, so you can never go back to the origin!
  • Please note that the workspace moves again and again after each use of the Undo function, which should not be the case!

Share this post


Link to post
Share on other sites

I have earlier reported similar behavior with beta, and still reproducible with the 1.8 release and current 1.8.x beta, happening when an artboard is created based on having an object already selected, having "Selection" option chosen from the Artboard size list, and clicking "Insert Artboard". The operation only succeeds, if the top left coordinate of the bounding box is at 0,0. If it is not, the artboard is created at 0,0 at correct size, but the selected object is not placed within the artboard.

This error seems to happen only if there is no existing artboard before using this method. If there is, the feature seems to work ok (the artboard is created at the position of the selected object).

Undo behavior is similar as described above: it is not possible to undo the action and revert to document setup size (the new artboard in practice becomes the new document size). 

In 1.7.3. the feature works without errors, and it is also possible to undo the action and revert to earlier document size (the document size becomes the size of the newly created artboard in version 1.7.3., as well, but I suppose this is intentional).

EDIT: I forgot to mention that an additional error with this feature (at least compared to v. 1.7.3) is that the selected objects are not placed within the created artboard, even in a situation that the artboard is created at the position of the selected objects. In version 1.7.3 the selected objects are placed (hierarchically) under the newly create artboard.

Share this post


Link to post
Share on other sites

Hi ChristAlix (and Patrick),

This is something we're aware off and with development to be fixed, I will get your comments passed on.

On 3/9/2020 at 6:58 PM, Lagarto said:

EDIT: I forgot to mention that an additional error with this feature (at least compared to v. 1.7.3) is that the selected objects are not placed within the created artboard, even in a situation that the artboard is created at the position of the selected objects. In version 1.7.3 the selected objects are placed (hierarchically) under the newly create artboard.

There was a change made when you have 'Edit All Layers' disabled in the Layers Panel that will mean any created object will always appear inside the selected artboard, even if it was hovering over a different artboard. If this is not what you're experiencing could you create a new thread in the Designer Bugs forum (not the beta one) regarding this and attach a video showing the behaviour you're getting please?

Share this post


Link to post
Share on other sites

Hello, Sean P.,
I want to report that the bug has not been seen since the latest 1.8.1.611 beta!

Thanks a lot, you solved it quickly!

AD_1.8.1.611_Beta_create_artboard_works.gif.2c033e7b0c0da840c0ef31566294c4ba.gif

 

 

What bothers me a lot now are these double (parallax) selection frames or selection boxes. Is this intentional or a bug?

 

AD_1.8.1.611_artboard_select_frame.png

AD_1.8.1.611_artboard_select_bug_2x.gif

Share this post


Link to post
Share on other sites

Not seeing the double selection box here - how odd.


Win10 Home x64   |   AMD Ryzen 7 2700X @ 3.7GHz   |   16 GB RAM   |   1TB SSD   |   nVidia GTX 1660   |   Huion 1060 Plus

How I make GIFs >>> ScreenToGIF (Windows only, Open Source, Portable, ~600kB)

Share this post


Link to post
Share on other sites
18 minutes ago, Patrick Connor said:

Is it a snap to grid effect?

I don't think it is, as I tried to recreate it with snap to grid enabled.

Also the double effect is present at an angle when dragging the artboard along a diagonal, which makes no sense with the square orthogonal grid.


Win10 Home x64   |   AMD Ryzen 7 2700X @ 3.7GHz   |   16 GB RAM   |   1TB SSD   |   nVidia GTX 1660   |   Huion 1060 Plus

How I make GIFs >>> ScreenToGIF (Windows only, Open Source, Portable, ~600kB)

Share this post


Link to post
Share on other sites

Hello Aammppaa, 
Hello hashms0a,
your statement that you have no trouble has left me a little confused.
And I must say that you are right, but with a big "But"! Because when I simply created a new A4 drawing and used the function "Insert Artboard" I suddenly didn't have any double (parallax) selection frames or selection boxes. "But", when I used the attached document for the above mentioned test the (parallax) effect was back! First thought was, the document is corrupt, it was created with the 1.7.x version. So I created an identical document in AD 1.8.0.585 and the (parallax) effect was still there.
After several tests and on different systems (HP EliteBook 8560w/8570w & HP ZBook 17 G4) (Win7 & Win10), as well as through all graphic settings under AD menu "Performance" I found out how this (parallax) effect is caused. 
So I came to the conclusion that it must possibly be due to the dimensions or resolution of the document. 
Since Affinity promotes the designer with a zoom of over 1.000.000%, I created an empty A4 document and chose the function "Insert Artboard" while zooming in, Bingo! The (parallax) effect was there again and with every zoom level it got worse.
Unfortunately I couldn't turn it off, not even by installing the latest graphics drivers.
So I claim here and now that this is a bug and I hope you can reproduce it and confirm my claim!

Thanks for your support guys!

AD_1.8.1.611_Beta_create_artboard_parallax_frame.gif

AD_1.8.1.611_Beta_create_artboard_works.afdesign

Share this post


Link to post
Share on other sites

Good detective work - I confirm that I see the double selection frame at zooms greater than 1000% and the greater the zoom level the worse it gets.

Not that I can imagine creating artboards at this size in my regular work!


Win10 Home x64   |   AMD Ryzen 7 2700X @ 3.7GHz   |   16 GB RAM   |   1TB SSD   |   nVidia GTX 1660   |   Huion 1060 Plus

How I make GIFs >>> ScreenToGIF (Windows only, Open Source, Portable, ~600kB)

Share this post


Link to post
Share on other sites

Artboard creating is pixel snapped (it was wrong when it wasn't) and this is that pixel snapping in action, showing your mouse but also the nearest whole pixel that the artboard falls on.

By design now I see what's happening


Patrick Connor
Serif Europe Ltd

Latest releases on each platform 

 

Share this post


Link to post
Share on other sites

Hello Aammppaa, 
I come from the 3D design environment (Inventor, 3DSMAX, Rhinoceros 3D, Maya, Adobe Illustrator) and have to create very detailed 2D drawings for my clients.
My problem was, until Affinity appeared, the zoom factor of Adobe Illustrator and Acrobat Reader (max. 6400%). With PDFs, even if I wanted to, I could not zoom into the finest detail (10000 - 100000%) and thus had to create several detailed drawings of a design for each presentation. Of course, this is a costly and time-consuming task! 
Until now I was able to create quite a lot of very small artboads (e.g. 0.01mmx0.01mm) in a document "as a kind of detail preview" and when double-clicking on the corresponding artboard, it was displayed on "full screen" so to speak. It was perfect and saved me a lot of work. Furthermore I could inspire my customers for Affinity Designer and also win them as Affinity customers, because they needed the program as in Art Viewer "in the demo version" and so they could enter their comments on design improvements "in the purchase version" in the same document.
But since version 1.8.x the whole thing with the artboards doesn't work anymore and that's what I get from my customers!
It would also be great if Affinity could integrate dimensioning and password protection for layers, artboards and document, but it's a different story or belongs in the "improvements" section!
PS: And this to the idea why you create the artboards in the "regular work" of these sizes!

Hello Patrick,
I don't quite understand what you mean by "Artboard creating is pixel snapped"

My settings are all in "mm" (0,000000 mm), so no pixel units should be active for the snap function in!

 

Made a screenshot for you with "Snap to grid" enabled in "Snapping".

AD_1.8.1.611_Beta_create_artboard_parallax_frame_box.gif.05cf7aad7ff5799cce4a20443658f1a9.gif

 

Now you can see exactly which of the rectangles creates the actual artboard and this is not the selection frame!

183200717_AD_1.8.1.611_Beta_create_artboard_threshold.png.4d72ebb2a0aca6f7afd4dbc698bfcf5e.png

Share this post


Link to post
Share on other sites

@ChristAlixHello, and thanks for explaining why you want such tiny artboards.

The pixel snapping of artboards has been forced so that they always fall on whole pixels. This didn't used to be the case and often resulted in users having antialiased lines in exported images.  Almost every day there was a new forum post complaining that output from Affinity was not sharp, and invariably it was because artboards and objects were not pixel aligned.

Forcing artboards to the pixel grid fixes this issue for most usage cases, but is unhelpful for you!

I think the solution to your problem is not to use artboard to zoom into the details, but instead set up View Points.

1. Zoom to the detail you want to highlight.

2. Ensure that the Navigator Panel is visible, and in Advanced mode (vie the hamburger menu top right).

3. Use the Cog icon (bottom right) to Add a new View Point, and give it a helpful name.

You may also want to set up keyboard shortcuts to Add New View Point and Move To Next / Previous View Point.

See… https://affinity.help/designer/English.lproj/pages/Panels/navigatorPanel.html for more info.

Or this tutorial… 

 


Win10 Home x64   |   AMD Ryzen 7 2700X @ 3.7GHz   |   16 GB RAM   |   1TB SSD   |   nVidia GTX 1660   |   Huion 1060 Plus

How I make GIFs >>> ScreenToGIF (Windows only, Open Source, Portable, ~600kB)

Share this post


Link to post
Share on other sites

Hello Aammppaa, 
thanks for the brilliant tip, I already forgot that there is this function, because I didn't use it! 
And thank you that you have dealt with my problem mentally, it is not self-evident that there are people who suggest sensible solutions instead of just giving problems and complaints!
I just thought about why I have successfully replaced this useful function with the "view point", and it occurred to me that I have set up the arboards in the "Export Persona" for my customers so that they could be exported individually as PDF files, so I don't have to search the entire document for change notes!

For my presentation to the customer audience this "view point" function is perfect and I can save even more time! Thanks a lot!!!!!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.