Jump to content
ziemo

Affinity Designer 1.8 - super slow performance, long opening time and problem with embedding media

Recommended Posts

Hi,

I have a serious problems with the new Affinity 1.8

When I create a pretty big file in Affinity Designer 1.6 (bigger than 2gb) the AD 1.6 opens it in about 5 sec. When I open the same file in AD 1.8 it works the same, UNTIL I save changes. After that the file size is automatically reduced to 250 MB and works super slow. Reopening the file takes almost 2 minutes and it works way worse... looks like it is not embedding media, but linking instead. The same problem occurs when you create a brand new file in AD 1.8. When you create many artboards with many big images, the project starts to run super slow. AD 1.6 didn't have that problems at all. Looks like new Affinity has some serious performance or media placing issues... How can we force the Affinity Designer to always embed media instead of linking them?

The same issue was present in AD 1.7, 1.8 didn't make anything better...

Please take a look how the file behaves in AD 1.6: https://youtu.be/ds9Wjh4IHzU

And how it works after saving the project in AD 1.8: https://youtu.be/F7KTDbsSf7c

Share this post


Link to post
Share on other sites

Hi Ziemo,

Please could you try the below beta build to see if this improves performance?

 

Thanks

C


Please tag me using @ in your reply so I can be sure to respond ASAP.

Share this post


Link to post
Share on other sites

Hi, I tried on BETA, but it is exactly the same behaviour. After saving file is reduced to 250 MB and completely unusable. What is going on with this software? Update after update is getting worse and worse:(

Share this post


Link to post
Share on other sites

Hi Ziemo,

I do not know what is wrong because I do not experience your problem. Your frustration is very understandable, however it does not solve anything.

When you click on the user "Callum" you can send him a private message. If I where you, I should try that way.

I do not know why it takes so long from Serif to reply because mainly they do reply. Maybe there are still looking into your problem? Anyway, they should give better support than this.

When you start a new document from scratch, what happens then? Do you receive the same behaviour. If everything is ok, then you can maybe import the objects  from your affected drawing and save to disk. With every safe, add a unique number to your file. You keep adding your objects and do a Save as... When you experience the buggy behaviour, at least you know what is causing it. Then you can provide more information to the Serif support team here.

I hope you will find a solution to your problem soon. No need to stress, we are here to help you. I am sure other more experienced users know an answer or workaround once they know more details about your problem.

Chris

 

Share this post


Link to post
Share on other sites
6 hours ago, Bad_Wolf said:

I do not know why it takes so long from Serif to reply because mainly they do reply.

Isn't it reasonable to assume that the coronavirus pandemic has a lot to do with the delay? Like with so many other businesses all over the world, all the staff are most likely trying to adjust to working entirely from their homes. So among other things, they probably do not have access to test computers at the office & can't collaborate face to face with each other.


Affinity Photo 1.8.4, Affinity Designer 1.8.4, Affinity Publisher 1.8.4;  2020 iMac 27"; 3.8GHz i7, Radeon Pro 5700, 40GB RAM; macOS 10.15.6
Affinity Photo 
1.8.4.186 & Affinity Designer 1.8.4.4 for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 14.0.1

Share this post


Link to post
Share on other sites

That is indeed a very acceptable explanation which is supported by the fact that Serif always reply. I hope everybody is fine and safe.

I also wish everybody a good health and hope nobody will get infected.

Chris

Share this post


Link to post
Share on other sites

I apologise for the delayed response it has been a hectic month for us with the 1.8 update launch and the UK lockdown unfortunately it means some threads such as this one have fallen through the cracks. Please could you provide the file in question so I can investigate this at my end? Could you also please provide the full specifications of your Mac?


Please tag me using @ in your reply so I can be sure to respond ASAP.

Share this post


Link to post
Share on other sites

Hi, this time I'm sorry for getting back here after so long time...

Well, I tested it 100 times and every time the situation is exactly the same. It's not happening on one particular project, it happens with EVERY document created on Affinity 1.6 which I then try to edit and save in the AD 1.8 (the newest version as well). When I save the file (or use "save as" and create a new file) it makes a 900mb file a 61mb and links every image which was previously embeded... it works very bad. In case you would like to investigate it I paste here some file created in AD 1.6: https://we.tl/t-y5YDCTd2M9

I would appreciate some help with this.

Share this post


Link to post
Share on other sites

The file you just uploaded is 950MB it took my 1.8 designer 5 seconds to open it

I then "saved as" to a new file

The new file is now 60MB and takes my 1.8 designer 14 seconds to open it

Affinity Publisher shows that all images are embedded not linked and the total size of all embedded images is 43MB

I am not seeing any real performance problems or glitchiness with the new 1.8 version of the file.

Maybe they (Affinity) have managed to improve (reduce) the file size needed in 1.8 compared to 1.6 but at the expense of the loading time and maybe some glitchiness that you can see but I can't


I am on Windows and can see you are on a MAC, what is the spec of your MAC?
Maybe someone with a similar MAC can report what they are seeing with your file

 


Due to the fact that Boris Johnson is now our Prime Minister, punctuation, spelling and grammar will never be worried about ever again.  We now have far bigger problems to be worried about.

Share this post


Link to post
Share on other sites

Same findings as carl123. I modified the file by duplicating two photos, saved and closed it. I reopened the file and modified it a second time by duplicating other photos, saved again and closed it. Each time the edited files are opened in 9 seconds and the operation is smooth.

Share this post


Link to post
Share on other sites

Well 14 seconds with this file is pretty long don't you think? I have some files that opens above 1 minute, where AD 1.6 opens them in 10 seconds.

And they are very glitchy when they finally opens. I'm on Macbook PRO, 15 inch, late 2014 model with IRIS PRO graphics and i7 2,2 ghz processor.

AD 1.6 works smoothly with files like 3-4 GB while AD 1.8 is practically unusable with such big files...

Share this post


Link to post
Share on other sites

I have another example of glitchy performance of 1.8.3

I've created a two files, one in AD 1.8.3 and one in AD 1.6. I used the same images.

Look how glitchy it is to move objects in AD 1.8.3 (not to mention this version with so many images in project crashes every 10 min...😞 )

 

Share this post


Link to post
Share on other sites

Hi  there!

I had this lag while draging problem since 1.7 version. Updated drivers, tried different preformance settings / different document sizes, updated my GPU and still nothing. GPU, CPU, disc etc in device manager works around 5% stress. Reinstaling, instaling beta version, nothing. I think that Designer is suited for specyfic types of PC configuration. Affinity Photo works smooth as butter :/

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.