Jump to content
fretn

Affinity Designer 1.8.1 destroyed my file

Recommended Posts

Affinity Designer 1.8.1 told me it could not save my file because of an internal error and that I should contact the developer.
I thought: no big deal, as I didn't really change anything. I closed affinity and double clicked my affinity file and then I saw
that the file was 0 bytes. Basicly Affinity Designer destroyed the file. I lost a lot of work. But it is my fault, I should have 
known better and take backups.
 
The mac just came back from sleep, Affinity Designer has been open sinds the 1.8.1 update,
never closed it, and that destroyed document was also open since then.
 
If you need more information to debug this issue, I'm heppy to help, I'm a developer myself so I have the technical skills to
provide you whatever you need to solve this issue.

PastedGraphic-1.png

Share this post


Link to post
Share on other sites

so I found a copy of my file (nothing is lost in the end).

But there is something wrong with that file, I can open it, but not save it, when I save it I get the same error as above and the original file is destroyed.

When I copy all contents of the file to a new Affinity Designer document, then I can save the file.

 

image.png.d8234c5d2d073d4754478124925b354c.png

Share this post


Link to post
Share on other sites

I am working on High Sierra + Designer 1.8.1, and I've noticed something similar.

If I do:

File>New>New Document - Presets - Print>A4

Then draw something, and Save it - everything works OK.

I can double click that file to open AD.

 

But, if do:

File>New>New Document - Presets - Architectural>Arch B

then draw something, and try to save it - Alert window opens: “Save failed due to internal error…”

Nevertheless, file is created in designated folder.

If I double click on that file to open AD, it crashes: “Affinity Designer quit unexpectedly.

 

Best Regards

Robert

 

 

Share this post


Link to post
Share on other sites

Hi @fretn,

Are you using Architectural Presets? If not, can you attach that document (not the 0b one) so we can have a look?

@Eramono Welcome to the forums and thanks for spotting this. I logged it with our developers. 

Share this post


Link to post
Share on other sites

We have made fixes/improvements to this area (Unable to save projects created with Architectural presets) of the program in the latest customer beta. If you would like to try these changes the beta software is available in the forum posts listed below.

The latest beta builds are downloadable from links at the top of each of these beta forum posts.

These betas install parallel, next to the release version (they do not overwrite your release) and so the fixes can be tried in the beta without affecting your normal workflow in the release version.

Once these programs have been through a full beta process the change will be released in a future free 1.8.1/1.8.2 update/patch to all customers.


Patrick Connor
Serif Europe Ltd

Latest releases on each platform 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.