Jump to content

Recommended Posts

In the latest release of Affinity Designer (1.8.0.585 ), Create Styles is not working.

When you right click and select 'create style'  nothing happens. When you select

'Add style from selection'  from the style panel, again nothing happens. 

Update: I tried some things as a work around. Currently a new style category can be 

created. I was able to add 'one' style to the  new category, but only one!  So 

currently it seems you can add a single style to a newly created 'style category', and you can 

create many style categories. This is only a work around, not the way it's supposed to work.

Share this post


Link to post
Share on other sites

Hi Steven Casey,

If a style already exists in a category then it is not possible to re-add it to that category. It sounds as though the style isn't being changed before you try to add another style. If the objects are being changed in-between trying to add them would you be able to get a screen recording of the process you're trying, along with any supporting files.
 

Thanks!

Share this post


Link to post
Share on other sites

Hi Sean,

Try this exercise , create a line style, say in a blue,  and add it. Change the colour to green, and then add it. Now change the colour to black 100% and try  adding it. This is what I observed, the styles created in colour will be added to the style panel. The black coloured line style will not be added. Also if you create a line style in any colour 'other than black 100%' you can add it more than once. 

In earlier version of Designer there was no issue adding custom line styles created with black 100%. I have only just discovered the issue was with black 100% outlines. I haven't tested fills.

Can you see if you  can duplicate my findings.

Thanks!

Share this post


Link to post
Share on other sites

I've posted a similar problem way back. I think it has something to do with the blavk coler and only stroke with no fill. The workaroun is to add a nother blank stroke under apearences menue. I've tryed to add multiple lines with different arrow heads and vas not able to, because apearently the style is based of color and weight of the stroke. But I could be wrong. 


OS Name    Microsoft Windows 10 Pro
Version    10.0.17134 Build 17134
System Type    x64-based PC
Processor    Intel(R) Core(TM) i7-7500U CPU @ 2.70GHz, 2904 Mhz, 2 Core(s), 4 Logical Processor(s)
Installed Physical Memory (RAM)    8.00 GB
Name    AMD FirePro (TM) W4190M

Share this post


Link to post
Share on other sites

Hi Rondem,

I tested your theory, and it proved to be correct. So more accurately if the line is black 100%, without fill ( normal ) , you cannot add the style to the style menu.

If you add a fill you can add the style..

And if you open the appearance menu and duplicate the line only, not the empty fill, you can add the style.

And if you uncheck the empty fill in the appearance menu, you can add the style.

So it's the black line with * no fill / normal * enabled that is the issue.

Thank you for the insight.

Still it shouldn't work that way.

Thanks,

Steve Casey

Share this post


Link to post
Share on other sites

Update:

In the stroke menu there is an "Order property"  with the option to "draw stroke in front" or "draw stroke behind". 

If you select 'draw stroke behind' it allows you to add a style, even if it has a black outline and no fill.

the following information is from Affinity Designer help.

  • "Draw stroke behind hides the inner half of the object's outline behind a closed shape—useful with very small objects or when shrinking outlined text. Draw stroke in front always reveals the whole line."

this insight was provided by a friend -  NIcolas Terry a fellow  origami enthusiast.

Previously there was no need to select that option, and it only seems to affect black outlines with no fill.

Share this post


Link to post
Share on other sites
On 3/1/2020 at 2:29 AM, Steven Casey said:

In the latest release of Affinity Designer (1.8.0.585 ), Create Styles is not working.

You probably updated Designer now - but several updates were released since that post:

image.png.a3c2b2191f7e6ac692e4d9e144a2bc2f.png

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.