Jump to content
lasscat

Affinity Photo 1.8 won't run up (split)

Recommended Posts

Affinity photo 1.7 was working great. I received the 1.8 update and now my program will not open. It crashes constantly. I've email Affinity but little help has been given. The program opens the logo, opens the background of the app but that's all, it never completes and crashes. Any ideas on how to fix this before I decide to uninstall and reinstall the original affinity software I purchase.

Share this post


Link to post
Share on other sites

Hi guys!

After the update (1.8) I was able to start the Photo App 2-3 times.
But now it crashes at every attempt to start.
I have tried at least 100 times!!

The same problem affects the Designer and Publisher app.
But after 5-10 attempts these Apps are working.

I also tried to deinstall and reinstall all Apps but the problem still exists. I also tried the Windows build in Reset and Repair function.

Bought and installed via the Windows Store.

Also the 1.7 Versions of all 3 Apps crashes quite often at start.

At the moment, working with these Apps is unfortunately not possible.  

System Info:
Older Version of HP Z400 Workstation
Windows 10 Pro 64bit Version 1909 with the latest updates.
Intel Xeon 3,07 GHz

 

Share this post


Link to post
Share on other sites

Hi Mark,

thanks for your quick reply.

Here are the reports (32) as a zip file, as well as the reports for the Designer and Publisher App.

Because the apps are installed via the Windows Store the reports were very hard to find.

I found the files in this location:

C:\Users\User\AppData\Local\Packages\SerifEuropeLtd.AffinityPhoto_xxx_xxx\LocalCache\Roaming\Affinity\Photo\1.0 (Store)\CrashReports\reports

maybe this helps someone else who is searching for them.

designer_reports.zip

hoto_reports.zip

publisher_reports.zip

Share this post


Link to post
Share on other sites
2 hours ago, nschall said:

Unfortunately I can't see any useful data in this crash dump. Do you have anything in %APPDATA%\Affinity\Photo\1.0 (Beta)\Log.txt ?

Share this post


Link to post
Share on other sites
6 minutes ago, nschall said:

Sorry , I realized just after I  uploaded it . I have uploaded the 1.8 Version with the next entry - sorry for that.

Norbert

7b1c507c-3f00-4787-806a-1fff0cd313ea.dmp 1.28 MB · 0 downloads 5f89cead-e2f0-4848-a8d2-157c390ccaf1.dmp 1.23 MB · 0 downloads

These are both the 1.8.1 beta crashes (similar to the other crash in 1.8.1, I can't see anything useful). Do you have a crash report for 1.8.0?

Share this post


Link to post
Share on other sites
3 hours ago, TOB said:

Because the apps are installed via the Windows Store the reports were very hard to find.

I found the files in this location:

C:\Users\User\AppData\Local\Packages\SerifEuropeLtd.AffinityPhoto_xxx_xxx\LocalCache\Roaming\Affinity\Photo\1.0 (Store)\CrashReports\reports

maybe this helps someone else who is searching for them.

designer_reports.zip 2.52 MB · 0 downloads photo_reports.zip 6.47 MB · 1 download publisher_reports.zip 3.73 MB · 0 downloads

Thanks, I've taken a look, but unfortunately like the other reports in this thread, I can't locate the source of the crash. I have a feeling it's related to loading specific fonts, so we may need to get in touch (tomorrow when tech support are back in the office) with regards to getting a list of your installed fonts etc.

Share this post


Link to post
Share on other sites

I have the same issue. 1.7 runs ok 99% of time. 1.8 ran a couple of times and now does not startup at all. I've save d the dump directy and attached it here.  Reinstalled 1.7 and its fine, excpet fo rthe constant noticiations that a new version is available.

Great program when it runs.

CrashReports.zip

Share this post


Link to post
Share on other sites

Hi!

As Mark mentioned, it could be a font problem, so I made some screenshots of the installed fonts on my PC. I guess most of them came with some software like the Lexmark printer driver or LibreOffice, … …

After nschalls post I also deleted all fonts I definitely don´t use.
(The red ones in the screenshot) I deleted even more like Asian, Arabic, … Fonts which came with Adobe. Also somewhere around 20 Noto Fonts. (I guess they came with Google Chrome) Unfortunately, not all of the deleted can be seen in the screenshot.

I also used Extensis Suitcase Fusion 6 for my Type1 Fonts.
But for 2-3 years, after a bigger Windows 10 update, it hasn´t worked as expected. So I deinstalled Suitcase Fusion to check if it causes any problems with Affinity.

I also use a second Typemanager www.fontba.se for all the other fonts.

After all those trial an error, the problem still exists. All three Affinity apps crash seconds after I start them. I can´t even open them.

At the start I see the Welcome Screen and the message “Schriften werden geladen…” (reading fonts…) and seconds after this font message disappears, the apps crash.

Interesting fact:

After I deleted the fonts which are marked red in the screenshot all Affinity apps worked as expected. But after a reboot of the system the problem still occurs and working is not possible.

font_list.zip

Share this post


Link to post
Share on other sites
7 hours ago, TOB said:

Hi guys!

Here are some new Crash Reports.

These are all made after I deinstalled Suitcase Fusion and all the fonts.

Maybe they differ from the reports before.

Tob

designer_reports.zip 2.2 MB · 0 downloads photo_reports.zip 5.99 MB · 0 downloads publisher_reports.zip 3.38 MB · 0 downloads

I can't get anything useful from these crash dumps. Could you try installing the latest beta and seeing if you still get the crash? If so, can you upload a dump from that?

It may be worth making a new post in the beta forum if so.

Share this post


Link to post
Share on other sites

@lasscat

Your post was split into it's own thread (this one). 

I saw your first post (last Friday) to the forum needed approval, and rather than add it to the original thread, I split it into it;s own independent thread here, in case the cause was different. 

As you see it got replies including one from Mark the head of Windows development.

Unfortunately I did not appreciate that when users have their posts split into new threads (like yours was) that those users did not automatically follow that new thread, so I doubt you received any of the notifications or replies. Sorry this was my fault. I have now added your name to the "Follow" list for this thread manually


Patrick Connor
Serif Europe Ltd

Latest releases on each platform 

 

Share this post


Link to post
Share on other sites
On 2/28/2020 at 9:57 PM, lasscat said:

Affinity photo 1.7 was working great. I received the 1.8 update and now my program will not open. It crashes constantly. I've email Affinity but little help has been given. The program opens the logo, opens the background of the app but that's all, it never completes and crashes. Any ideas on how to fix this before I decide to uninstall and reinstall the original affinity software I purchase.

Having the same issue - 

All worked fine until updating to v1.8 (Using Affinity Photo only; Windows 10 Pro with all the latest updates)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.