Jump to content
KyleCrotts

AD 1.8 Not Responding & Crashing (Windows)

Recommended Posts

Since i updated to 1.8 yesterday it has been an absolute nightmare using Designer. It constantly crashing or just stops responding. I was attempting to copy something from AD to APu and it just crashed every time. It seems to stop responding when i'm in the appearance panel. 

I using the Windows version.

Edit: I tried twice to combine multiple curves and it crashed both times. 1.8 is not usable

Edited by KyleCrotts
new information

Share this post


Link to post
Share on other sites
  1. I am using the latest version. Unless another version was released while I was sleeping. 
  2. I can reproduce the issue easily. Usually on multiple documents. Although the issue doesn’t always occur, it usually does or eventually will. 
  3. It happens on new documents as well as old documents.
  4. Freezing usually occurs when I am adjusting the fill color, in the appearance panel, of a curve object. Especially when adjusting the gradient fill of an object. 
    Freezing has also occurred while adjusting nodes of a curved object. I have also experienced freezing while creating an artboard from selected. And when un-grouping objects. Crashing occurs when I attempt to copy paste layers from AD to APu

With 90% of the issues I’d reopen the document, attempt again to do what I was trying to do , and The issue would occur again. 

I am using Windows 10. And it is up to date.

I expected AD not to freeze or crash and it did.

I'm using an external monitor, but that shouldn’t affect AD.

On previous versions of AD I had no such issues. Since upgrading to 1.8 I have had issue after issue and the software is basically unusable. 
 

Edit: I have uninstalled and reinstall AD and the issues still occurs.

Edited by KyleCrotts
New information added

Share this post


Link to post
Share on other sites

Can you attach a screen recording of this in action? We can't seem to replicate this here. 

On 2/28/2020 at 5:21 PM, KyleCrotts said:

Freezing has also occurred while adjusting nodes of a curved object. I have also experienced freezing while creating an artboard from selected. And when un-grouping objects. Crashing occurs when I attempt to copy paste layers from AD to APu

These are different issue, with different recipes. Can you please create a new post following that template for each of them so we can investigate them? 

Share this post


Link to post
Share on other sites
On 3/2/2020 at 6:34 AM, Gabe said:

Can you attach a screen recording of this in action? We can't seem to replicate this here. 

These are different issue, with different recipes. Can you please create a new post following that template for each of them so we can investigate them? 

This is a screen recording of the appearance panel freezing on a project. I don't want to spend the time making new posts for all of these issues, so let's just focus on this one as it seems to be the most common.

there's a part in the video that my cursor is just moving over icons and layers. I'm actually clicking on stuff, or at least trying to, but there no audio in the video so it might be hard to tell.

Share this post


Link to post
Share on other sites

To add to this, I have upgrade to this version today and it's become immediately obvious there's an issue with this build...

I too get crashes all the time. The current task I'm trying to complete is changing the fill colour of about 200 circles in bulk selects of about 30 at a time. If I bulk select and recolour (which has never been a problem for literally hundreds of objects at once) then it's an instant crash. I am now doing every single one individually 😞

I am going to have to uninstall this today and roll back.

  • Designer v1.8. 
  • Windows 10 v1909, build 18363.693
  • AMD Ryzen 5 1440 Quad 3.20GHz
  • 8GB RAM

Share this post


Link to post
Share on other sites
11 hours ago, KyleCrotts said:

This is a screen recording of the appearance panel freezing on a project. I don't want to spend the time making new posts for all of these issues, so let's just focus on this one as it seems to be the most common.

there's a part in the video that my cursor is just moving over icons and layers. I'm actually clicking on stuff, or at least trying to, but there no audio in the video so it might be hard to tell.

Thanks. This should be fixed in the latest beta: Affinity Designer Customer Beta build 1.8.1.610 for Windows 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.