Jump to content
Our response time is longer than usual currently. We're working to answer users as quickly as possible and thank you for your continued patience.

Supported Nik Collection plugins ? (split)


Recommended Posts

  • Moderators

Hi robert joseph bailey,
The plugin search folders section is pointing to the stand alone applications of the Nik Collection, not to the plugin files as it should. I believe you missed a step during the install where you have to create a folder to install these plugin files.

Please follow the instructions on this video. Pay attention to the section that starts at 0:40s where James click the "+" button to add a custom folder to where install the plugin files. This folder must be created manually by you. James has created it on his desktop and called it Plugins but I advise you to create the folder inside the Applications folder on your Mac and call it Photoshop Plugins (or whatever you see fit). Then, when you click the "+" button (as in the 0:40s in the video) point it to that folder you just created and continue following the rest of the instructions in the video. The Nik installer will create a new folder named/labelled DxO inside the folder you created - this is where all plugin files will be placed - and its the folder you have to browse to/add to the Plugin Search Folder section in Affinity Photo Photoshop Plugins Preferences.

Link to comment
Share on other sites

1 hour ago, MEB said:

Hi chakko007, 
Tick the checkbox on the bottom left of the Photoshop Plugins panel. Restart the app. Then all plugins should work including the ones marked as unknown (in yellow on the list).

Thank you. 👍

I take it that the plugins work anyway, even though the status is shown as "unknown"?

Link to comment
Share on other sites

  • Moderators

Yes, they will work despite the unknown status (this is an internal check). Quite a few plugins will display it. As long as you have the mentioned checkbox ticked they will be allowed to run.

Note that not all Photoshop plugins are compatible. Affinity Photo only supports basic image filters plugins. Anything else relying on Photoshop automation, file import/export formats etc will not work.

Link to comment
Share on other sites

3 hours ago, MEB said:

Hi robert joseph bailey,
The plugin search folders section is pointing to the stand alone applications of the Nik Collection, not to the plugin files as it should. I believe you missed a step during the install where you have to create a folder to install these plugin files.

Please follow the instructions on this video. Pay attention to the section that starts at 0:40s where James click the "+" button to add a custom folder to where install the plugin files. This folder must be created manually by you. James has created it on his desktop and called it Plugins but I advise you to create the folder inside the Applications folder on your Mac and call it Photoshop Plugins (or whatever you see fit). Then, when you click the "+" button (as in the 0:40s in the video) point it to that folder you just created and continue following the rest of the instructions in the video. The Nik installer will create a new folder named/labelled DxO inside the folder you created - this is where all plugin files will be placed - and its the folder you have to browse to/add to the Plugin Search Folder section in Affinity Photo Photoshop Plugins Preferences.

Thank you for your help. They now load and appear in the menus as the tutorial. Although they do not aappear to function correctly. Please see the three screen shots below.

All the shots are for Color Efex Pro 4.

This screen is the Nik application:

1379640168_Screenshot2020-02-27at17_57_17.thumb.png.4abc9005410deca8fd0164a4d42dfbcf.png

This screen is Affinity Photo:

Screenshot_2020-02-27_at_17_55_53.thumb.png.3babb8a51f543e6cd937c0a0e42d530e.png

This screen is the Nik plugin from within Affinity Photo

514077541_Screenshot2020-02-27at17_55_30.thumb.png.c4f5bebefba4d4515e2cff1cc3e547dc.png

Link to comment
Share on other sites

  • Moderators

Hi robert joseph bailey,
You must select the (correct) layer before launching the plugin. In your screenshot you have an empty/edited pixel layer selected, not the main background image layer (on the bottom of the layer's stack) which i assume is what you want to send to the plugin.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.