Jump to content

Recommended Posts

  • Moderators

Hi Greywizard,

Welcome to the forums :)

Please could you call up the run box by holding down the Windows key and tapping the letter R and then enter the following %temp% \AffinitySetup into the run box and click ok.  This should open a folder, with some other folders in.  Open the latest folder and there should be 2 log files, Setup.log and SetupUI.log. Please attach these two files to this thread so I can look int this further with you.

Thanks

C

Please tag me using @ in your reply so I can be sure to respond ASAP.

Link to post
Share on other sites

Hi Callum,

Problem solved in a roundabout way. I uninstalled each programme and then installed the new 1.8 updater with no problem. A bit of a nuisance, but it worked! Thanks. I assume the log files you ask for will reflect this fact. If not, of course I can send whatever you need.

Best,

Greywizard

Link to post
Share on other sites

Hi,

For your information, the setup affinity-photo-1.8.0.exe also crashed on my computer. I retried several times without success. Then, I tried to uninstall the previous version (affinity-photo-1.7.3) but was not able to find it in the list of installed softwares. I had to reboot my computer, reinstall affinity-photo-1.7.3 then reboot and install affinity-photo-1.8.0.exe to have no errors with the 1.8.0.585.

Kind Regards,
Franc

Link to post
Share on other sites

I had those problems all the last updates. 
This time I did the following. 
open program, -> download -> close -> remove icon from task list on side panel -> clicked on the .exe and it updated. The first time ever. I only changed that I released/removed the task list icon. 
(Runing windows 10)

Link to post
Share on other sites
On 2/27/2020 at 11:05 AM, andriko said:

I had those problems all the last updates. 
This time I did the following. 
open program, -> download -> close -> remove icon from task list on side panel -> clicked on the .exe and it updated. The first time ever. I only changed that I released/removed the task list icon. 
(Runing windows 10)

Are you saying that previously you tried to perform the update while the application was still running?

If so, yes, that would cause problems. The Affinity installers are not clever enough to detect that the application is already running and shut it down for you (Edit: unless they've been improved since the last time I tried that :) )

Edited by walt.farrell
Clarify installing while the app is running

-- Walt

Windows 10 Home, version 20H2 (19042.685),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop (2021-04-06):  32GB memory, Intel Core i7-10750H @ 2.60GHz
, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU
Affinity Photo 1.9.2.1035 and 1.9.4.1065 Beta   / Affinity Designer 1.9.2.1035 and 1.9.4.1065 Beta  / Affinity Publisher 1.9.2.1035 and 1.9.2.1024 Beta

Link to post
Share on other sites
32 minutes ago, KimRH said:

Hello!  I am experiencing the "setup failed" message when trying to update to 1.8.   I believe I encountered the same problem with the last update.   May I copy my log files to this thread for support?   Thank you!!!

Welcome to the Serif Affinity forms, Kim.

Feel free to upload your log files, but first I would suggest restarting Windows, and then right-clicking on the installer .exe file and choosing Run As Administrator, if you haven't tried that already.

-- Walt

Windows 10 Home, version 20H2 (19042.685),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop (2021-04-06):  32GB memory, Intel Core i7-10750H @ 2.60GHz
, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU
Affinity Photo 1.9.2.1035 and 1.9.4.1065 Beta   / Affinity Designer 1.9.2.1035 and 1.9.4.1065 Beta  / Affinity Publisher 1.9.2.1035 and 1.9.2.1024 Beta

Link to post
Share on other sites

Glad to hear it worked, Kim. Best wishes.

-- Walt

Windows 10 Home, version 20H2 (19042.685),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop (2021-04-06):  32GB memory, Intel Core i7-10750H @ 2.60GHz
, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU
Affinity Photo 1.9.2.1035 and 1.9.4.1065 Beta   / Affinity Designer 1.9.2.1035 and 1.9.4.1065 Beta  / Affinity Publisher 1.9.2.1035 and 1.9.2.1024 Beta

Link to post
Share on other sites

As I said, uninstalling the older version and then installing 1.8 from scratch worked for me. I tried Walt's method, but it didn't work, both the rebooting and running as administrator (in that order). It's worth noting that, when I first tried to install Photo, Photo was running, and the installer offered to shut it down for me, but then, once it was shut down, setup failed. So, at least for me, the installer was clever enough to recognise the programme as running, and shut it down. I didn't try Andriko's method, which sounds quite complex, and it is surprising that it worked (a bit like doing a sacred dance, though a very clever one), but it may contain a clue as to what is wrong when it doesn't install. Anyway, it's good to know that there are work-arounds for it, and good to see, too, that everyone is so helpful when problems arise.

Edited by Greywizard
Link to post
Share on other sites
On 2/27/2020 at 5:58 PM, walt.farrell said:

Are you saying that previously you tried to perform the update while the application was still running?

Hi, 
No no, I have the program closed after downloading the update-exe file. :).
I only unlocked the icon from my taskbar before I excecuted the exe.file. And that made it work for me opposed to all the other updates, where I struggled a lot. 
Everythins fine on my end :) 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.