Jump to content
Sign in to follow this  
Irmunsul

Affinity Publisher Closes without Error when opening afpub file

Recommended Posts

Hello,

I've just updated Affinity Publisher to version 1.8 and wanted to open some of my previously edited documents used for layouting an app's UI.

When I try to open (via file dialog, per drag & drop or double-clicking the file in Windows Explorer) the Publisher application opens up, shows the default empty interface (without an opened document) and closes again.
It does not provide any error messages or crash messages to me when this occurs and it is 100% consistent with one file I have.

Unfortunately I didn't looked up the version I've opened it with last but I assume it was 1.7.3 as I didn't get any update notifications for a longer time. The mentioned file contains several linked designer or publisher documents (if this might be important). If it helps I might provide the affected file and all related documents to you (via PM or mail etc.)

When I try to embed or link the mentioned file into a new empty document it works as expected and I can double click the embedded document and change it or even copy all elements into another new empty document.
I also tried to copy all elements to a new empty document and save it as a new file, which does not change the behaviour when opening the newly saved file as Publisher closes itself without displaying anything but the empty UI.

 

Best Regards

Tobias

Share this post


Link to post
Share on other sites

Hi Jon, 

I've just uploaded a zip archive with a file called "VW Robotation Academy.afpub" which is the main culprit.
The archive also contains some svg and other afpub and afdesigner (and an afassets file) Where the afdesigner files are opened normally as are some of the afpub documents in the "Controls" folder except the "Map List.afpub" document which behaves identically to the above mentioned document.

I'm not sure whether the problem might be related to the embedding and linking of other documents thus I've uploaded the whole bunch of files.

Thank you in advance for taking a look at this.

Share this post


Link to post
Share on other sites

Hi @Irmunsul,

The file opens fine for me, I've pm'd you a link to a resaved version of it that might hopefully resolve it for you.

Can you navigate to %appdata%/Affinity/Publisher and zip up and upload the 1.0 folder to the above link for me, it will contain crash reports that might shed some light on what's happening.

I also suspect if you rename the folders containing your linked resource and then re-linking them might help, let me know if it does.

Edit: Your crash reports seem to indicate it is related to some auto correct functionality


Serif Europe Ltd. - www.serif.com

Share this post


Link to post
Share on other sites

Hi @Jon P,

thank you for your fast response. I was afraid the file would work flawless on your side and I've checked your provided files and the "VW Robotation Academy.afpub" inside your archive opens fine on my machine now too.
The file "Controls/Map List.afpub" still fails but I assume you did not re-save that file specifically.

Might it be helpful if I uninstall Publisher and re-install it after removing everything from %AppData% or other user profile directories? Or should I stick with my current installation to prevent the state for further investigation of this issue?

Thank you for re-saving my main file again 😃 It helps me continue working on the project for now.

Share this post


Link to post
Share on other sites

I also have this problem. My files are relatively huge (magazines; too huge to share) and I do manage to repair them somehow, but it is evident that something is not ok with this new version (e.g. both version 1.7 as well as the latest beta 1.8 worked fine with my files). I have the impression that links (e.g. names without space???) and/or/in combi with preflight might cause the problem. I hope it will be solved (maybe I won't have to repair all previous issues:)) 

Share this post


Link to post
Share on other sites

Tip(???): I created an empty afpub wich I called 'start.afpub'. Once open I can also open other afpubs which crash if I do noit have start.afpub opened.

Share this post


Link to post
Share on other sites

@adbosch Thank you for your tip with an empty file beforehand. Doing so allowed me to update linked documents in my faulty files and re-save them which then allowed me to open them in publisher without having the empty file. I'm not sure what affected the ability to open them without error after re-save (I cannot tell whether it was only the re-save by itself with the newer version of the software or if the update of linked documents made any difference).

Share this post


Link to post
Share on other sites

I'm having this problem too trying to open multiple page docs fails as described, but opening a single page doc first then

the larger doc does work.  This is not just happening with one specific recent file but older docs from months back.

 

Share this post


Link to post
Share on other sites

@Pablo Feron and @Susanrh can you upload some of the problem files here, thanks

Quote

I'm having this problem too trying to open multiple page docs fails as described, but opening a single page doc first then

the larger doc does work. 

It's interesting this is working for a few people - if you save a problem document once it's opened does it then open fine on its own?


Serif Europe Ltd. - www.serif.com

Share this post


Link to post
Share on other sites

I moved a crash causing afpub file to a location where it would't find the links. It opened normally (with dialogue about unfound links which I exited with a 'no' ) and I saved it with a new name.  Copied this new afpub to the original directory and voilà: all cured.

I don't know if this works for all but it's worth a try.

Share this post


Link to post
Share on other sites

Thanks for the info, I've recovered a file for someone else doing a similar thing - I'm still looking into the cause, but glad it's fixed it for now.


Serif Europe Ltd. - www.serif.com

Share this post


Link to post
Share on other sites

I tried opening a file (open small doc then larger doc)  then saved larger doc.  Still won't open the larger doc on its own.

I have tried moving files and renaming them with the same result. 

 

Share this post


Link to post
Share on other sites

I have the same issue after upgrading to 1.8 on Windows 10.  I have tried opening the two most recent files I worked on in 1.7.3 and Publisher immediately crashes (that is, the file never gets opened at all).  The files are small.  There is a linked photo but it has not been modified recently, so my issue seems different than what someone else posted about.  I have attached one of the files.

David

mod_clefs_cover_v2.afpub

Share this post


Link to post
Share on other sites
On 2/27/2020 at 5:48 PM, adbosch said:

I moved a crash causing afpub file to a location where it would't find the links. It opened normally (with dialogue about unfound links which I exited with a 'no' ) and I saved it with a new name.  Copied this new afpub to the original directory and voilà: all cured.

I don't know if this works for all but it's worth a try.

I can confirm adbosch' workaround - These forums are tremendous! 


Lenovo laptop with Intel Core i7, 16 GB RAM, Windows 10 Home. Former user of most Serif software from PagePlus 3.0 through PagePlus X9, now enjoying Affinity Designer, Photo, and Publisher.

 

Share this post


Link to post
Share on other sites

I have just upgraded to 1.8.0.584 and my 80 page magazine crashed the Publisher program.

Using the, (open a blank document first) workaround I was able to open the magazine. It showed two warnings i.e. A changed linked item and a missing font.

I corrected both of these and now the magazine opens without crashing and now no need to open a Blank document first.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.