Jump to content

Recommended Posts

I'm on a Mac using the latest version of Publisher. In my toolbar neither the rectangle picture tool frame nor the ellipsis picture tool frame is available- they're both grayed out. What do I do?

Share this post


Link to post
Share on other sites

Welcome to the Serif Affinity forums.

Have you tried selecting one of them? I think they're supposed to be gray.


-- Walt

Windows 10 Home, version 1909 (183623.476),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop:  8GB memory, Intel Core i7-3625QM @ 2.30GHz, Intel HD Graphics 4000 or NVIDIA GeForce GT 630M
Affinity Photo 1.8.3.641 and 1.8.4.650 Beta   / Affinity Designer 1.8.3.641 and 1.8.4.650 Beta  / Affinity Publisher 1.8.3.641 and 1.8.4.651 Beta.

Share this post


Link to post
Share on other sites

@dchristman have you either opened a new document or an existing one?   On MAC those shapes are gray if no document is open on your canvas. They should be blue if s document is open.

Without a document opened (or new):

1397268110_ScreenShot2020-02-22at12_10_08PM.png.3c6a590c2b0c3fc8873e65ef2855872c.png

With a document opened (or new)

774434660_ScreenShot2020-02-22at12_09_51PM.png.6ba5db3ad303de266bbc01c0fab79fa1.png


21.5 iMAC Retina 4K display. MacOS Sierra v. 10.12.6 (which I am not changing).  3.1 GHz quad-core Intel Core i5, Turbo Boost up to 3.6 GHz.  Memory 8 GB 1867 MHz LPDDR3.  1TB Fusion Drive.  Intel Iris Pro Graphics 6200 1536 MB.   iPad Pro 12.9, iOS v. 12.3.1, Apple Pencil.  Affinity Publisher 1.8.3, Affinity Photo 1.8.3, Affinity Designer 1.8.3 

Magic mouse.9_9

Share this post


Link to post
Share on other sites

Perhaps a screenshot or two of what you’re seeing?
In the screenshots here, the first is how the Frame and other tools should look with no document loaded.
The second is how they look once a document has been loaded and with the Rectangular Frame tool being used.

265089889_Screenshot2020-02-22at01_10_43.png.6338bc51c76e7524add2b26a493739f6.png        424849661_Screenshot2020-02-22at01_12_07.png.ab4c03f079d56f1ab65da2deddf8785f.png

 


macOS 10.14.6  15" Macbook Pro, 2017  |  4 Core i7 3.1GHz CPU  |  Radeon Pro 555 2GB GPU + Integrated Intel HD Graphics 630 1.536GB  |  16GB RAM  |  Wacom Intuos4 M

Share this post


Link to post
Share on other sites

Hi @dchristman I really hope I'm not stating the obvious, but after you've clicked one of these tools, do you then draw out a shape? They don't work "instantaneously" like the Place Picture tool, and sometimes when using the dark interface option it can be a bit hard to detect that they've been clicked.

Again, sorry if you've already tried this.


Affinity Photo 1.8.3,  Affinity Designer 1.8.3, Affinity Publisher 1.8.3, Mac OSX 10.15, 2018 MacBook Pro 15"

Betas as they happen... 

Share this post


Link to post
Share on other sites
9 hours ago, dchristman said:

like the 2nd picture. Since I can't access them

Just because they're gray doesn't mean they're disabled. Unfortunately only inappropriate, and for some users confusing color icons.

 


Affinity Store: Affinity Suite (ADe, APh, APu) 1.8.3.
Windows 10 Pro, Version 1909, Build 18363.720.
Dell Latitude E5570, i5-6440HQ 2.60 GHz, 8 GB, Intel HD Graphics 530, 1920 x 1080.
Dell OptiPlex 7060, i5-8500 3.00 GHz, 16 GB, Intel UHD Graphics 630, Dell P2417H 1920 x 1080.
Intel NUC5PGYH, Pentium N3700 2.40 GHz, 8 GB, Intel HD Graphics, EIZO EV2456 1920 x 1200.

Share this post


Link to post
Share on other sites

Well- that's what I get for not poking around enough- that worked! It is obvious, but I've been "too well" trained by previous programs. In reply to jmwellborn: I had a doc open, but they weren't blue. TY for your help!

Share this post


Link to post
Share on other sites
3 hours ago, dchristman said:

Well- that's what I get for not poking around enough- that worked! It is obvious, but I've been "too well" trained by previous programs. In reply to jmwellborn: I had a doc open, but they weren't blue. TY for your help!

I wonder whether it has something to do with the MAC OS version I am on?   I am using Sierra 10.12.6.  Anyway, I edited my post above, to include screenshots. Glad you have it worked out!!


21.5 iMAC Retina 4K display. MacOS Sierra v. 10.12.6 (which I am not changing).  3.1 GHz quad-core Intel Core i5, Turbo Boost up to 3.6 GHz.  Memory 8 GB 1867 MHz LPDDR3.  1TB Fusion Drive.  Intel Iris Pro Graphics 6200 1536 MB.   iPad Pro 12.9, iOS v. 12.3.1, Apple Pencil.  Affinity Publisher 1.8.3, Affinity Photo 1.8.3, Affinity Designer 1.8.3 

Magic mouse.9_9

Share this post


Link to post
Share on other sites
1 hour ago, jmwellborn said:

I wonder whether it has something to do with the MAC OS version I am on?

Running Catalina (10.15) I can see the blue borders in Light UI mode but not in Dark UI, which is what the OP was using:

352311524_Screenshot2020-02-22at18_28_14.png.b5e9a2d95feef5fef8414a39f5c2ca22.png

The light borders in Dark UI don't change when the tools are selected.

“If Only You Knew The Power Of The Dark Side...”

 

 


Affinity Photo 1.8.3,  Affinity Designer 1.8.3, Affinity Publisher 1.8.3, Mac OSX 10.15, 2018 MacBook Pro 15"

Betas as they happen... 

Share this post


Link to post
Share on other sites

Thank you so much @h_d.  Thought perhaps I was losing my mind … or what is left of it!!  Dark Mode and I are at daggers drawn.


21.5 iMAC Retina 4K display. MacOS Sierra v. 10.12.6 (which I am not changing).  3.1 GHz quad-core Intel Core i5, Turbo Boost up to 3.6 GHz.  Memory 8 GB 1867 MHz LPDDR3.  1TB Fusion Drive.  Intel Iris Pro Graphics 6200 1536 MB.   iPad Pro 12.9, iOS v. 12.3.1, Apple Pencil.  Affinity Publisher 1.8.3, Affinity Photo 1.8.3, Affinity Designer 1.8.3 

Magic mouse.9_9

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.