Jump to content

Recommended Posts

Hi Affinity team,

 

I am unable to save any projects. this is the error message that I am getting: "Save failed due to an internal error. This should be reported to the development team."

Share this post


Link to post
Share on other sites

Welcome to the forums.
It will probably help the Affinity team to diagnose the problem if you can tell them as much information as possible:
* OS and version;
* Application version;
* Where you are trying to save the document to (internal hard drive, flash drive, cloud drive, etc.);
* Whether the file has been successfully saved previously, and was this to a different place or not?
The more information you can give the better the help you can get.

Share this post


Link to post
Share on other sites

Hi Neny,

If you answer GarryP's points above we should be able to help you with this further.

Thanks

C


Please tag me using @ in your reply to I can be sure to respond ASAP.

Share this post


Link to post
Share on other sites

I have this same problem. 

 

OS: Mac OS X 10.14 (Mojave)

Version: Designer 1.8.1

Location: On-disk. Tried Desktop and Dropbox folders. It creates a zero-byte file at the desired location. 

Saved previously: No, I started a new file. One artboard. 

Share this post


Link to post
Share on other sites

Having the same issue for Photo and Designer. Publisher seems to be fine. 

OS and version = MacOS Catalina (Version 10.15.3)
Application version = 1.8.1 for both Photo and Designer. 
Tried saving to = Google Drive, Desktop(+iCoud Drive) and Box with no success
New files not saved previously. New files started from your Arch D templates. 

Share this post


Link to post
Share on other sites

Interestingly, I also used the Arch D template when creating a new document. However, if I create a "Custom" doc using the settings on the right side of the New Document modal, I **AM** able to save. 

 

I just tried a smattering of random templates, and Arch D did *NOT* allow saving. Others did. 

Share this post


Link to post
Share on other sites

@Callum

I spent 2 mins on making a few tests in all of the programs and versions below:

Windows 10 Enterprise

  • Designer 1.8.0 release version
  • Designer 1.8.1.604 beta
  • Photo 1.8.0 release version
  • Photo 1.8.1.604 beta
  • Publisher 1.8.0 release version
  • Publisher 1.8.1.604 beta

What a rotten bit of luck: ALL files based on whatever template under the 'Architectural' tab cannot be saved, ever, same error:

image.png.fb1907f1f2c0e43bf6b6507e14a39fe9.png

image.png.4758645d075f6d9e77f4df50ef1c05bc.png

Share this post


Link to post
Share on other sites

So far I have only tested this in AD 1.8.1 on my Mac with a few of the Architectural presets, but not only do I get the 'failed to save' error & zero byte files, I also get a failure notice if I try to use File > Edit in Photo:

804196834_failedtolaunch.jpg.4b6c87066be2da68e3dbcfd0f4bd9c22.jpg


Affinity Photo 1.8.2, Affinity Designer 1.8.2, Affinity Publisher 1.8.2; macOS Mojave 10.14.6 iMac (27-inch, Late 2012); 2.9GHz i5 CPU; NVIDIA GeForce GTX 660M; 8GB RAM
Affinity Photo 
1.8.2.174 & Affinity Designer 1.8.2.4 for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 13.3.1

Share this post


Link to post
Share on other sites

Note that in another topic (Jowday's bug report), Patrick Connor provided a workaround until this can be fixed in the next beta:

View > Studio > Snapshot, add a snapshot, select it, then click the "new document from snapshot" icon.


-- Walt

Windows 10 Home, version 1909 (183623.476),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop:  8GB memory, Intel Core i7-3625QM @ 2.30GHz, Intel HD Graphics 4000 or NVIDIA GeForce GT 630M
Affinity Photo 1.8.2.620 and 1.8.3.628 Beta   / Affinity Designer 1.8.2.620 and 1.8.3.628 Beta  / Affinity Publisher 1.8.2.620 and 1.8.3.627 Beta.

Share this post


Link to post
Share on other sites
17 hours ago, Tony Christian said:

Hi, I'm Having the same issue:
Affinity Publisher 1.8.2
It was a file That I have been working for while, and suddenly that happen. And it crashed some times already.

Screen Shot 2020-03-25 at 17.48.53.png

Screen Shot 2020-03-25 at 17.55.49.png

Living_Fountais_or_Bronken_Cisterns_1-L.afpub 21.48 MB · 0 downloads Living Fountais or Bronken Cisterns 1-m ERROR.afpub 0 B · 0 downloads

What I am going to do now? I have to finish my work, but I cannot progress, because I can not same my changes!! Help me, please!!

Share this post


Link to post
Share on other sites
14 minutes ago, Tony Christian said:

What I am going to do now?

I downloaded your document and had no trouble making changes and saving. This may be due to the missing EPS file on Master C. Check that and maybe replace it.

Living_Fountais saved.afpub.zip


MacBook Pro (13-inch, Mid 2012) Mac OS 10.12.6 || Mac Pro (Late 2013) Mac OS 10.14.5

Affinity Designer 1.8.2 | Affinity Photo 1.8.2 | Affinity Publisher 1.8.2 | Affinity Designer Beta 1.8.x.x | Affinity Photo Beta 1.8.x.x | Affinity Publisher Beta 1.8.x.x

Share this post


Link to post
Share on other sites
18 hours ago, Tony Christian said:

Hi, I'm Having the same issue:
Affinity Publisher 1.8.2
It was a file That I have been working for while, and suddenly that happen. And it crashed some times already.

This topic is talking about a specific failure related to using the Architectural presets when creating a new document. Did you really use one of those for your Publisher document?

If not, it's probably not the same issue; just a similar one.

If you did use an Architectural preset, and you have Photo or Designer installed, perhaps you can use the same workaround I mentioned just above your post. Go to the Photo or Designer Persona, open the Snapshots studio panel, and add a new snapshot. Then see if you can Save your file.

I suppose, even if you didn't use an Architectural preset you could try that workaround.

Other than that, I can only suggest trying to Save As someplace else, in some different folder. And not one that has such a long path name. Also use a simpler file name.

And failing that, you might export it as a PDF file, which you could then Open later to recover much of your work.


-- Walt

Windows 10 Home, version 1909 (183623.476),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop:  8GB memory, Intel Core i7-3625QM @ 2.30GHz, Intel HD Graphics 4000 or NVIDIA GeForce GT 630M
Affinity Photo 1.8.2.620 and 1.8.3.628 Beta   / Affinity Designer 1.8.2.620 and 1.8.3.628 Beta  / Affinity Publisher 1.8.2.620 and 1.8.3.627 Beta.

Share this post


Link to post
Share on other sites

This is what I see when I open your document

1175007418_ScreenShot2020-03-26at9_39_48AM.png.9f0a13cfcc909d00aaadba48bf65cdf1.png

1869437782_ScreenShot2020-03-26at9_40_35AM.png.be04e26bdac5419c23183e9c7cf58026.png

EPS is a type of file Encapsulated Postscript.


MacBook Pro (13-inch, Mid 2012) Mac OS 10.12.6 || Mac Pro (Late 2013) Mac OS 10.14.5

Affinity Designer 1.8.2 | Affinity Photo 1.8.2 | Affinity Publisher 1.8.2 | Affinity Designer Beta 1.8.x.x | Affinity Photo Beta 1.8.x.x | Affinity Publisher Beta 1.8.x.x

Share this post


Link to post
Share on other sites
19 minutes ago, walt.farrell said:

This topic is talking about a specific failure related to using the Architectural presets when creating a new document. Did you really use one of those for your Publisher document?

If not, it's probably not the same issue; just a similar one.

If you did use an Architectural preset, and you have Photo or Designer installed, perhaps you can use the same workaround I mentioned just above your post. Go to the Photo or Designer Persona, open the Snapshots studio panel, and add a new snapshot. Then see if you can Save your file.

I suppose, even if you didn't use an Architectural preset you could try that workaround.

Other than that, I can only suggest trying to Save As someplace else, in some different folder. And not one that has such a long path name. Also use a simpler file name.

And failing that, you might export it as a PDF file, which you could then Open later to recover much of your work.

 Thank's @walt.farrell I didn't pay attention to that!  My is a different issue then, just having trouble to save a publisher file without Architectural presets, But I will try what you said and let you know if works! 

Share this post


Link to post
Share on other sites
5 minutes ago, Old Bruce said:

This is what I see when I open your document

1175007418_ScreenShot2020-03-26at9_39_48AM.png.9f0a13cfcc909d00aaadba48bf65cdf1.png

1869437782_ScreenShot2020-03-26at9_40_35AM.png.be04e26bdac5419c23183e9c7cf58026.png

EPS is a type of file Encapsulated Postscript.

Thank you, I did  replace that,  but still not working. It seems that is some change that I did in this last version, because my other versions that a save before I am able to save.

Share this post


Link to post
Share on other sites
1 hour ago, walt.farrell said:

This topic is talking about a specific failure related to using the Architectural presets when creating a new document. Did you really use one of those for your Publisher document?

If not, it's probably not the same issue; just a similar one.

If you did use an Architectural preset, and you have Photo or Designer installed, perhaps you can use the same workaround I mentioned just above your post. Go to the Photo or Designer Persona, open the Snapshots studio panel, and add a new snapshot. Then see if you can Save your file.

I suppose, even if you didn't use an Architectural preset you could try that workaround.

Other than that, I can only suggest trying to Save As someplace else, in some different folder. And not one that has such a long path name. Also use a simpler file name.

And failing that, you might export it as a PDF file, which you could then Open later to recover much of your work.

I tried, and that also didn't work. I realized that by going back to the previous version and making certain changes, then the problem occurs.

Share this post


Link to post
Share on other sites

Well, I download Old Bruce's file, and in the beginning, that could be saved, but after a while the same problem return. But It is interesting that even though this message of error appears, a file appears in the folder, saved, but when I try to open it, it will crash Publisher.Living Fountais SAVE 1-m.afpub.zip

Screen Shot 2020-03-26 at 16.34.27.zip

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.