Jump to content
Cybergooch

Drag and Drop into Affinity Photo?

Recommended Posts

The latest version of Affinity Photo would crash whenever I started it up. I did a search to see if anyone else was having the same problem, and it turns out starting the program in Administrator mode fixed the issue.

However, ever since I started running in admin mode, I can no longer drag images from explorer into Affinity Photo.

When I try to, I just see the black circle with a line through it as the cursor shape, Anybody know what causes this?

(Latest version of Photo in Windows 10)

Share this post


Link to post
Share on other sites

My guess is that it's some sort of Windows security measure to protect the system when you try to drop something onto a program that you have specifically run as administrator.

My recommendtion: Photo should not be crashing. Rather than finding a workaround and ignoring the crash, you should figure out what is causing the crash and fix that. I would start with the hints in this FAQ entry.

If those don't help, then I suggest you run Photo normally, collect the crash report, and start a new topic in the Photo Bugs forum to describe the problem and provide the crash report to Serif. For assistance in finding the crash report, you can refer to this FAQ entry.

 

 


-- Walt

Windows 10 Home, version 1909 (183623.476),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop:  8GB memory, Intel Core i7-3625QM @ 2.30GHz, Intel HD Graphics 4000 or NVIDIA GeForce GT 630M
Affinity Photo 1.8.3.641 and 1.8.4.650 Beta   / Affinity Designer 1.8.3.641 and 1.8.4.650 Beta  / Affinity Publisher 1.8.3.641 and 1.8.4.651 Beta.

Share this post


Link to post
Share on other sites

Thanks Walt, good idea.

I did some poking around for a while and was able to find out which 3rd party program was causing the trouble. It's Actual Windows Manager.

This is a program I've used for years, so apparently something has changed at some point. I could just exclude Affinity Photo from AWM, but was curious to find out what was going on. Apparently, it's actually the startup panel. (The popup panel that asks you what you want to do when you first start Photo.)

When I unchecked the box (so it doesn't come up anymore) Photo doesn't crash, even though it's still being affected by AWM. So I'll just leave that so it doesn't open.

Exactly the same thing was happening with Affinity Designer, and the same fix worked.

(And drag and drop is working again, yay!)

 

Share this post


Link to post
Share on other sites

Glad to hear it's working. :)

@Leigh: Possibly the 3rd-party software FAQ post should include Actual Windows Manager?


-- Walt

Windows 10 Home, version 1909 (183623.476),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop:  8GB memory, Intel Core i7-3625QM @ 2.30GHz, Intel HD Graphics 4000 or NVIDIA GeForce GT 630M
Affinity Photo 1.8.3.641 and 1.8.4.650 Beta   / Affinity Designer 1.8.3.641 and 1.8.4.650 Beta  / Affinity Publisher 1.8.3.641 and 1.8.4.651 Beta.

Share this post


Link to post
Share on other sites
1 hour ago, walt.farrell said:

Glad to hear it's working. :)

@Leigh: Possibly the 3rd-party software FAQ post should include Actual Windows Manager?

I'll see what I can do :) Leave it with me. Thanks @walt.farrell

Share this post


Link to post
Share on other sites

You're welcome, Leigh :)


-- Walt

Windows 10 Home, version 1909 (183623.476),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop:  8GB memory, Intel Core i7-3625QM @ 2.30GHz, Intel HD Graphics 4000 or NVIDIA GeForce GT 630M
Affinity Photo 1.8.3.641 and 1.8.4.650 Beta   / Affinity Designer 1.8.3.641 and 1.8.4.650 Beta  / Affinity Publisher 1.8.3.641 and 1.8.4.651 Beta.

Share this post


Link to post
Share on other sites
On 2/10/2020 at 7:29 PM, Cybergooch said:

The latest version of Affinity Photo would crash whenever I started it up. I did a search to see if anyone else was having the same problem, and it turns out starting the program in Administrator mode fixed the issue.

Is it possible to send me your Crash Reports so that I can look into this further? 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.