Jump to content

Recommended Posts

I've got a pattern of curves that is masked. I'm wondering if there is a way to more permanently trim off the ends of the curves that are masked, so I'd be left with shorter curves instead of masked long curves. This would help with export to other software that isn't handling masks well.

Screen Shot 2020-01-29 at 3.01.37 PM.png

Screen Shot 2020-01-29 at 3.01.52 PM.png

Share this post


Link to post
Share on other sites

Welcome to the forums.

One (not ideal) answer would be to:
* Select all the curves;
* Select the Node Tool;
* Press the “Join Curves” button on the Context Toolbar;
* Select the Move Tool;
* Select both the joined curves and the ‘cutter shape’;
* Choose menu “Layer → Geometry → Intersect” (or press the Intersect button on the Toolbar).
You can then break the remaining curves and delete the bits you don’t need.
My attached GIF shows the process before breaking and deleting.
It’s not a totally automatic process but it gets you part-way to what you want quite easily.

This might not be the best way so maybe someone else can give you a better workflow.

cutting-mask.gif

Share this post


Link to post
Share on other sites

Thanks Garry! After posting I was able to figure that way out, but I guess I was still holdin out hope that there’d be a more automated approach. I was using the merge curves command under geometry. Your way makes for a bit less cleanup afterward.

Edited by jiminyfickett

Share this post


Link to post
Share on other sites

Unfortunately I can’t think of a better way of doing it at the moment.
If/when we get a Knife Tool – or something similar, it’s been requested many times – then this sort of thing might become easier.

Share this post


Link to post
Share on other sites

Thanks for the idea! This was another way I tried, but then you're left with outlines of the curves. I need the curves themselves in this case. Is there a way to get the strokes back after you've expanded them? :4_joy:

Share this post


Link to post
Share on other sites

 To my knowledge no, I thought I had found a solution:

"Layer," "Geometry," "Separate Curves." 
Invert the colors (set the fill to "None" and the contour to black).
Set the line thickness to 0.
Reverse the colors again (set the fill to "Black").

But the result is the same, the outline is simply hidden. :(
 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.