Jump to content

Recommended Posts

Greetings to all, I've been using Affinity for two years, and something strange has happened to me today, I'm not sure if it's a mistake.

When you drag an image to the affinity canvas the images are placed in gray scales, but the original image is in color!

If I place the image from the panel, the same thing happens! either a png or jpge image is placed in gray scales, when the originals are in color, and I find no reason for it!

I would appreciate any comments!!

Captura de Pantalla 2020-01-21 a la(s) 11.25.04 p.m..png

Link to post
Share on other sites
  • Moderators

Hi Neloross,

I don't believe this is a bug, your placed image has a white fill applied which will turn it into a two tone image with the fill colour (white) and shade. If you click the small circle with a red line through it on the Colour Panel it will remove the white fill and return it back to the original colour.

Initially I had thought you'd saved the fill on an (Image) layer as a default, therefore every placed object would have the white fill. However I couldn't get this to occur and the fill was never saved as a default for an (Image) layer. Try going to Edit > Defaults > Factory Reset and see if that corrects it.

Is it just this document that is affected, or any new documents?

Link to post
Share on other sites

hi, SP.
Thanks for the prompt response

I did everything you write but the image does not change at all, I just realized that for the images in "PNG" and "screen fields" when you drag the image to the document it turns gray even if the image is in color , if you embed the image from the same panel it is added in grayscale.

and this happens for a new file as well as for an already made file

Also try converting the capture into a jpg file but it continues to become grayscale! I don't understand the logic for this!

I can color the image by changing the wheel on the panel, but it is not the original color of the image.

If you take a screenshot and drag it to any document, you will be able to see what I am talking about .... it is gray cove in a color image !!

Captura de Pantalla 2020-01-22 a la(s) 1.30.15 p.m..png

Link to post
Share on other sites
2 minutes ago, MikeW said:

¿El documento está configurado en escala de grises?

Si ese no es el problema, ¿subirías esta imagen?

not at all, the document is for rgb color or failing for cmyk printing ... I can upload the two images but any PNG you want to put or screenshot that I take adds them as grayscale

 

01111.jpg

Captura de Pantalla 2020-01-14 a la(s) 11.04.27 a.m..png

Link to post
Share on other sites

Looking at your video, @Neloross, the fill color is showing as white. I can see it briefly change to None (circle with red slash) but then it turns back to white. I'm not sure what you were doing that caused it to briefly change, nor to change back to white. But I would suggest that you try again to set the Fill for each of those images to None.

@MikeW: The New Document dialog in the video showed RGB/8 as the color format.

-- Walt

Windows 10 Home, version 20H2 (19042.685),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop (2021-04-06):  32GB memory, Intel Core i7-10750H @ 2.60GHz
, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU
Affinity Photo 1.9.2.1035 and 1.9.4.1065 Beta   / Affinity Designer 1.9.2.1035 and 1.9.4.1065 Beta  / Affinity Publisher 1.9.2.1035 and 1.9.2.1024 Beta

Link to post
Share on other sites
14 minutes ago, walt.farrell said:

Mirando su video, @Neloross , el color de relleno se muestra como blanco. Puedo verlo cambiar brevemente a Ninguno (círculo con barra roja) pero luego vuelve a ser blanco. No estoy seguro de lo que estaba haciendo que hizo que cambiara brevemente, ni que volviera a ser blanco. Pero le sugiero que intente nuevamente establecer el Relleno para cada una de esas imágenes en Ninguno.

@MikeW : El cuadro de diálogo Nuevo documento en el video mostró RGB / 8 como el formato de color.

how to do it? when I add the images the fill is in none, and if I give it fill it changes to the color that is selected .... it doesn't make sense to me ...

Link to post
Share on other sites
Hace 22 minutos, MikeW dijo:

¡Extraño!

¿Qué tal otra cosa? Intente cambiar de Adobe RGB a otro perfil RGB en un nuevo documento. No me imagino que funciona. Pero se me acabaron las ideas.

Comportamiento muy extraño, he cambiado el perfil muchas veces pero nada, ¡todavía me comporto de la misma manera!

If you take a screenshot and drag it to the document, do you color it? or it's just me with this problem

Edited by Neloross
Link to post
Share on other sites
44 minutes ago, Neloross said:

Comportamiento muy extraño, he cambiado el perfil muchas veces pero nada, ¡todavía me comporto de la misma manera!

If you take a screenshot and drag it to the document, do you color it? or it's just me with this problem

I've never experienced the issue you are having. I do not color the images...color images just come in properly. 

Link to post
Share on other sites
  • Moderators

I've just tried a new document using Adobe RGB (1998) with your image and it is placing fine for me. Do you still get the issue when creating a document using sRGB?

Have you used any form of colour management devices or calibrations on your machine? Can you go into the ColorSync Utility and go to 'Devices' and then expand the 'Displays' section and select your display and show a screenshot of that please? What sort of screen are you using to view your Mac on?

Link to post
Share on other sites
9 hours ago, Sean P said:

Acabo de probar un nuevo documento con Adobe RGB (1998) con su imagen y me está quedando bien. ¿Sigue teniendo el problema al crear un documento con sRGB?

¿Ha utilizado alguna forma de dispositivos de administración de color o calibraciones en su máquina? ¿Puede ingresar a la Utilidad ColorSync e ir a 'Dispositivos' y luego expandir la sección 'Pantallas' y seleccionar su pantalla y mostrar una captura de pantalla de eso, por favor? ¿Qué tipo de pantalla estás usando para ver tu Mac?

I don't think I have to see my mac's profile, since that would affect all programs, but it doesn't...

I leave you a capture where you can see that PSD opens it correctly, while any screenshot, affinity makes it a gray scale

Captura de Pantalla 2020-01-23 a la(s) 11.33.20 a.m..png

Captura de Pantalla 2020-01-23 a la(s) 11.29.13 a.m..png

Link to post
Share on other sites

The file in both your screengrabs and video clip are only displaying the blue channel rather than the full greyscale image which you can see when comparing the two.

comparison.jpg

Since everyone else who has viewed the files you've posted isn't experiencing the same issues, i.e. they appear in colour when opened, placed or dragged into Affinity Designer I'm wondering whether you may have a hardware/graphics card issue? Having said that I would have expected the thumbnails on your desktop and the Quickview to exhibit the same problem?

Questions

  1. The png file is interlaced for web use which means it hasn't been cropped and exported using Affinity Photo since as far as I'm aware AP doesn't provide an option to interlace png files on export. Was it created using Photoshop, GIMP or some other software?
  2. If you place the files in Apple Pages do they still appear in greyscale?
  3. Are you able to view the files on another mac running Affinity Designer, if so, do they appear correctly there?

 

Affinity Photo 1.7.3, Affinity Designer 1.7.3, Affinity Publisher 1.7.3

MacBook Pro 16GB, macOS Mojave 10.14.6

Link to post
Share on other sites
2 minutes ago, Neloross said:

??????

Apologies, when I hit Ctrl enter on my keyboard it posts the message automatically rather than adding space between numbered bullet points, I've edited my post now...

Affinity Photo 1.7.3, Affinity Designer 1.7.3, Affinity Publisher 1.7.3

MacBook Pro 16GB, macOS Mojave 10.14.6

Link to post
Share on other sites
1 hour ago, Hangman said:

El archivo tanto en las capturas de pantalla como en el videoclip solo muestra el canal azul en lugar de la imagen en escala de grises completa que puede ver al comparar los dos.

comparación.jpg

Dado que todos los que han visto los archivos que ha publicado no experimentan los mismos problemas, es decir, aparecen en color cuando se abren, colocan o arrastran en Affinity Designer. Me pregunto si puede tener un problema de hardware / tarjeta gráfica. ¿Habiendo dicho que hubiera esperado que las miniaturas en su escritorio y Quickview exhibieran el mismo problema?

Preguntas

  1. El archivo png está entrelazado para uso web, lo que significa que no se ha recortado y exportado usando Affinity Photo desde que tengo conocimiento de que AP no proporciona una opción para entrelazar archivos png en la exportación. ¿Fue creado usando Photoshop, GIMP o algún otro software?
  2. Si coloca los archivos en Apple Pages, ¿siguen apareciendo en escala de grises?
  3. ¿Puede ver los archivos en otra Mac que ejecuta Affinity Designer? De ser así, ¿aparecen correctamente allí?

 

It is not a graphics card or hardware problem, since this problem only affects affinity, if it were a problem of the aforementioned it would affect all programs and mac, but it is not a unique problem.

1. All the examples put in this thread were screenshots, in the examples it is specified that they are color screenshots, but AD does not recognize them in color, even if I open them directly in AP the same opens them in grayscale.

2.they appear in color, even if I open the screenshots, with another program either code editor, PSD, Illustrator, IND, open them in color ... but in affinity they do not follow in gray scales.

3. No idea, will someone from the forum take a screenshot and drag it to affinity or see if it is the same behavior or is it different ...

I emphasize, any screenshot I take, when opened in affinity, has this grayscale behavior, also png ... and I have no idea what may be happening.

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.