Jump to content
F_Z

Curve with arrow head gets rasterized in PDF export

Recommended Posts

Hi,

using Affinity Designer 1.7.3.481 on Windows 10 Education 1803.

When PDF-exporting a curve with an arrow head, the curve gets rasterized. It seems to be connected to having an arrow head, since the same object without arrow head does not get rasterized:

arrowPdfExport.pdf

I would expect the arrow-head curve to not get rasterized. Is this a bug? Does a workaround exist? I have also enclosed the afdesign file.

Regards

arrowPdfExport.afdesign

Share this post


Link to post
Share on other sites
1 minute ago, Joachim_L said:

Can confirm this weird behaviour / bug. To prevent rasterisation, remove the fill from the lines with the arrowhead.

Perfect, thanks a lot for this workaround!

 

Still, it would be great if this got fixed sooner or later.

Share this post


Link to post
Share on other sites

In Designer 1.8 beta (I have not tried 1.7), the Fill of both lines is white, though the lines display as black. The exact fill color is H:0, S:0, L: 92, and perhaps the saturation of 0 is acting something like having an Opacity of 0 and causing rasterization upon export due to the export settings and the need to rasterize transparent objects based on those settings.

I'm not sure why it only affects the line with the arrowhead.

Share this post


Link to post
Share on other sites
15 minutes ago, Sean P said:

In addition to the workaround Walt has said

Which workaround? As long as the line with the arrowhead has a fill - no matter what kind of fill - rasterisation is on.

Share this post


Link to post
Share on other sites
18 minutes ago, Joachim_L said:

Which workaround? As long as the line with the arrowhead has a fill - no matter what kind of fill - rasterisation is on.

Sorry I could have phrased that better. After Walt's finding removing the fill will allow it to export, which in the attached document's case will not change the look of the object.

Share this post


Link to post
Share on other sites
20 hours ago, Joachim_L said:

To prevent rasterisation, remove the fill from the lines with the arrowhead.

OK, I thought it was about Walt's assumption about opacity. ;)

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.