Jump to content
Dybkjær

Problem printing generated PDF with transparency

Recommended Posts

It is a well-known flaw of PDF that it does not print what you see if transparency is involved.

As I am using transparency in my drawings with AD, my question is if there are workarounds?

I would like this workflow: 1) Make a drawing in AD with multiple art boards. 2) Export that as PDF (for print, web, ...). 3) Print it, or send it to a printing company.

Notes: Please, do not say "Publisher", my computer is an iPad. My book printer only accepts PDF (in RGB only - but that is not the issue here).

What happens is illustrated in the two images below. The original TransparencyTest.afdesign as well as the generated PDF (for print) are also enclosed.

The dark image is the printed one. The other is a screen shot of the same PDF file and looks as intended. Clearly, PDF is not wysiwyg.

We look at this, back to front:

  1. The right side has an opaque, white rectangle in the very background.
    To make sure the problem is not a black default background.
    We see that is not the case, the right and left sides of the image look the same.
  2. The blue background is a gaussian blurred rectangle.
    Clearly PDF print handles the print wrongly.
  3. The 4 smaller snowflakes are embedded PNG which are transparent outside the actual snowflakes. 
    1. The layer of the two light grey ones are partially opaque.
    2. The dark grey ones are fully opaque.
  4. In front, white vector drawings and a bit of text.
    They look as they should.

Apparently, transparency through partial opaqueness works fine. The faulty darkness towards the boarder of the semi-opaque ones seems to be the wrong blur-darkness shining through.

Transparency from Gaussian blur fails. Is there a viable workaround?

Transparency of PNG fails. Is there a viable workaround?

Before you suggest that the printer or the driver are at fault, please try to print it on your own printer. Ι have tried to print from different computers and to different printers, all fails.

Best regards,

       Hans

TransparencyTest.pdf

A6792608-EDD6-4207-BAD1-A43D8CE56FB6.jpeg

6B76C488-47DF-4462-BE0C-BB03E5A94C5E.jpeg

TransparencyTest.afdesign

Share this post


Link to post
Share on other sites

Can you please confirm the model of your printer and are you printing directly from your iPad as when I print your PDF file or create a new one using the .afdesign file the print looks the same as onscreen and the PDF file

Share this post


Link to post
Share on other sites
Posted (edited)

I printed the above directly from the iPad (12.9" 2918, iOS 13.3). 

Thanks a lot for testing the print. That led me to test it on my wife's Windows computer, and on a 4-year old macbook (OS 10.13.6). Both places it prints fine.

Now I "only" need to figure out if it can be  printed directly from the iPad. It is inconvenient having to send it to another computer.

Also I will at times send a PDF to other people and I have previously experienced problems there (pre-Affinity Designer). Determining problem mostly is with the iPad or also partially with he PDF, would be useful.

Best,
   Hans

PS sorry, forgot the printer model: Canon Pixma 7250

Edited by Dybkjær
forgot info asked for

Share this post


Link to post
Share on other sites

iOS iPad and your test file using epson printer. Preview looks fine.

 

DF6649BF-560E-4C2F-B3E6-EB5029C681BD.png


IPad Pro 10.5/512GB   lpadOS 13.5.1   Affinity Photo 1.8.3 .180   Affinity Design 1.8.3.2 Publisher for iPad (2020?)

Share this post


Link to post
Share on other sites

Hi DM1, yes, the preview looks fine on my iPad, too. Which just means that the preview and the printer rendering are produced differently.

Note: I still wonder why Apple has not included a proper print dialog on the iPad, with all the detailed choices present on OS X and Windows.

Share this post


Link to post
Share on other sites

Prompted by inputs from Dwright and DM1 I tried more things:

  • Preview looks fine, print does not, from iPad.
  • Preview and print look fine from mac (OS X 10.13.6).
  • Printer Canon Pixma iP7250 has firmware 1.101. Newest firmware update is older, 1.070 (https://www.canon.dk/support/consumer_products/products/printers/inkjet/pixma_ip_series/pixma_ip7250.html?type=firmware).
  • The app Canon print inkjet/SELPHY has the same problem.
  • The Printer Pro app has the same problem.
  • I tested with each pdf export preset (actual prints, not preview as that is unreliable):
    • export: Wrong
    • flatten: The side with a white rectangle at the bottom is OK, the other side is wrong.
      Of course, flatten is a bitmap, so now text is blurry.
    • print: Wrong
    • web: Wrong
    • x1a: OK
      Nice, but X-1a is n old pdf format. I do not believe I can expect a book printer to accept this format.
    • x3: The partially opaque snowflakes and the gaussian blur are OK, the fully opaque flakes are wrong.
    • x4: The gaussian blur and one partially opaque snowflake are OK, the other three are wrong.
      I have no idea why there is this difference. Pairwise the snowflakes have the same properties. Even if I extend the white rectangle out under all the objects, the result is the same. 

The PDF/X format seems to state that the colour profile must be CMYK. I cannot see how this is expressed in the preset. I know that my printing company requires PDF with an RGB  colour profile, so I am not sure they would like to get CMYK. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.