Jump to content

Affinity Designer Canvas Turns to black sometimes

Recommended Posts


The canvas turns into black some times (Especially when zoom in + pan). When I zoom out, it becomes normal. Kindly have a look at the screenshot. And, I couldn't regenerate this issue. It sometimes happens (not frequently).


Note: I have all my drivers updated to the latest version.

Version: Affinity Designer

Operating System : Windows 10 Pro

CPU : Intel i3-4005U with Intel HD 4400 Graphics


Tablet : One by Wacom  (CTL-471)

Annotation 2020-01-02 151031.png

Link to comment
Share on other sites


I use graphic tablet only. I used to "pan" the canvas with MMB (assigned in pen). But, sometimes, the canvas freeze for a sec, while I pan the canvas (when zoomed in). Then the black screen appeared. When I zoomed out one step (with CTRL  -), the black screen disappeared. I face this issue every day three to four times. But, not frequently.

Link to comment
Share on other sites

Hi @Gabe,

I'm sorry, if my information was not clear. Please have a look at the screenshots. Hope you understand what I'm trying to say.

You could see the screen jump while dragging the canvas (issue.gif). It freezes for a second and a black screen overlaid on the canvas. And, when I zoomed out the black overlay disappears.

The "normal.gif" is just a comparison (I don't face this issue all the time).







Link to comment
Share on other sites

Go into

Edit > Preferences > Performance

and change Renderer to Warp

This will help determine if the problem is related to your graphics card

Things may run a little slower on Warp but use it for a while and report back if the problem still exists or has gone away

Due to the fact that Boris Johnson is now our Prime Minister, punctuation, spelling and grammar will never be worried about ever again.  We now have far bigger problems to be worried about.

Link to comment
Share on other sites

Hi @Gabe,

I changed the renderer settings to my dedicated GPU. It worked fine with no slow performance issues. Then, I did one more test with my Intel GPU. I uninstalled my display driver and reinstalled the latest driver. And I did a "reset user defaults" in affinity designer (CTRL+ launch AD).

Now it works fine with no issues on my Intel GPU.

Thank you @carl123 and @Gabe for your help and support.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.