Jump to content

Desinger Crash at StartUp without error message - Programm unusable

Recommended Posts

Design unuseable, programm starts and crashes immediately without error message. Photo and Publisher are working.

Newest Version just downloaded from the download center @affinity 1.7.3.xxx

It starts and the small loading windows open, then the big black windows starts and then it just closes without notification. This can be reproduced.

I can understand if something on my system (e.g. too many fonts or whatever is a problem for the designer, but I can not understand that it closes without even a single message, it's just gone as if I would have closed the program on my own :-(   )

Note: The last thing what was possible is that the program was always still asking me if I want to allow automatic crash reports, this question came up for 2 second and then the program crashes. I could even select it and it seems that the program kept the "auto crash report" settings as afterwards it did not ask for this anymore. Unfortunately, the program keeps crashing at the same point.

This is in my eyes a showstopper bus (at least for me ...) program can be used and without any kind of error message there is no way to debug it ...

Share this post

Link to post
Share on other sites

Hi sorry for the long time to reply, I'm quite busy and have very seldom time ti work with Designer or Photo stuff. It's more a hobby from time to time.

Strange enough the Designer suddenly started to work but in exchange Photo and Publisher stopped woprking with same behavior. (While it was the opposite befor, Designer did not work and both other did)

Renaming as suggested does not help. In my mind there must be some major bug inside, as there is not even an error message. The fact that the forum is not full of this however seems to be an indication that it has to do with my system (my be the high amount of fonts installed?). At the moment all 3 programs are unusable for me especially as I do not know which one will run stable if I want to do something. (as I was trying right know and suddenly realized that now Photo stopped starting). :-( :-( :-(

Version of all 3:





Any suggestion how to fix this would be very very welcome.

Share this post

Link to post
Share on other sites

Ok follow up here:

I started it roughly 10x at least photo started now the first time. After ~8x tries it suddenly asked me if want to enable the transfer of crash reports (it crashed befor this on the other tries at it seems). I said yes and it crashed again. Then restarted and it asked me again about the crash reports, I said yes again and it crashed again. Then restarted and now it was starting up. Very strange. So it seems one solution is just to keep trying. Never the less this sound then to be a kind of starnge race condition during start up?

I'll report back in here once it keeps crashing or if thumb restrating a dozens of time will solve the issue for the time beeing.

Share this post

Link to post
Share on other sites

I had the same issue a few days ago. Neither A. Design nor A. Photo could be opened. they both crashed right before opening.
None of the suggestions I found here worked. Believe me! I tried them all!
Finally, after reinstalling both and restarting my PC, I did the following and both worked!

Go to the program file location (not the shortcut), right click on it and in the menu select "Troubleshoot compatibility". Let the process run until you see a new pop-up. Choose "Try recommended settings" and "Test the Program" (the program will open without any problem). Do not close the program and go back to the pop-up. Click Next and choose  " Yes, save these settings for this program". Close the pop-up.
Just let me know, should you need further help. 😉

Share this post

Link to post
Share on other sites
On 12/18/2019 at 4:42 PM, Gabe said:

Hi @2good2stop,

Welcome to the forums. 

Try this: 

Navigate to %AppData%\Affinity\Designer\ and rename 1.0 to 1.0.backup. Re-open Designer and see if it's fine :)

I had this problem, too and this fixed it. Thanks!


Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.